View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0014758LazarusDatabasepublic2009-10-08 13:372011-12-01 11:24
ReporteralexP 
Assigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionwon't fix 
Platformfpc2.24OSwinxp32OS Version0.9.29 beta
Product VersionProduct Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0014758: error in buttons DBNavigator
Descriptionwhen you insert or edit command buttons DBNavigator refresh insert and delete are enabled as well as the first, prior, next and last. believe that the right would be to disable these buttons avoiding user error application. thanks
Tagsdbcontrols
Fixed in Revision
LazTarget0.9.30
Widgetset
Attached Filesdiff file icon dbnavigator - diff.diff [^] (1,941 bytes) 2009-10-09 04:03 [Show Content]
patch file icon dbnavigator.patch [^] (1,741 bytes) 2010-06-11 19:32 [Show Content]

- Relationships

-  Notes
(0031213)
alexP (reporter)
2009-10-09 04:04

I arranged a time and made some changes that worked well, follow the file for approval
(0038483)
samuel herzog (developer)
2010-06-11 19:34

I tested the changes from alexP and it seems to be ok.
Uploaded the patch-file again. (against current SVN).
(0038650)
Jesus Reyes (developer)
2010-06-19 21:07

I'm sorry, i think the intended behavior is not ok, or at least it looks it's a feature just some applications need.

Cursor buttons should not be disabled while editing, otherwise we would need a way to prevent the user to move to another record using mouse or keyboard (in a grid)

Deleting a non-inserted or even an editing record, it's not a bug and the same can be made with keyboard (in a grid)

In general features supported by underlaying dataset should not be artificially blocked, or if they must, then it's application specific behavior.

In case an application needs to customize what buttons are enabled (or visible, but for that there is a VisibleButtons property) the programmer can access protected DbNavigator's Buttons Field using an access (or crack) class, or at request we can modify DbNavigator to include easy access to Button's enabled property, in that case, please submit a feature request for it.

- Issue History
Date Modified Username Field Change
2009-10-08 13:37 alexP New Issue
2009-10-08 14:30 Vincent Snijders LazTarget => 1.0
2009-10-08 14:30 Vincent Snijders Status new => acknowledged
2009-10-08 14:30 Vincent Snijders Target Version => 1.0.0
2009-10-09 04:03 alexP File Added: dbnavigator - diff.diff
2009-10-09 04:04 alexP Note Added: 0031213
2009-10-09 08:38 Vincent Snijders LazTarget 1.0 => 0.9.30
2009-10-09 08:38 Vincent Snijders Assigned To => Jesus Reyes
2009-10-09 08:38 Vincent Snijders Status acknowledged => assigned
2009-10-09 08:38 Vincent Snijders Target Version 1.0.0 => 0.9.30
2010-03-15 03:04 Jesus Reyes Tag Attached: dbcontrols
2010-06-11 19:32 samuel herzog File Added: dbnavigator.patch
2010-06-11 19:34 samuel herzog Note Added: 0038483
2010-06-19 21:07 Jesus Reyes Status assigned => resolved
2010-06-19 21:07 Jesus Reyes Fixed in Version => 0.9.29 (SVN)
2010-06-19 21:07 Jesus Reyes Resolution open => won't fix
2010-06-19 21:07 Jesus Reyes Note Added: 0038650
2011-12-01 11:24 Marc Weustink Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker