View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0015291LazarusIDEpublic2009-12-08 18:202014-01-14 15:12
ReporterStephano 
Assigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version0.9.29 (SVN)Product Build 
Target Version1.4Fixed in Version 
Summary0015291: Switching desktops marks units/forms modified flag
DescriptionUbuntu 9.10
Launch lazarus in a desktop. Switch to another desktop then back. Units with forms will be marked with a '*'
TagsNo tags attached.
Fixed in Revision26005
LazTarget1.4
WidgetsetGTK 2
Attached Files

- Relationships
parent of 0017628confirmed Moving a form with the mouse does not set the modified flag 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0032949)
Vincent Snijders (manager)
2009-12-11 13:21

Maybe because of a window state change of the designer?
(0032988)
Stephano (developer)
2009-12-12 00:09

Desktop visual effects are set to Normal.
I tried setting them to None. Units are not marked as modified anymore.

It seems the horizontal forms motion as part of the desktop switching is the cause.
(0036268)
Zeljan Rikalo (developer)
2010-03-30 09:34

Can you retest with latest svn please ?
(0036279)
Stephano (developer)
2010-03-30 10:14
edited on: 2010-03-30 10:17

Problem still persists. Note that for the problem to show up, a unit must have its form visible in the IDE.

(0038418)
Zeljan Rikalo (developer)
2010-06-09 10:37

cannot reproduce your issue with Lazarus 0.9.29 r26005 FPC 2.4.1 i386-linux-gtk 2 (beta) so probably fixed in the meantime. Feel free to reopen if it's still reproducable.I've tested on Fedora 12 under KDE and GNOME (kwin & metacity).
(0038429)
Stephano (developer)
2010-06-09 12:28
edited on: 2010-06-10 08:29

Issue is still there
Lazarus 0.9.29 r26006M FPC 2.4.0 i386-linux-gtk 2 (beta)
Ubuntu 10.04 (gtk 2.20) / Visual effects: normal

I guess FPC 2.4.1 won't make a difference?

Edited: gtk 2.20

(0038431)
Zeljan Rikalo (developer)
2010-06-09 13:01

No, fpc version doesn't matter but gtk2 version or window manager can make such messy thing.FYI, I've just tested with gtk2-2.12 under KDE 3.5 and it works correct, so again - cannot reproduce here.
Since I'm not sure if I'm doing it correctly, please provide test project with your units, so I can check switching.
(0038444)
Stephano (developer)
2010-06-10 08:28

It is very easy to reproduce here:
Create a new project
Make sure form1 is visible
switch desktops and back
unit1 has a star next on its tab in the source editor

Notes:
- make sure that visual effect is "Normal" and not "None" (ubuntu). I am not sure how that translates to other distributions.
- Switching desktops is like a camera panning from one desktop to the other. In other words, you see all windows of the 1st desktop going sideways and disappearing while the new windows come to replace them. IIRC, visual effects "None" do not exhibit that panning effect.
(0038445)
Zeljan Rikalo (developer)
2010-06-10 09:22

@Stephano, I don't want to fix ubuntu's wm bugs or unexpected non-standard wm behaviour. Switching (virtual) desktops under X11 means: pager send minimize to all windows in previous desktop when switch to another one, and sends restore to all windows in current one while switching. What ubuntu does I don't know, but under FC12 cannot reproduce even with compiz + desktop cube switch.
(0038447)
Stephano (developer)
2010-06-10 11:34

Is desktop wall (viewport switching) enabled in compiz?

Rotate cube gives the same effect
(0038450)
Zeljan Rikalo (developer)
2010-06-10 14:20

don't know, cannot test now, since I have FC12 @home, here is FC3 so no fancy effects.
(0040694)
Zeljan Rikalo (developer)
2010-08-31 21:17

Reproduced under Fedora 13 , gtk-2.20, Gnome with compiz enabled.I suspect metacity+compiz for this issue.Note that lazarus qt shows same problem under this environment.Without compiz it works ok. Under KDE both works ok.
(0040771)
Stephano (developer)
2010-09-03 15:21

Any chance of getting it fixed?
(0040774)
Anton Kavalenka (reporter)
2010-09-03 18:10

Also Debian/GNU Linux Squeeze shows same behaviour.
Rotating the cube or switching desktops mark form-containg units modified.
Lazarus 0.9.30 SVN 27527
FPC 2.5.1
Gnome 2.30.2
(0040775)
Zeljan Rikalo (developer)
2010-09-03 18:17

@Stephano: Sorry I don't have enough time to fix such bugs. If someone provide patch or at least detailed investigation (so I can create patch and test in few hours) it will be fixed.
(0041805)
Stephano (developer)
2010-10-14 10:32

Resolution of bug http://bugs.freepascal.org/view.php?id=17625 [^] has resolved this bug, but introduced another related bug (http://bugs.freepascal.org/view.php?id=17628 [^])

Pls do not mark this issue as resolved until bug 0017628 is resolved without side effects.
(0056384)
Zeljan Rikalo (developer)
2012-02-04 13:21

Not blocker, postponed.

- Issue History
Date Modified Username Field Change
2009-12-08 18:20 Stephano New Issue
2009-12-08 18:20 Stephano Widgetset => GTK 2
2009-12-11 13:21 Vincent Snijders LazTarget => 1.0
2009-12-11 13:21 Vincent Snijders Note Added: 0032949
2009-12-11 13:21 Vincent Snijders Status new => acknowledged
2009-12-11 13:21 Vincent Snijders Target Version => 1.0.0
2009-12-12 00:09 Stephano Note Added: 0032988
2010-03-30 09:34 Zeljan Rikalo Note Added: 0036268
2010-03-30 09:34 Zeljan Rikalo Status acknowledged => feedback
2010-03-30 10:04 Flávio Etrusco (mantis doesn't notify me) Note Added: 0036276
2010-03-30 10:05 Flávio Etrusco (mantis doesn't notify me) Note Deleted: 0036276
2010-03-30 10:14 Stephano Note Added: 0036279
2010-03-30 10:16 Stephano Note Edited: 0036279
2010-03-30 10:17 Stephano Note Edited: 0036279
2010-06-09 10:37 Zeljan Rikalo Fixed in Revision => 26005
2010-06-09 10:37 Zeljan Rikalo Status feedback => resolved
2010-06-09 10:37 Zeljan Rikalo Resolution open => fixed
2010-06-09 10:37 Zeljan Rikalo Assigned To => Zeljan Rikalo
2010-06-09 10:37 Zeljan Rikalo Note Added: 0038418
2010-06-09 12:28 Stephano Note Added: 0038429
2010-06-09 12:28 Stephano Status resolved => assigned
2010-06-09 12:28 Stephano Resolution fixed => reopened
2010-06-09 13:01 Zeljan Rikalo Note Added: 0038431
2010-06-10 08:28 Stephano Note Added: 0038444
2010-06-10 08:29 Stephano Note Edited: 0038429
2010-06-10 09:22 Zeljan Rikalo Note Added: 0038445
2010-06-10 11:34 Stephano Note Added: 0038447
2010-06-10 14:20 Zeljan Rikalo Note Added: 0038450
2010-08-31 21:17 Zeljan Rikalo Note Added: 0040694
2010-09-03 15:21 Stephano Note Added: 0040771
2010-09-03 18:10 Anton Kavalenka Note Added: 0040774
2010-09-03 18:17 Zeljan Rikalo Note Added: 0040775
2010-10-14 10:32 Stephano Note Added: 0041805
2010-10-14 10:55 Vincent Snijders Relationship added parent of 0017628
2012-02-04 13:21 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-02-04 13:21 Zeljan Rikalo Note Added: 0056384
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2014-01-14 15:10 Martin Friebe LazTarget 1.2 => 1.4
2014-01-14 15:12 Martin Friebe Target Version 1.2.0 => 1.4



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker