View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0017813FPCDatabase Componentspublic2010-11-03 12:432012-04-20 20:26
ReporterMarcelo B Paula 
Assigned ToJoost van der Sluis 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionProduct Build 
Target Version2.6.1Fixed in Version2.7.1 
Summary0017813: Ability to create FieldsDef from Persistent Fields
DescriptionThe proposed patch solves 0016968.

Features:
- Expose published properties from parent.
- CreateDataset: Ability to create FieldsDef from Persistent Fields.
Additional Informationtested with Lazarus svn, fpc 2.5.1, i386-linux.
TagsNo tags attached.
FPCOldBugId0
Fixed in Revision20941
Attached Filesdiff file icon buffdataset.diff [^] (1,297 bytes) 2010-11-03 12:43 [Show Content]

- Relationships
duplicate of 0016967closedJoost van der Sluis FPC Persistent TField objects do not work with the Data Access palette related components 
related to 0016968acknowledgedJoost van der Sluis Lazarus TBufDataset component needs improvements at design time. 
related to 0008201assignedJoost van der Sluis FPC TField is missing protected procedure Bind(Binding: Boolean); virtual; 

-  Notes
(0047850)
Joost van der Sluis (developer)
2011-04-27 22:19

Fixed the published properties
(0049349)
Marcelo B Paula (reporter)
2011-06-23 23:19

The CreateDataSet part of this patch intend to be for Delphi compatibility.
If the Team understands that is not the case, is better to close this report and the related one.
A long time passed since this suggestion was posted.
(0057758)
Marco van de Voort (manager)
2012-03-17 12:14

I think the reason is more that fielddef used to be nothing more than a stub.
(0058801)
Joost van der Sluis (developer)
2012-04-20 16:03

I was not sure if it was a good idea to create a dataset based on field definitions at all.
(0058814)
Marcelo B Paula (reporter)
2012-04-20 20:26

The purpose was to be able to define fields properties, as editmasks, labels, displaylabels and of course navigate through the open dataset at design-time as Delphi does. By using the persistent fields, all these settings are stored at the stream file and are used as the form is loaded and the dataset is open. Just another RAD resource, instead of assigning all these methods at run-time.

Thank you.

- Issue History
Date Modified Username Field Change
2010-11-03 12:43 Marcelo B Paula New Issue
2010-11-03 12:43 Marcelo B Paula Status new => assigned
2010-11-03 12:43 Marcelo B Paula Assigned To => Joost van der Sluis
2010-11-03 12:43 Marcelo B Paula File Added: buffdataset.diff
2010-11-03 13:20 Jonas Maebe Relationship added related to 0016968
2011-04-27 22:19 Joost van der Sluis Note Added: 0047850
2011-05-03 23:04 Joost van der Sluis FPCOldBugId => 0
2011-05-03 23:04 Joost van der Sluis Summary TBUFDATASET improvements => Ability to create FieldsDef from Persistent Fields
2011-06-23 23:19 Marcelo B Paula Note Added: 0049349
2012-03-17 12:14 Marco van de Voort Note Added: 0057758
2012-03-17 12:14 Marco van de Voort Relationship added related to 0008201
2012-04-20 16:03 Joost van der Sluis Fixed in Revision => 20941
2012-04-20 16:03 Joost van der Sluis Status assigned => resolved
2012-04-20 16:03 Joost van der Sluis Fixed in Version => 2.7.1
2012-04-20 16:03 Joost van der Sluis Resolution open => fixed
2012-04-20 16:03 Joost van der Sluis Note Added: 0058801
2012-04-20 16:03 Joost van der Sluis Target Version => 2.6.1
2012-04-20 16:06 Joost van der Sluis Relationship added duplicate of 0016967
2012-04-20 20:26 Marcelo B Paula Status resolved => closed
2012-04-20 20:26 Marcelo B Paula Note Added: 0058814



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker