View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0019103LazarusOtherpublic2011-04-05 18:282012-09-11 14:39
ReporterAndrey Zubarev 
Assigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.9.31 (SVN)Product Build 
Target Version1.0.0Fixed in Version 
Summary0019103: TOpenGLControl issue (incorrect call InitWGL)
DescriptionGLWin32WGLContext.InitWGL procedure is called before creating the OpenGL context, so we get in it the values ​​(wglGetExtensionsStringARB, wglGetPixelFormatAttribivARB, etc.) are equal to nil
TagsOpenGL
Fixed in Revision37277
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

- Relationships

-  Notes
(0047255)
Andrey Zubarev (reporter)
2011-04-05 20:58

move call InitWGL to GLWin32WGLContext.LOpenGLMakeCurrent?
(0058131)
Alen (reporter)
2012-03-28 00:26

moving the call to GLWin32WGLContext.LOpenGLMakeCurrent does not work! Anyone found a fix?
(0058137)
Denis Golovan (reporter)
2012-03-28 08:25

Looks like something was broken recently.
Under Linux LOpenGLMakeCurrent crashes when calling glXMakeCurrent.
Tested under ATI opensource drivers + Mesa 8.0.1
(0058141)
Mattias Gaertner (manager)
2012-03-28 09:32

Please create a separate issue for the gtk backend.
(0058155)
Alen (reporter)
2012-03-28 18:10

Don't we have to load the extension via the GlExt unit?
(0060449)
Mattias Gaertner (manager)
2012-06-11 19:17

Is this still an issue?
The comments in InitWGL say it works.
(0060633)
Mattias Gaertner (manager)
2012-06-20 16:50

Probably fixed in the meantime.
(0062288)
Andrey Zubarev (reporter)
2012-09-11 14:27

Yes, now works. thanks.
(0062289)
Andrey Zubarev (reporter)
2012-09-11 14:27

fixed in 37277

- Issue History
Date Modified Username Field Change
2011-04-05 18:28 Andrey Zubarev New Issue
2011-04-05 18:28 Andrey Zubarev Widgetset => Win32/Win64
2011-04-05 18:31 Andrey Zubarev Tag Attached: OpenGL
2011-04-05 20:58 Andrey Zubarev Note Added: 0047255
2011-10-05 15:25 Vincent Snijders LazTarget => 1.0
2011-10-05 15:25 Vincent Snijders Assigned To => Mattias Gaertner
2011-10-05 15:25 Vincent Snijders Status new => assigned
2011-10-05 15:25 Vincent Snijders Target Version => 1.0.0
2012-03-28 00:26 Alen Note Added: 0058131
2012-03-28 08:25 Denis Golovan Note Added: 0058137
2012-03-28 09:32 Mattias Gaertner Note Added: 0058141
2012-03-28 18:10 Alen Note Added: 0058155
2012-06-11 19:17 Mattias Gaertner Note Added: 0060449
2012-06-11 19:17 Mattias Gaertner Status assigned => feedback
2012-06-20 16:50 Mattias Gaertner Note Added: 0060633
2012-06-20 16:50 Mattias Gaertner Status feedback => resolved
2012-06-20 16:50 Mattias Gaertner Resolution open => fixed
2012-09-11 14:27 Andrey Zubarev Note Added: 0062288
2012-09-11 14:27 Andrey Zubarev Status resolved => closed
2012-09-11 14:27 Andrey Zubarev Note Added: 0062289
2012-09-11 14:39 Mattias Gaertner Fixed in Revision => 37277



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker