View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0020094FPCUtilitiespublic2011-08-29 13:492014-03-06 10:22
ReporterHans-Peter Diettrich 
Assigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.5.1Product Build 
Target Version2.6.0Fixed in Version2.6.0 
Summary0020094: FPDoc creates bad link to fpdoc.css
DescriptionThe generated HTML files contain links to ../fpdoc.css, which does not exist in that location.
Steps To ReproduceLook at the rtl or lcl HTML documentation, where all lists (tables) have entries separated by much whitespace.

Now copy fpdoc.css from e.g. docs/html/fpdocs.css to docs/html/doc/fpdocs.css, and the excess whitespace disappears, because now the .css file is used.
TagsNo tags attached.
FPCOldBugId0
Fixed in Revision818
Attached Files

- Relationships

-  Notes
(0051335)
Marco van de Voort (manager)
2011-08-31 21:58

As far as I can see, when a CSSFILE= option is passed to the FPCDOC makefile, the cssfile is copied into the documents target directory.

Without it isn't.
(0051336)
Marco van de Voort (manager)
2011-08-31 21:59

Hans: please fill in operating system and provide information on where the archive you are testing is coming from.
(0051416)
Hans-Peter Diettrich (reporter)
2011-09-03 10:50

I'm working on the Lazarus LCL documentation, using build_lcl_docs.lpr on Win7.
As far as I can see, no CSSFILE is passed to fpdoc, but references to
../fpdoc.css are inserted into the HTML pages. I could not find any FPC supplied fpdoc.css?

Q: does it make sense to have an css file in *every* package directory?
Otherwise in a html/<package>/<module>/*.html directory structure a single html/fpdoc.css would make all pages look the same.

Now the real trouble: all tables in the HTML files have excess whitespace between the rows, which I could reduce once by copying the Lazarus supplied css file into the expected location - but now this procedure seems not to help any more. Graeme refers to http://opensoft.homeip.net:8080/tiopf/core/fpdoc.css, [^] and this css seems to remove the excess whitespace.


Here's a snippet from such an fpdoc generated table:

<h2>Declaration</h2>

Source position: controls.pp line 148


<table cellpadding="0" cellspacing="0">
<tr>
<td>

<tt><span class="code"><span class="kw">type </span>TAlign<span class="sym"> = </span><span class="sym">(</span></span></tt>

</td>
</tr>
<tr>
<td valign="top">

<tt><span class="code">  alNone<span class="sym">,</span></span></tt>

</td>
<td>

  

</td>
<td><p class="cmt">Control has fixed size and position

</td>
</tr>

I'm wondering why so many (empty) paragraphs are inserted into the rows?
(0051418)
Michael Van Canneyt (administrator)
2011-09-03 11:48

* fpdoc.css is now copied to rtl/fcl.
* Applied a fix from Graeme's css to remove whitespace
  (Cannot test, since my browser showed everything fine with the first one)
* you can refer to a custom .css location using the --cssfile=my_custom_file option.
* Please create separate bug reports for separate issues

- Issue History
Date Modified Username Field Change
2011-08-29 13:49 Hans-Peter Diettrich New Issue
2011-08-31 21:56 Marco van de Voort Status new => assigned
2011-08-31 21:56 Marco van de Voort Assigned To => Michael Van Canneyt
2011-08-31 21:58 Marco van de Voort Note Added: 0051335
2011-08-31 21:59 Marco van de Voort Note Added: 0051336
2011-08-31 21:59 Marco van de Voort Status assigned => feedback
2011-09-03 10:50 Hans-Peter Diettrich Note Added: 0051416
2011-09-03 11:48 Michael Van Canneyt Fixed in Revision => 818
2011-09-03 11:48 Michael Van Canneyt Status feedback => resolved
2011-09-03 11:48 Michael Van Canneyt Fixed in Version => 2.7.1
2011-09-03 11:48 Michael Van Canneyt Resolution open => fixed
2011-09-03 11:48 Michael Van Canneyt Note Added: 0051418
2011-09-03 11:48 Michael Van Canneyt Target Version => 2.6.0
2011-12-03 17:29 Marco van de Voort FPCOldBugId => 0
2011-12-03 17:29 Marco van de Voort Fixed in Version 2.7.1 => 2.6.0
2014-03-06 10:22 Michael Van Canneyt Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker