View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0020271FPCDatabase Componentspublic2011-09-16 09:142012-12-17 16:28
ReporterReinier Olislagers 
Assigned ToReinier Olislagers 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
Platformx64OSWindowsOS VersionVista
Product Version2.7.1Product BuildFPC git 16 September 2011  
Target Version2.7.1Fixed in Version2.7.1 
Summary0020271: [Patch] SimpleXML export: new test for fcl-db
DescriptionNew tests for FPC: Source\packages\fcl-db\tests\
that test SimpleXML export using:
1. Default settings
2. Custom settings using CSVFormatsettings.
Additional InformationThese tests demonstrate limitations in current code (ASCII/code page but no UTF8 support)

New files.

Please extract contents of simplexmlexporttest.zip - i.e.
xmlexporttest.lpi
xmlexporttest.lpr
xmlexporttestcase1.pas
into
Source\packages\fcl-db\tests\

Thanks.

I do realise the tests for dbf, csv, simplexml, xmlxsd export could be combined in a monster export test, but it might be an even better idea to incorporate it in the existing dbtestframework.

However, understanding how to work the db testframework to do the export tests for a large amount of different data in the datasets is a bit above the combination of (my skills+my interest in figuring it out), so in the meanwhile my motto is: a test (or 2) is better than no test.
TagsNo tags attached.
FPCOldBugId
Fixed in Revisionr23164
Attached Fileszip file icon simplexmlexporttest.zip [^] (6,135 bytes) 2011-09-16 09:14

- Relationships

-  Notes
(0059361)
Marco van de Voort (manager)
2012-05-07 19:23
edited on: 2012-05-07 19:23

So now you documented fcl-db's testframework we can expect a review of this one?

(0059364)
Reinier Olislagers (developer)
2012-05-07 20:28

@Marco: do you mean you want me to incorporate the tests above into the dbtestframework? Had a quick look; seems it can be done well enough.

I would however like to use some of the test data from this patch in the db test framework; that can e.g. be in the specific export test, but might also be useful for performing other tests on... but we can discuss that when/if I come to it ;)

Will try to rework this one to fit into the regular test framework.
(0059387)
Marco van de Voort (manager)
2012-05-08 12:21

I was just thinking what to do with this. Logically I lean towards one single testsystem, instead of multiple, and since you already hinted on integration that sounded logical.

That is not set in stone, if there are heavy reasons to not do it, let's hear it.
(0059391)
Reinier Olislagers (developer)
2012-05-08 13:54

I'll have a go; 2 things I'm thinking about:
1. Having enough variety in the field data to test export=>can be solved by adding some records in the test itself
2. Not all field types may be tested depending on which kind of dataset is tested. So be it, that's the point of testing in some sense. Current patch uses bufdataset so having bufdataset in database.ini would give the same effect.
Apart from that, I can't think of anything that would hinder integration.

This will take a while as I'm still busy with fpdatadict support for MSSQL etc but I suppose there's no terrible rush...
(0064354)
Reinier Olislagers (developer)
2012-12-17 16:28

Test was consolidated into new db export test unit

- Issue History
Date Modified Username Field Change
2011-09-16 09:14 Reinier Olislagers New Issue
2011-09-16 09:14 Reinier Olislagers Status new => assigned
2011-09-16 09:14 Reinier Olislagers Assigned To => Joost van der Sluis
2011-09-16 09:14 Reinier Olislagers File Added: simplexmlexporttest.zip
2012-03-17 13:31 Marco van de Voort Assigned To Joost van der Sluis => Michael Van Canneyt
2012-05-07 19:23 Marco van de Voort Note Added: 0059361
2012-05-07 19:23 Marco van de Voort Note Edited: 0059361
2012-05-07 20:28 Reinier Olislagers Note Added: 0059364
2012-05-08 12:21 Marco van de Voort Note Added: 0059387
2012-05-08 13:54 Reinier Olislagers Note Added: 0059391
2012-11-01 12:28 Reinier Olislagers Assigned To Michael Van Canneyt => Reinier Olislagers
2012-12-17 16:28 Reinier Olislagers Fixed in Revision => r23164
2012-12-17 16:28 Reinier Olislagers Status assigned => resolved
2012-12-17 16:28 Reinier Olislagers Fixed in Version => 2.7.1
2012-12-17 16:28 Reinier Olislagers Resolution open => fixed
2012-12-17 16:28 Reinier Olislagers Note Added: 0064354
2012-12-17 16:28 Reinier Olislagers Target Version => 2.7.1
2012-12-17 16:28 Reinier Olislagers Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker