View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0020311LazarusIDEpublic2011-09-21 14:082013-12-30 09:12
ReporterMark Morgan Lloyd 
Assigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.9.31 (SVN)Product Build 
Target Version1.2.0Fixed in Version 
Summary0020311: IDE always tailors "Target processor" options for Intel CPUs.
DescriptionThe "Options for Project" dialogue presents a "Target Platform" -> "Target Processor" dropdown for i386-family CPUs, even (a) when running on and generating code for a different family e.g. PowerPC and (b) a different family has been explicitly selected using the "Target CPU family" dropdown.
Additional Informationr32446 with 2.7.1 on Linux (Debian "Lenny" or later).
TagsNo tags attached.
Fixed in Revisionr42758 etc.
LazTarget1.2
Widgetset
Attached Files

- Relationships
related to 0020310closedJuha Manninen IDE always presents "Assembler style" even when not appropriate. 

-  Notes
(0056438)
Zeljan Rikalo (developer)
2012-02-04 14:12

Not blocked ,postponed
(0069987)
Juha Manninen (developer)
2013-09-12 22:23

r42758 improves this. The list of Intel processor types is shown only for i386 and x86_64. It is not fully right either, I am not sure which processors should be listed for x86_64. The list is empty for other CPUs.

I would need help filling the choices for other cases. See procedure
 TCompilerConfigTargetFrame.UpdateByTargetCPU
with a "case" statement. Please create a patch or just list the needed choices here.
(0069989)
Vincent Snijders (manager)
2013-09-12 22:51

The values you gave are only valid for i386, not for x86_64.

See fpc -h:
      -Cp<x> Select instruction set, see fpc -i for possible values
and fpc -i on x86_64:
Supported CPU instruction sets:
  ATHLON64
(0071521)
Mark Morgan Lloyd (reporter)
2013-11-23 19:12

This appears OK on PPC, can't test on SPARC due to issue 23703.

Is x86_64 still considered to be a problem? If not I think it can be closed.
(0071529)
Juha Manninen (developer)
2013-11-24 11:25

x86_64 was fixed back then. Thanks Vincent.

m68k and jvm are still empty.
(0072089)
Juha Manninen (developer)
2013-12-30 00:03

Resolving. m68k and jvm may not get any "Target Processor" choices.
(0072097)
Mark Morgan Lloyd (reporter)
2013-12-30 09:11

Hopefully the IDE displays a hint that anybody using it for those targets is welcome to contribute.
(0072098)
Mark Morgan Lloyd (reporter)
2013-12-30 09:12

Thanks for the good work.

- Issue History
Date Modified Username Field Change
2011-09-21 14:08 Mark Morgan Lloyd New Issue
2011-09-21 14:08 Mark Morgan Lloyd Widgetset => GTK 2
2011-10-07 15:13 Vincent Snijders Relationship added related to 0020310
2011-10-07 15:14 Vincent Snijders LazTarget => 1.0
2011-10-07 15:14 Vincent Snijders Status new => acknowledged
2011-10-07 15:14 Vincent Snijders Target Version => 1.0.0
2012-02-04 14:12 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-02-04 14:12 Zeljan Rikalo Widgetset GTK 2 =>
2012-02-04 14:12 Zeljan Rikalo Note Added: 0056438
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2013-08-07 11:22 Juha Manninen Assigned To => Juha Manninen
2013-08-07 11:22 Juha Manninen Status acknowledged => assigned
2013-09-12 22:23 Juha Manninen Note Added: 0069987
2013-09-12 22:23 Juha Manninen Status assigned => feedback
2013-09-12 22:51 Vincent Snijders Note Added: 0069989
2013-11-23 19:12 Mark Morgan Lloyd Note Added: 0071521
2013-11-23 19:12 Mark Morgan Lloyd Status feedback => assigned
2013-11-24 11:25 Juha Manninen Note Added: 0071529
2013-12-30 00:03 Juha Manninen Fixed in Revision => r42758 etc.
2013-12-30 00:03 Juha Manninen Note Added: 0072089
2013-12-30 00:03 Juha Manninen Status assigned => resolved
2013-12-30 00:03 Juha Manninen Resolution open => fixed
2013-12-30 09:11 Mark Morgan Lloyd Note Added: 0072097
2013-12-30 09:12 Mark Morgan Lloyd Note Added: 0072098
2013-12-30 09:12 Mark Morgan Lloyd Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker