View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0020476LazarusIDEpublic2011-10-13 07:482012-02-28 04:03
ReporterMarkus Müller 
Assigned ToJuha Manninen 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWin32OS VersionXP
Product VersionProduct Build32864 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020476: Cannot compile Lazarus !!!!
DescriptionI have load the snapshot "Lazarus-0.9.31-32864-fpc-2.7.1-20111013-win32.exe"

Then I wand install the zeos database component for this I must reicompile lazarus.
This version make a lazarus.exe where is 70% smaller ant the new generated EXE ist corrupt!

Lazarus.old.exe = 14149KB
Lazarus.new.exe = 6339KB
TagsNo tags attached.
Fixed in Revisionr32874
LazTarget0.99.0
Widgetset
Attached Filespng file icon Bild1.png [^] (14,779 bytes) 2011-10-13 08:14

- Relationships
has duplicate 0020498closedMaxim Ganetsky Lazarus doesn't start after rebuild 

-  Notes
(0052916)
Vincent Snijders (manager)
2011-10-13 08:02

How do you know that it is corrupt?

How did you recompile lazarus?
(0052917)
Alexander Shishkin (reporter)
2011-10-13 08:09

I have same problems. File is not corrupted, it in NOT lazarus.exe its lazbuild.exe somehow linked overwriting lazarus.
http://lists.lazarus.freepascal.org/pipermail/lazarus/2011-October/067821.html [^]
(0052919)
Markus Müller (reporter)
2011-10-13 08:13

Yes it is corrupt !!!

I load every week a new snapshot and includ here allways this one component.
I do always the same steps for install a new component, see Picture.
Then there comes the question "want you recompile lazarus" >> YES.

Then Lazarus works a minute and the EXE is corrupt and much smaller.

Then I have change the "Prfile to compile" from Debug IDE to Optimized IDE, there is the same result.

LAZARUS CRASH! No Error on compiling.
(0052920)
Markus Müller (reporter)
2011-10-13 08:17

Why cannot I see this Bugreport here:

http://bugs.freepascal.org/view_all_bug_page.php [^]

???
(0052921)
Juha Manninen (developer)
2011-10-13 09:03

Please test with r32866. You must do "make clean all" first and then build from the "Build Lazarus" dialog.
(0052922)
Markus Müller (reporter)
2011-10-13 09:16

Thank you very much, I load it tomorrow from here:
ftp://ftp.hu.freepascal.org/pub/lazarus/snapshots/ [^]
and test it again.
(0052923)
Alexander Shishkin (reporter)
2011-10-13 09:16

r32866 same error. lazarus is overwritten with lazbuild
(0052927)
Vincent Snijders (manager)
2011-10-13 09:38

@Markus Müller
> Why cannot I see this Bugreport here:

Probably because you still have the FPC project selected (you submitted this issue in the fpc project too) instead of the Lazarus project.
(0052928)
Markus Müller (reporter)
2011-10-13 09:46

OK, yes, you have right. My error. Now I see it.
(0052931)
Zoran Vučenović (reporter)
2011-10-13 11:25

I confirm this problem and it has nothing to do with fpc version, I use fpc 2.4.4 and when I try to compile Lazarus from IDE, it always happens. I downloaded fresh Lazarus from trunk — rev. 32867.
I experienced it now on Windows 7, but it happens on Windows XP too (I tried last evening at home on XP).
(0052940)
Flávio Etrusco (mantis doesn't notify me) (developer)
2011-10-13 16:10

This is a bit too much of/for a coincidence that this appeared just after Juha removed the 'examples' entry to avoid a similar problem, isn't it?
While we try to dig and debug it, can anybody provide a step-by-step how to reproduce it on a clean repository with a clean configuration folder?
(0052941)
Markus Müller (reporter)
2011-10-13 16:30

tomorrow, i try the next snapshot installation setup, clean the configuarion folder and test it again. I think it is the best way with the original setup.
(0052952)
Flávio Etrusco (mantis doesn't notify me) (developer)
2011-10-13 19:47

Markus, if you're not following the discussion in the mailing list: do you use an antivirus? Is your project folder in the exception list?
(0052953)
Markus Müller (reporter)
2011-10-13 20:08

Yes, I have Free-AV. I had no problem until now.
(0052960)
Juha Manninen (developer)
2011-10-13 22:39

I reverted the changes. Please test.
(0053010)
samuel herzog (developer)
2011-10-15 17:04

Rebuild does still not work.
Somehow the filenames get mixed up.
Lazbuild.exe becomes Lazarus.exe.

After some compiling and linking the lazarus ide gets restarted, but only the splash shows up and shortly I can see a dos console opens and closes.

When I start the new lazarus.exe from command line I get this output:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\lazarus>lazarus.exe

lazbuild [options] <project or package-filename>

Parameter:

--help or -? Diese Hilfeanzeige

-B or --build-all alle Dateien des Projekts/Packages/IDE kompilieren
-r or --recursive Build-Flag (-B) auf für die Abhängigkeiten setzen
-d or --skip-dependencies Abhängigkeiten nicht kompilieren
--build-ide=<options> IDE mit allen Packages kompilieren
-v or --version Version anzeigen und Ende

--primary-config-path=<path>
or --pcp=<path>
                      primäres Konfigurationsverzeichnis in dem Lazarus
                      seine Konfigurationsdateien speichert.
                      Voreinstellung istC:\Dokumente und Einstellungen\sam.STRT\
Lokale Einstellungen\Anwendungsdaten\lazarus

--secondary-config-path=<path>
or --scp=<path>
                      sekundäres Konfigurationsverzeichnis in dem
                      Lazarus nach Vorlagendateien sucht. Voreinstellung
                      istC:\lazarus

--operating-system=<operating-system>
or --os=<operating-system>
?berschreibt das Betriebssystem des Projekts, z.B. win32, linux.
                      Voreinstellung:

--widgetset=<widgetset>
or --ws=<widgetset>
                      Überschreibt das Widget-Set des Projekts. Z.B.
                      GTK, GTK2, Qt, Win32, Carbon. Voreinstellung: win32

--cpu=<cpu>
                      überschreibt die Projekt-CPU, z.B. i386, x86_64,
                      powerpc, powerpc_64 usw. Voreinstellung: i386

--build-mode=<project build mode>
or --bm=<project build mode>
ebt den Projekt-Erstellmodus auf

--compiler=<ppcXXX>
                      überschreibt den voreingestellten Compiler, z.B.
                      ppc386, ppcx64, ppcppc etc. Die Voreinstellung ist
                      in environmentoptions.xm abgelegt

--language=
                      Sprache überschreiben. Beispielsweise
                      --language=de. Für die möglichen Werte siehe die
                      Dateien im Verzeichnis »languages«.

--create-makefile
                      Instead of compile package create a simple Makefile.
Heap dump by heaptrc unit
130714 memory blocks allocated : 295138538/295620536
130714 memory blocks freed : 295138538/295620536
0 unfreed memory blocks : 0
True heap size : 2490368 (80 used in System startup)
True free heap : 2499344
Should be : 2490288

C:\lazarus>
(0053014)
samuel herzog (developer)
2011-10-15 17:05

Sorry, this issue is not resolved.
(0053015)
Maxim Ganetsky (developer)
2011-10-15 17:45

@Samuel: I can't reproduce it. Lazarus 0.9.31 r32906M FPC 2.5.1 i386-win32-win32/win64, Windows XP SP3.
(0053016)
samuel herzog (developer)
2011-10-15 17:59

A) "Tools"->"Configure Build Lazarus" and check "Clean+Build" and "Clean all".
B) Pressed Button "Build" in the "Configure Build Lazarus" dialog.
(0053020)
Juha Manninen (developer)
2011-10-15 18:16

I can't reproduce either.
Please try with "make clean all" and then later use "Configure Build Lazarus" dialog.
(0053024)
samuel herzog (developer)
2011-10-15 18:27

@Juha: How to do "make clean all". Is this in the lazarus IDE or from commandline ?

I searched my harddisks for all folders named "lazarus" and deleted them.
Then I ran a registry cleaner.
The I downloaded the daily snapshot Lazarus-0.9.31-32864-fpc-2.5.1-20111013-win32.exe and installed it. (by the way, there is no snapshot from 20111014). Problem happends!
The I saw that you mention svn 32867 should fix the problem, but my daily snapshot has 32864. So I did a svn checkout over my existing lazarus-folder and tried again. So I am now at 32907. Problem is still the same.
(0053026)
Maxim Ganetsky (developer)
2011-10-15 18:53

> How to do "make clean all". Is this in the lazarus IDE or from commandline ?

Of course from command line.

Execute it from Lazarus directory and then run newly built IDE and try if rebuild works as Juha wrote.
(0053028)
Juha Manninen (developer)
2011-10-15 20:57

> So I am now at 32907. Problem is still the same.

r32907 should be OK. Works well here.

Juha
(0053033)
lainz (reporter)
2011-10-15 22:57

When I try to compile this file is missing:
{$I staticpackages.inc}

in lazarus.pp

fpc2.4.4 lazarus r32914


C:\FPC\laz\ide\lazarus.pp(59,4) Fatal: Can't open include file "staticpackages.inc"
(0053034)
Juha Manninen (developer)
2011-10-15 23:49

lainz, please try "make clean all".
(0053036)
lainz (reporter)
2011-10-16 01:57

Yes it's working.
(0053037)
samuel herzog (developer)
2011-10-16 08:15

I will re-test as soon as the daily snapshots are working again. They are still stuck on the 13.Oct.
(0053040)
Juha Manninen (developer)
2011-10-16 09:51

samuel herzog, I make a wild guess:
"make clean all" does not work for you because the Delphi's version of "make" is called and it is not compatible.
You can rename or delete it. You don't typically need it with Delphi either.
(0053055)
Maxim Ganetsky (developer)
2011-10-16 16:56

This bug is fixed.

@Samuel: please solve your problems with your build configuration. Also I don't understand why you are waiting for snapshots when you already have fresh revision checked out from SVN.
(0053104)
samuel herzog (developer)
2011-10-17 20:21

I search the WIKI how to do "make clean all" but did not find it.
Does someone have a link for me ?

@Maxim: I almost do daily a svn update and then recompile the whole stuff from Lazarus IDE menu. It worked fine until some days ago. The daily-snapshots on the lazarus page also stopped. So I still believe it's not just a problem on my computer.
(0053105)
Juha Manninen (developer)
2011-10-17 20:37

> how to do "make clean all"

Open a command prompt. "cd" to lazarus root directory. Type "make clean all" and hit Enter.
If you get lots of errors, see my earlier note about Delphi's version of "make".
(0053106)
Vincent Snijders (manager)
2011-10-17 20:41

The daily snasphots compile fine, but they fail to upload, due to a broken network connection. If I have time, I will try to replace pscp with rsync and retry until succeeded.
(0053107)
samuel herzog (developer)
2011-10-17 21:23
edited on: 2011-10-17 21:24

Ok, I opened a command line in "c:\lazarus\" and typed "make clean all".
The message "unknown command "make"" is shown.

So I added C:\lazarus\fpc\2.5.1\bin\i386-win32 to my environment path variable:

c:\path=%path%;C:\lazarus\fpc\2.5.1\bin\i386-win32

After this step "make clean all" worked fine and I get a correct lazarus.exe file.
I started then the new Lazarus version (Lazarus 0.9.31 r32949 FPC 2.5.1 i386-win32-win32/win64) and did again the same test like always:

A) "Tools"->"Configure Build Lazarus" and check "Clean+Build" and "Clean all".
B) Pressed Button "Build" in the "Configure Build Lazarus" dialog.

Still the same problem. The lazarus.exe is in fact then the lazbuild-tool.

(0053108)
Maxim Ganetsky (developer)
2011-10-17 22:20

This revision works correctly for me. Make sure that you rebuild with it, not with old revision.
(0053116)
Markus Müller (reporter)
2011-10-18 07:51
edited on: 2011-10-18 07:58

@ all Developers:

Do another test:

1) Delete all your System
2) Reinstall Windows XP (Virtual Machine?)
3) go to ftp://ftp.hu.freepascal.org/pub/lazarus/snapshots/ [^] and load the setup
4) Install it
5) Do not set any environment variable manually
6) make a Rebuild from lazarus

... please.

PS: I cannot load the newest snapshot for Win32. The file there is old. ?

(0053117)
Vincent Snijders (manager)
2011-10-18 08:19
edited on: 2011-10-18 08:22

Why do another test with old (= not yet updated after the fix) snapshots?

(0053118)
Markus Müller (reporter)
2011-10-18 08:26

If it is fixed, thenn all is ok. Now, I cannot test it. I wait for the new Snapshot and write the result.
(0053141)
samuel herzog (developer)
2011-10-19 06:57

I have downloaded and installed Lazarus-0.9.31-32951-fpc-2.5.1-20111018-win32.exe and now it works fine!

Thank you all.
(0053172)
Markus Müller (reporter)
2011-10-19 18:40
edited on: 2011-10-19 18:41

I have test it with "Lazarus-0.9.31-32953-fpc-2.7.1-20111018-win32.exe".
Now it works. Thank you, too.


- Issue History
Date Modified Username Field Change
2011-10-13 07:48 Markus Müller New Issue
2011-10-13 08:00 Vincent Snijders Project FPC => Lazarus
2011-10-13 08:02 Vincent Snijders LazTarget => 0.99.0
2011-10-13 08:02 Vincent Snijders Note Added: 0052916
2011-10-13 08:02 Vincent Snijders Assigned To => Juha Manninen
2011-10-13 08:02 Vincent Snijders Status new => feedback
2011-10-13 08:02 Vincent Snijders Target Version => 0.99.0
2011-10-13 08:09 Alexander Shishkin Note Added: 0052917
2011-10-13 08:13 Markus Müller Note Added: 0052919
2011-10-13 08:14 Markus Müller File Added: Bild1.png
2011-10-13 08:17 Markus Müller Note Added: 0052920
2011-10-13 09:03 Juha Manninen Note Added: 0052921
2011-10-13 09:16 Markus Müller Note Added: 0052922
2011-10-13 09:16 Alexander Shishkin Note Added: 0052923
2011-10-13 09:38 Vincent Snijders Note Added: 0052927
2011-10-13 09:46 Markus Müller Note Added: 0052928
2011-10-13 11:25 Zoran Vučenović Note Added: 0052931
2011-10-13 16:10 Flávio Etrusco (mantis doesn't notify me) Note Added: 0052940
2011-10-13 16:30 Markus Müller Note Added: 0052941
2011-10-13 17:21 Alexander Shishkin Note Added: 0052944
2011-10-13 17:24 Alexander Shishkin Note Edited: 0052944
2011-10-13 17:25 Alexander Shishkin Note Edited: 0052944
2011-10-13 17:30 Alexander Shishkin Note Deleted: 0052944
2011-10-13 19:47 Flávio Etrusco (mantis doesn't notify me) Note Added: 0052952
2011-10-13 20:08 Markus Müller Note Added: 0052953
2011-10-13 22:39 Juha Manninen Fixed in Revision => r32874
2011-10-13 22:39 Juha Manninen Status feedback => resolved
2011-10-13 22:39 Juha Manninen Resolution open => fixed
2011-10-13 22:39 Juha Manninen Note Added: 0052960
2011-10-15 17:04 samuel herzog Note Added: 0053010
2011-10-15 17:05 samuel herzog Note Added: 0053014
2011-10-15 17:05 samuel herzog Status resolved => confirmed
2011-10-15 17:45 Maxim Ganetsky Note Added: 0053015
2011-10-15 17:45 Maxim Ganetsky Status confirmed => feedback
2011-10-15 17:59 samuel herzog Note Added: 0053016
2011-10-15 18:16 Juha Manninen Note Added: 0053020
2011-10-15 18:27 samuel herzog Note Added: 0053024
2011-10-15 18:53 Maxim Ganetsky Note Added: 0053026
2011-10-15 20:57 Juha Manninen Note Added: 0053028
2011-10-15 22:57 lainz Note Added: 0053033
2011-10-15 23:49 Juha Manninen Note Added: 0053034
2011-10-16 01:57 lainz Note Added: 0053036
2011-10-16 08:15 samuel herzog Note Added: 0053037
2011-10-16 09:51 Juha Manninen Note Added: 0053040
2011-10-16 16:56 Maxim Ganetsky Status feedback => resolved
2011-10-16 16:56 Maxim Ganetsky Fixed in Version => 0.9.31 (SVN)
2011-10-16 16:56 Maxim Ganetsky Note Added: 0053055
2011-10-17 20:21 samuel herzog Note Added: 0053104
2011-10-17 20:37 Juha Manninen Note Added: 0053105
2011-10-17 20:41 Vincent Snijders Note Added: 0053106
2011-10-17 21:23 samuel herzog Note Added: 0053107
2011-10-17 21:24 samuel herzog Note Edited: 0053107
2011-10-17 22:20 Maxim Ganetsky Note Added: 0053108
2011-10-17 22:29 Maxim Ganetsky Relationship added has duplicate 0020498
2011-10-18 07:51 Markus Müller Note Added: 0053116
2011-10-18 07:54 Markus Müller Note Edited: 0053116
2011-10-18 07:57 Markus Müller Note Edited: 0053116
2011-10-18 07:58 Markus Müller Note Edited: 0053116
2011-10-18 08:19 Vincent Snijders Note Added: 0053117
2011-10-18 08:22 Vincent Snijders Note Edited: 0053117
2011-10-18 08:26 Markus Müller Note Added: 0053118
2011-10-19 06:57 samuel herzog Note Added: 0053141
2011-10-19 18:40 Markus Müller Note Added: 0053172
2011-10-19 18:41 Markus Müller Note Edited: 0053172
2012-02-28 04:03 samuel herzog Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker