View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0020498Lazarus-public2011-10-17 06:092011-10-25 05:53
ReporterAnna 
Assigned ToMaxim Ganetsky 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version 
Summary0020498: Lazarus doesn't start after rebuild
DescriptionAfter installation from here : http://lazarus-ccr.svn.sourceforge.net/viewvc/lazarus-ccr/components/geckoport/ [^] Lazarus closes himself but then doesn't start.
Additional Informationlazarus snapshot: Lazarus-0.9.31-32864-fpc-2.5.1-20111013-win32.exe
os: WinXP SP3
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

- Relationships
duplicate of 0020476closedJuha Manninen Cannot compile Lazarus !!!! 

-  Notes
(0053065)
Anna (reporter)
2011-10-17 06:13

Is there a way to install gecko. I have tried Lazarus-0.9.31-32070-fpc-2.4.4-20110828-win32.exe but package doesn't compiled on fpc 2.4.4.
On fpc 2.5.1 package is compiled but lazarus doesn't start after package install. What a delusion?
(0053098)
Anna (reporter)
2011-10-17 16:54

Lazarus executable even doesn't have normal icon:
http://img3.imageshack.us/img3/7614/27507572.png [^]

Here command line text, which is appeared when lazarus tries to start:
http://pastebin.com/urb5vL5v [^]
(0053100)
Flávio Etrusco (mantis doesn't notify me) (developer)
2011-10-17 17:43

If you look at your log, the executable that's run while restarting says it's lazbuild (instead of lazarus).
This is most certainly related to 0020476, please try the latest svn (or an older snapshot).
(0053101)
Bart Broersma (developer)
2011-10-17 18:07

See note from Falvio.
(0053102)
Anna (reporter)
2011-10-17 18:14
edited on: 2011-10-17 18:22

>or an older snapshot
from where? As I know new snap writes over old.

Maybe better wait for newer snap?

(0053103)
Anna (reporter)
2011-10-17 20:04

Please, make video-tutorial 'How to make workable Lazarus from SVN'.
Because existing text tutorial kills my mind.
(0053109)
Maxim Ganetsky (developer)
2011-10-17 22:29
edited on: 2011-10-17 22:29

This is duplicate of 0020476 and is fixed in recent revisions (e.g. r32949 works OK for me).

(0053111)
Anna (reporter)
2011-10-18 03:32

Where is snapshot of r32949?
http://img441.imageshack.us/img441/5397/67546069.png [^]
Do you mean sources? Sorry, but I do not know what to do with them.
(0053128)
Flávio Etrusco (mantis doesn't notify me) (developer)
2011-10-18 13:23

Anna, please use the mailing list, forum or the IRC channel for other questions.
The snapshots are(were?) a bit outdated because of a connection problem (according to a post in the mailing list). It should be fixed soon if not already.
Compiling from svn is as simple of installing FPC 2.4.4, checkout lazarus from svn, put the bin folder from fpc in the PATH and run make in lazarus root folder.

- Issue History
Date Modified Username Field Change
2011-10-17 06:09 Anna New Issue
2011-10-17 06:13 Anna Note Added: 0053065
2011-10-17 06:18 Anna Note Added: 0053066
2011-10-17 16:53 Anna Note Deleted: 0053066
2011-10-17 16:54 Anna Note Added: 0053098
2011-10-17 17:43 Flávio Etrusco (mantis doesn't notify me) Note Added: 0053100
2011-10-17 18:07 Bart Broersma LazTarget => -
2011-10-17 18:07 Bart Broersma Note Added: 0053101
2011-10-17 18:07 Bart Broersma Status new => feedback
2011-10-17 18:14 Anna Note Added: 0053102
2011-10-17 18:22 Anna Note Edited: 0053102
2011-10-17 18:22 Anna Note Edited: 0053102
2011-10-17 20:04 Anna Note Added: 0053103
2011-10-17 22:29 Maxim Ganetsky Relationship added duplicate of 0020476
2011-10-17 22:29 Maxim Ganetsky Duplicate ID 0 => 20476
2011-10-17 22:29 Maxim Ganetsky Status feedback => resolved
2011-10-17 22:29 Maxim Ganetsky Resolution open => duplicate
2011-10-17 22:29 Maxim Ganetsky Assigned To => Maxim Ganetsky
2011-10-17 22:29 Maxim Ganetsky Note Added: 0053109
2011-10-17 22:29 Maxim Ganetsky Note Edited: 0053109
2011-10-18 03:31 Anna Note Added: 0053110
2011-10-18 03:32 Anna Note Added: 0053111
2011-10-18 03:51 Anna Status resolved => assigned
2011-10-18 03:51 Anna Resolution duplicate => reopened
2011-10-18 03:51 Anna Note Deleted: 0053110
2011-10-18 13:23 Flávio Etrusco (mantis doesn't notify me) Status assigned => resolved
2011-10-18 13:23 Flávio Etrusco (mantis doesn't notify me) Resolution reopened => duplicate
2011-10-18 13:23 Flávio Etrusco (mantis doesn't notify me) Note Added: 0053128
2011-10-18 13:23 Flávio Etrusco (mantis doesn't notify me) Duplicate ID 20476 => 0
2011-10-25 05:53 Anna Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker