View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0020811LazarusIDEpublic2011-12-04 18:062011-12-06 18:57
ReporterSwen Heinig 
Assigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSKubuntu x64OS Version11.10
Product Version0.9.31 (SVN)Product Build33955 
Target VersionFixed in Version 
Summary0020811: Lazarus IDE shortcuts can't be changed
DescriptionAfter a svn update I saw, that some of my shortcuts were disappeared. Then I thought, ok let's create them again. But when I try to change a shortcut I get

TApplication.HandleException Invalid argument index in format ""
  Stack trace:
  $00000000006438AD
  $00000000006451C3
  $0000000000645869
  $0000000000677627 line 548 of lclproc.pas
  $0000000000676D47 line 583 of lclproc.pas
  $00000000009FDAD9 line 6457 of propedits.pp
  $000000000100ED2A line 140 of keymapshortcutdlg.pas
  $00000000006640F9 line 878 of include/customform.inc
  $000000000066230D line 79 of include/customform.inc
  $0000000000669AE6 line 2934 of include/customform.inc
  $000000000100EA9A line 98 of keymapshortcutdlg.pas
  $0000000000B9D951 line 252 of frames/editor_keymapping_options.pas
  $000000000081D547 line 1238 of include/control.inc
  $000000000081EDC4 line 2022 of include/control.inc
  $000000000062A185
  $0000000000812A52 line 5265 of include/wincontrol.inc
  $000000000087261D line 4142 of include/treeview.inc
QPixmap::handle(): Pixmap is not an X11 class pixmap

A strange thing is, that if I change the IDE language from german to english, I again can change the shortcuts. (But when I switch back to german, all changes will disappeare.) I don't know exactly, which update caused this problem, but it must be after revision 33346 (with this revision I don't have the problem).
Additional InformationLazarus version: 0.9.31
Lazarus svn revision: 33653:33955M
Lazarus build date: 2011/12/04
Lazarus was compiled for x86_64-linux
Lazarus was compiled with fpc 2.4.4

Global IDE options:
Primary config directory=/home/swen/.lazarus
Secondary config directory=/etc/lazarus
LazarusDirectory=/home/swen/svn/lazarus/
CompilerFilename=/usr/bin/fpc
Real CompilerFilename=/usr/bin/fpc
CompilerMessagesFilename=/home/swen/svn/fpc/compiler/msg/errordu.msg
FPC source directory=/usr/share/fpcsrc/$(FPCVer)/
Real FPC source directory=/usr/share/fpcsrc/2.4.4/
Test directory=/tmp/

Working directory=/home/swen/svn/lazarus
Application.ExeName=/home/swen/svn/lazarus/lazarus

Parameters:
/home/swen/svn/lazarus/lazarus

Environment variables:
SSH_AGENT_PID=1656
SSH_AGENT_PID=1656
KDE_MULTIHEAD=false
DM_CONTROL=/var/run/xdmctl
GPG_AGENT_INFO=/tmp/gpg-2RLngb/S.gpg-agent:1657:1
SHELL=/bin/bash
TERM=xterm
XDG_SESSION_COOKIE=152a469bbe8156a3f0a34b36000002ab-1322993613.85155-769763401
XDM_MANAGED=method=classic,auto
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/swen/.gtkrc-2.0:/home/swen/.gtkrc-2.0-kde4:/home/swen/.kde/share/config/gtkrc-2.0
KONSOLE_DBUS_SERVICE=:1.135
GS_LIB=/home/swen/.fonts
GTK_RC_FILES=/etc/gtk/gtkrc:/home/swen/.gtkrc:/home/swen/.kde/share/config/gtkrc
WINDOWID=109051920
SHELL_SESSION_ID=df0047f4a1cc4000a827e0e1fa09e45c
KDE_FULL_SESSION=true
USER=swen
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32: *.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31: *.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31: *.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31: *.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35: *.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35: *.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35: *.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35: *.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35: *.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36: *.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
SSH_AUTH_SOCK=/tmp/ssh-cFySUBuS1596/agent.1596
SESSION_MANAGER=local/swen1:@/tmp/.ICE-unix/1883,unix/swen1:/tmp/.ICE-unix/1883
DEFAULTS_PATH=/usr/share/gconf/default.default.path
XDG_CONFIG_DIRS=/etc/xdg/xdg-default:/etc/xdg
DESKTOP_SESSION=default
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
PWD=/home/swen/svn/lazarus
KDE_SESSION_UID=1000
LANG=de_DE.UTF-8
MANDATORY_PATH=/usr/share/gconf/default.mandatory.path
QT_GRAPHICSSYSTEM=raster
UBUNTU_MENUPROXY=libappmenu.so
KONSOLE_DBUS_SESSION=/Sessions/1
HISTCONTROL=ignoreboth
HOME=/home/swen
COLORFGBG=15;0
SHLVL=1
KDE_SESSION_VERSION=4
LANGUAGE=
XCURSOR_THEME=default
LOGNAME=swen
XDG_DATA_DIRS=/usr/share/default:/usr/local/share/:/usr/share/
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-KuZn6fCqxc,guid=ffe9c98b8d60935cb6aab7ec00000016
LESSOPEN=| /usr/bin/lesspipe %s
WINDOWPATH=7
PROFILEHOME=
DISPLAY=:0
QT_PLUGIN_PATH=/home/swen/.kde/lib/kde4/plugins/:/usr/lib/kde4/plugins/
LESSCLOSE=/usr/bin/lesspipe %s %s
OLDPWD=/home/swen/svn

TagsNo tags attached.
Fixed in Revisionr34001
LazTarget-
WidgetsetQT
Attached Files? file icon lclstrconsts.de.po [^] (40,173 bytes) 2011-12-06 15:12

- Relationships

-  Notes
(0054716)
Juha Manninen (developer)
2011-12-05 00:48

I can't reproduce this.
My guess is that the problem is caused by a corrupted / old configuration file, or an old .ppu file when building Lazarus.
Try deleting your local config dir and selecting "Clean All + Build" in Configure Build Lazarus dialog.
(0054726)
Juha Manninen (developer)
2011-12-05 20:47

@Swen, ping. Did you try the clean build?
(0054727)
Swen Heinig (developer)
2011-12-05 20:49

I did a make clean all. But the problem is still there.
(0054730)
Juha Manninen (developer)
2011-12-05 22:14

Try also deleting your local config dir and selecting "Clean All + Build" in Configure Build Lazarus dialog, as I suggested, or alternatively "make cleanlaz ide".
(0054731)
Swen Heinig (developer)
2011-12-05 22:32

I deleted the config dir - without any success. There must be an other reason for the problem.
(0054735)
Juha Manninen (developer)
2011-12-06 12:35

Your stack trace: $0000000000677627 line 548 of lclproc.pas
refers to
  VK_NUMPAD0..VK_NUMPAD9: AddPart(Format(ifsVK_NUMPAD,[Key-VK_NUMPAD0]));
in
function KeyAndShiftStateToKeyString(Key: word; ShiftState: TShiftState): String;

It means you used the numpad keys to set a shortcut.

Your error says: Invalid argument index in format ""
The format string used is:
  ifsVK_NUMPAD = 'Numpad %d';

I don't know what causes the problem for you.
Can someone else reproduce?
(0054736)
cobines (reporter)
2011-12-06 13:20

In lclstrconsts.de.po:

#: lclstrconsts.ifsvk_numpad
msgid "Numpad %d"
msgstr "Zahlenblock %s"

There is %s instead of %d.
(0054738)
Zeljan Rikalo (developer)
2011-12-06 14:32

So, translation kills keys ? ;)
(0054741)
Swen Heinig (developer)
2011-12-06 15:15

Thanks for the hint with the translation error. I uploaded a changed file which should solve the problem. After applying the file this issue can be closed.
(0054743)
Juha Manninen (developer)
2011-12-06 15:59
edited on: 2011-12-06 16:02

Thanks, I applied the changes. You found some other errors, too.

P.S. There should be a tool that checks such errors in .po files. It could also check for unused and duplicate resource strings. There are plenty of them.


- Issue History
Date Modified Username Field Change
2011-12-04 18:06 Swen Heinig New Issue
2011-12-04 18:06 Swen Heinig Widgetset => QT
2011-12-04 18:32 Zeljan Rikalo Status new => assigned
2011-12-04 18:32 Zeljan Rikalo Assigned To => Juha Manninen
2011-12-05 00:48 Juha Manninen LazTarget => -
2011-12-05 00:48 Juha Manninen Note Added: 0054716
2011-12-05 00:48 Juha Manninen Status assigned => feedback
2011-12-05 20:47 Juha Manninen Note Added: 0054726
2011-12-05 20:49 Swen Heinig Note Added: 0054727
2011-12-05 22:14 Juha Manninen Note Added: 0054730
2011-12-05 22:32 Swen Heinig Note Added: 0054731
2011-12-06 11:02 Juha Manninen Additional Information Updated
2011-12-06 11:04 Juha Manninen Additional Information Updated
2011-12-06 12:35 Juha Manninen Note Added: 0054735
2011-12-06 13:20 cobines Note Added: 0054736
2011-12-06 14:32 Zeljan Rikalo Note Added: 0054738
2011-12-06 15:12 Swen Heinig File Added: lclstrconsts.de.po
2011-12-06 15:15 Swen Heinig Note Added: 0054741
2011-12-06 15:59 Juha Manninen Fixed in Revision => r34001
2011-12-06 15:59 Juha Manninen Status feedback => resolved
2011-12-06 15:59 Juha Manninen Resolution open => fixed
2011-12-06 15:59 Juha Manninen Note Added: 0054743
2011-12-06 16:02 Juha Manninen Note Edited: 0054743
2011-12-06 18:57 Swen Heinig Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker