View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021514FPCCompilerpublic2012-03-19 20:362012-04-20 20:14
ReporterAndrey Zubarev 
Assigned ToFlorian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product VersionProduct Build 
Target VersionFixed in Version2.6.1 
Summary0021514: Wrong location error "Fatal: Can't find unit XXXX used by YYYY" in Lazarus
DescriptionIt copy of http://bugs.freepascal.org/view.php?id=21510 [^]
If an error occurs:

Fatal: Can't find unit XXXX used by YYYY

location of the error is displayed incorrectly, see uses.png
TagsNo tags attached.
FPCOldBugId0
Fixed in Revision20944
Attached Filespng file icon uses.PNG [^] (141,215 bytes) 2012-03-19 20:36


7z file icon test.7z [^] (60,758 bytes) 2012-03-23 18:50

- Relationships
has duplicate 0021776closedFlorian FPC wrong error line on compilation 
related to 0021510closedMattias Gaertner Lazarus Wrong location error "Fatal: Can't find unit XXXX used by YYYY" 

-  Notes
(0057932)
Florian (administrator)
2012-03-22 22:05

FPC writes now the file location if available so lazarus has to guess less.
(0057939)
Andrey Zubarev (reporter)
2012-03-23 08:58
edited on: 2012-03-23 08:58

Still indicates the wrong place

(0057961)
Florian (administrator)
2012-03-23 18:03

Without some example code which shows the problem, I don't know what to fix then, sorry.
(0057966)
Andrey Zubarev (reporter)
2012-03-23 18:52

Project in test.7z shows:

unit1.pas(33,2) Fatal: Can't find unit blablabla used by Unit1
(0057968)
Florian (administrator)
2012-03-23 18:58

Works with plain fpc:

c:\fpc\tmp>c:\fpc\svn\compiler\ppc386 -n @c:\fpc\bin\fpc.cfg project1.lpr -l
Free Pascal Compiler version 2.7.1-r1:18013M [2012/03/22] for i386
Copyright (c) 1993-2011 by Florian Klaempfl and others
unit1.pas(5,2) Fatal: Can't find unit blablabla used by Unit1
Fatal: Compilation aborted

so apparently only the lazarus part is left to be fixed.

- Issue History
Date Modified Username Field Change
2012-03-19 20:36 Andrey Zubarev New Issue
2012-03-19 20:36 Andrey Zubarev File Added: uses.PNG
2012-03-20 11:18 Vincent Snijders Relationship added related to 0021510
2012-03-22 22:05 Florian Fixed in Revision => 20583
2012-03-22 22:05 Florian Status new => resolved
2012-03-22 22:05 Florian Fixed in Version => 2.7.1
2012-03-22 22:05 Florian Resolution open => fixed
2012-03-22 22:05 Florian Assigned To => Florian
2012-03-22 22:05 Florian Note Added: 0057932
2012-03-23 08:58 Andrey Zubarev Status resolved => feedback
2012-03-23 08:58 Andrey Zubarev Resolution fixed => reopened
2012-03-23 08:58 Andrey Zubarev Note Added: 0057939
2012-03-23 08:58 Andrey Zubarev Note Edited: 0057939
2012-03-23 18:03 Florian Assigned To Florian =>
2012-03-23 18:03 Florian Note Added: 0057961
2012-03-23 18:50 Andrey Zubarev File Added: test.7z
2012-03-23 18:52 Andrey Zubarev Note Added: 0057966
2012-03-23 18:58 Florian Status feedback => resolved
2012-03-23 18:58 Florian Resolution reopened => unable to reproduce
2012-03-23 18:58 Florian Assigned To => Florian
2012-03-23 18:58 Florian Note Added: 0057968
2012-03-23 19:18 Andrey Zubarev Status resolved => closed
2012-04-15 19:53 Jonas Maebe Relationship added related to 0021776
2012-04-15 19:54 Jonas Maebe Relationship deleted related to 0021776
2012-04-15 19:54 Jonas Maebe Relationship added has duplicate 0021776
2012-04-20 20:14 Jonas Maebe FPCOldBugId => 0
2012-04-20 20:14 Jonas Maebe Fixed in Revision 20583 => 20944
2012-04-20 20:14 Jonas Maebe Fixed in Version 2.7.1 => 2.6.1



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker