View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021621FPCUtilitiespublic2012-04-01 12:342014-03-06 10:23
ReporterMarco van de Voort 
Assigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
Platformi386-linuxOSOS Version
Product VersionProduct Build 
Target Version2.6.1Fixed in Version2.7.1 
Summary0021621: fpdoc fails to generate html/chm docs
Description(trunk as of today) fpdoc seems quite broken, and can't generate chm docs. Sometimes there is an access violation and generation terminates, and sometimes generation "succeeds", but sizes are less than half the 2.6.0 docs.

I tried to debug and the problem seems to be mostly that module.interfacesection is not assigned in scanmodule. Fixing that, it crashes somewhere else on the same problem. (interfacesection not being assigned)

Steps To ReproduceRun fixdocs.sh from fpdocs repo. Look in "buildlog.txt" for the fpdoc cmdline, start fpdoc in gdb with the same arguments.
TagsNo tags attached.
FPCOldBugId0
Fixed in Revision22144
Attached Files

- Relationships
related to 0021642closedMichael Van Canneyt fcl_passrc: pparser, pscanner: range -> EParserError : Expected "=" at token "of" ; scanner returns tkWhitespace 

-  Notes
(0058229)
Marco van de Voort (manager)
2012-04-01 16:24

The exception (the interface section problem) seems to be related to unit oldlinux. It could be that the deprecated warning in that unit is related to the problem.

If I remove that unit however, I have no more exceptions, but get heaps of warnings for system and sysutils routines that can't be found, and the resulting file is still half of the size of the 2.6.0 one.
(0058246)
Marco van de Voort (manager)
2012-04-02 12:33

Seems that the other incomplete or missing units have warnings/errors in them (e.g. the known range problems). Could it be that that stops parsing or so?
(0058837)
Marco van de Voort (manager)
2012-04-21 16:28
edited on: 2012-04-21 16:29

Slowly the amount of code properly parsed is rising again. Currently it bombs on classesh.inc:210:

 Type
      TDirection = (FromBeginning, FromEnd);

with
Expected "," or ":" at token "=" in file

(0058840)
Michael Van Canneyt (administrator)
2012-04-21 17:36

Nested types are not yet supported. I'm working on that.
(0061771)
Michael Van Canneyt (administrator)
2012-08-20 18:39

Improved fcl-passrc so Docs are generated again without errors.

- Issue History
Date Modified Username Field Change
2012-04-01 12:34 Marco van de Voort New Issue
2012-04-01 12:34 Marco van de Voort FPCOldBugId => 0
2012-04-01 12:35 Marco van de Voort Status new => assigned
2012-04-01 12:35 Marco van de Voort Assigned To => Michael Van Canneyt
2012-04-01 16:24 Marco van de Voort Note Added: 0058229
2012-04-02 12:33 Marco van de Voort Note Added: 0058246
2012-04-04 10:33 Marco van de Voort Relationship added related to 0021642
2012-04-21 16:28 Marco van de Voort Note Added: 0058837
2012-04-21 16:29 Marco van de Voort Note Edited: 0058837
2012-04-21 17:36 Michael Van Canneyt Note Added: 0058840
2012-08-20 18:39 Michael Van Canneyt Fixed in Revision => 22144
2012-08-20 18:39 Michael Van Canneyt Status assigned => resolved
2012-08-20 18:39 Michael Van Canneyt Fixed in Version => 2.7.1
2012-08-20 18:39 Michael Van Canneyt Resolution open => fixed
2012-08-20 18:39 Michael Van Canneyt Note Added: 0061771
2012-08-20 18:39 Michael Van Canneyt Target Version => 2.6.1
2014-03-06 10:23 Michael Van Canneyt Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker