View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021826LazarusLCLpublic2012-04-21 18:372012-06-14 22:12
ReporterPhilippe Benest 
Assigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformOSOS Version
Product Version0.9.30.4Product Build 
Target VersionFixed in Version 
Summary0021826: When I quit my program made with Lazarus+FP a message window opened with : class 'RunError 52952'
DescriptionI made a project with the last release of Lazarus-win32 on windowXP up to date.
I have installed Lazarus-win64 last release on my portable computer which runs with Windows 7 64bit.
After that I compiled the project (64 bit) except, when I close the main window, Lazarus don't stop the program and open a message window with the message : class 'RunError 52952', then a closed this window and a new window (Title : Assembleur) with a lot of such lines :


000000000040ED1A 0000 add %al,(%rax)
000000000040ED1C 0000 add %al,(%rax)
000000000040ED1E 0000 add %al,(%rax)
SYSTEM_HANDLEERRORADDRFRAME$LONGINT$POINTER$POINTER
000000000040ED20 4883ec38 sub $0x38,%rsp
000000000040ED24 48895c2420 mov %rbx,0x20(%rsp) (with Green arrow pointed in front of this line)
000000000040ED29 48897c2428 mov %rdi,0x28(%rsp)
000000000040ED2E 889742430 mov %rsi,0x30(%rsp)
000000000040ED33 89cb mov %ecx,%ebx


When I execute the .exe program everything is correct and no message appened when I closed the window.
Additional InformationMy computer : ASUS G74S.
Microprocessor : Intel core I7.
OS : Windows 7, 64 bits.

Before that I had Lazarus-win32 and I had not any problems.

If you have any questions, please don't hesitate to contact me.

Philippe Benest
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

- Relationships

-  Notes
(0058886)
Juha Manninen (developer)
2012-04-22 15:34

FPC 2.4.4 had some problems on 64-bit systems.
Most likely however you have FPC 2.6.0 but there is something left from your old FPC / Lazarus installation.
Try making a clean install.
(0058888)
Zeljan Rikalo (developer)
2012-04-22 15:44

I've just rebuilded current trunk on win7 64 bit with fpc-2.4.4 32bit ,and tried some apps - everything works fine. My wild guess is that Juha is right - you should try 2.6.0 / 2.6.1
(0060544)
Juha Manninen (developer)
2012-06-14 22:12

No activity, resolving now.
Most likely caused by a local compilation or configuration or other such problem.

- Issue History
Date Modified Username Field Change
2012-04-21 18:37 Philippe Benest New Issue
2012-04-21 18:37 Philippe Benest Widgetset => Win32/Win64
2012-04-22 15:34 Juha Manninen Note Added: 0058886
2012-04-22 15:44 Zeljan Rikalo Note Added: 0058888
2012-06-14 22:12 Juha Manninen LazTarget => -
2012-06-14 22:12 Juha Manninen Status new => resolved
2012-06-14 22:12 Juha Manninen Resolution open => no change required
2012-06-14 22:12 Juha Manninen Assigned To => Juha Manninen
2012-06-14 22:12 Juha Manninen Note Added: 0060544



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker