View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021832LazarusIDEpublic2012-04-22 14:452012-04-22 20:43
ReporterStephano 
Assigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version 
Summary0021832: Code completion for library not working well
DescriptionThe code completion for a library does not work for the initialization and finalization keywords (could be related to bug 0021830) as well as anything in these 2 sections.

library Project1;

{$mode objfpc}{$H+}

uses
  Classes
  { you can add units after this };

var
  count: Integer;

initialization <- no code completion here
  coun and here

end.
    
TagsNo tags attached.
Fixed in Revision36974, 36975
LazTarget-
Widgetset
Attached Files

- Relationships
related to 0021831closedMattias Gaertner Code completion does not work for initialization and finalization 

-  Notes
(0058897)
Stephano (developer)
2012-04-22 20:34

The situation is now worse:
- Initialization is still not recognised by code completion
- Add before 'begin'
 var count: integ
and invoke code completion. Lazarus will freeze.
(0058899)
Stephano (developer)
2012-04-22 20:42

I missed one revision update due to a race condition :).

The IDE no longer freezes, and code completion works in the initialization section.

This bug can be closed.

- Issue History
Date Modified Username Field Change
2012-04-22 14:45 Stephano New Issue
2012-04-22 14:52 Juha Manninen Relationship added related to 0021830
2012-04-22 14:54 Juha Manninen Relationship deleted related to 0021830
2012-04-22 14:54 Juha Manninen Relationship added related to 0021831
2012-04-22 14:56 Mattias Gaertner Status new => assigned
2012-04-22 14:56 Mattias Gaertner Assigned To => Mattias Gaertner
2012-04-22 20:25 Mattias Gaertner Fixed in Revision => 36974
2012-04-22 20:25 Mattias Gaertner LazTarget => -
2012-04-22 20:25 Mattias Gaertner Status assigned => resolved
2012-04-22 20:25 Mattias Gaertner Resolution open => fixed
2012-04-22 20:34 Stephano Status resolved => assigned
2012-04-22 20:34 Stephano Resolution fixed => reopened
2012-04-22 20:34 Stephano Note Added: 0058897
2012-04-22 20:42 Stephano Note Added: 0058899
2012-04-22 20:42 Mattias Gaertner Fixed in Revision 36974 => 36974, 36975
2012-04-22 20:42 Mattias Gaertner Status assigned => resolved
2012-04-22 20:42 Mattias Gaertner Resolution reopened => fixed
2012-04-22 20:43 Stephano Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker