View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021903LazarusIDEpublic2012-05-01 10:372012-06-15 11:23
ReporterReinier Olislagers 
Assigned ToJuha Manninen 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
Platformx64OSWindowsOS VersionVista
Product Version1.1 (SVN)Product Buildr37047 
Target VersionFixed in Version 
Summary0021903: lhelp: scrollbar doesn't work using mouse
DescriptionRunning lhelp, clicking below the vertical scrollbar gives no reaction.

Windows Vista x64, Aero

Tested on various combinations:
Error:
- lazarus x64 r37117 windows (recent FPC trunk)
- lazarus x86 r37047 windows (recent FPC trunk)

No error:
- lazarus x86 r37102 windows (recent FPC fixes 2.6)
- lazarus x86 r37117 windows (recent FPC fixes 2.6)

Difference between FPC fixes and trunk!?!?
Steps To ReproduceOpen Lhelp.exe (did it for testing without Lazarus opened)
Open CHM file, e.g. fcl.chm
(If necessary resize window so content won't fit vertically)
Click below vertical scrollbar
Content does not move (upward) as it should
Additional InformationPerhaps related to
21326: LHelp, Win / CHM Help Facility doesn't scroll via Page UP / Page Down (PG Dwn) nor arrow keys
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

- Relationships
related to 0021326resolvedAndrewH LHelp, Win / CHM Help Facility doesn't scroll via Page UP / Page Down (PG Dwn) nor arrow keys 
related to 0019445new Lazarus lhelp mouse wheel movement is very slow 
related to 0023498new help browser unusable beause of impossible scrolling 

-  Notes
(0060224)
Reinier Olislagers (developer)
2012-06-03 15:43
edited on: 2012-06-03 15:45

Can be closed as far as I'm concerned:

Seems fixed in
Lazarus version: 1.1
Lazarus svn revision: 37399
Lazarus build date: 2012/05/23
Lazarus was compiled for i386-win32
Lazarus was compiled with fpc 2.6.1
and
Lazarus version: 1.1
Lazarus svn revision: 37499
Lazarus build date: 2012/06/03
Lazarus was compiled for i386-win32
Lazarus was compiled with fpc 2.6.1

(0060540)
Juha Manninen (developer)
2012-06-14 21:41

I tested also with latest FPC trunk and the mouse operations work well.
The related keyboard related issue still remains.

- Issue History
Date Modified Username Field Change
2012-05-01 10:37 Reinier Olislagers New Issue
2012-05-01 11:37 Juha Manninen Relationship added related to 0021326
2012-05-01 11:42 Juha Manninen Relationship added related to 0019445
2012-06-03 15:43 Reinier Olislagers Note Added: 0060224
2012-06-03 15:44 Reinier Olislagers Note Edited: 0060224
2012-06-03 15:45 Reinier Olislagers Note Edited: 0060224
2012-06-14 21:41 Juha Manninen LazTarget => -
2012-06-14 21:41 Juha Manninen Status new => resolved
2012-06-14 21:41 Juha Manninen Resolution open => unable to reproduce
2012-06-14 21:41 Juha Manninen Assigned To => Juha Manninen
2012-06-14 21:41 Juha Manninen Note Added: 0060540
2012-06-15 11:23 Reinier Olislagers Status resolved => closed
2012-12-17 11:08 Reinier Olislagers Relationship added related to 0023498



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker