View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021944Lazarus CCRVirtual Treeviewpublic2012-05-05 16:562012-05-08 20:19
Reportercobines 
Assigned ToLuiz Americo 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWin32OSWindows XPOS VersionSP3
Summary0021944: Header is not taken into account when auto scrolling
DescriptionWhen auto scrolling in some cases mouse cursor position is compared against Client bounds but ClientRect does not contain header and header height is not substracted from mouse position.

I have added my own scrolling, when mouse is moved to the border of the ClientRect the tree should scroll.

To reproduce:
1. Run project.
2. Move mouse to the most bottom node. Scrolling should start but it does not.
3. Move mouse a little bit up, to the second or third from bottom node. Scrolling starts.

Same thing at the top of the control. Scrolling is not performed when mouse is on the most top node, but it is performed when mouse is on the header.

Patch against trunk attached.
TagsNo tags attached.
Widgetset
Attached Filesdiff file icon autoscroll_with_header.diff [^] (846 bytes) 2012-05-05 16:56 [Show Content]
zip file icon vtv_scroll.zip [^] (2,375 bytes) 2012-05-05 17:00

- Relationships
duplicate of 0002418closedMichael Van Canneyt FPC Run time error 216 at 0x0043AE26 while compiling Pascall Yacc program Lex 

-  Notes
(0059327)
Luiz Americo (developer)
2012-05-07 03:51

Fixed in 4.8 branch
(0059347)
cobines (reporter)
2012-05-07 11:27

Thanks. Although it still also scrolls when mouse is over the header. Is that the intention that in DoTimerScroll InRect is True if mouse is over header?
Then in DetermineScrollDirections if mouse is over header Y is negative but it is compared against node height:
  if (Y < Integer(FDefaultNodeHeight))
Can this be changed?
(0059359)
Luiz Americo (developer)
2012-05-07 18:38

Done
(0059414)
cobines (reporter)
2012-05-08 20:19

Thanks.

- Issue History
Date Modified Username Field Change
2012-05-05 16:56 cobines New Issue
2012-05-05 16:56 cobines File Added: autoscroll_with_header.diff
2012-05-05 17:00 cobines File Added: vtv_scroll.zip
2012-05-06 02:35 Luiz Americo Status new => assigned
2012-05-06 02:35 Luiz Americo Assigned To => Luiz Americo
2012-05-07 03:51 Luiz Americo Relationship added duplicate of 0002418
2012-05-07 03:51 Luiz Americo Duplicate ID 0 => 2418
2012-05-07 03:51 Luiz Americo Status assigned => resolved
2012-05-07 03:51 Luiz Americo Resolution open => fixed
2012-05-07 03:51 Luiz Americo Note Added: 0059327
2012-05-07 11:27 cobines Status resolved => feedback
2012-05-07 11:27 cobines Resolution fixed => reopened
2012-05-07 11:27 cobines Note Added: 0059347
2012-05-07 18:38 Luiz Americo Status feedback => resolved
2012-05-07 18:38 Luiz Americo Resolution reopened => fixed
2012-05-07 18:38 Luiz Americo Note Added: 0059359
2012-05-07 18:38 Luiz Americo Duplicate ID 2418 => 0
2012-05-08 20:19 cobines Status resolved => closed
2012-05-08 20:19 cobines Note Added: 0059414



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker