View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021976Lazarus CCRVirtual Treeviewpublic2012-05-07 12:122012-05-14 18:43
Reportercobines 
Assigned ToLuiz Americo 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinux i386OSDebianOS VersionSid
Summary0021976: VTVDragManager unneccesarily created on non-Windows with DragType=dtVCL
DescriptionVTVDragManager is created on non-Windows even with DragType=dtVCL but it is not implemented and after drag&drop operation it for example prevents scrolling in DoTimerScroll (DoSetOffsetXY is not called).

VTVDragManager is created in TBaseVirtualTree.DragOver because there is a missing check for FDragManager <> nil.

You can test with attached project on Linux, but you need to hardcode InRect to True in DoTimerScroll because MapWindowPoints is not implemented:
1. Move mouse at the bottom of the Tree, scrolling should start.
2. Start dragging some node and after dragging starts release mouse.
3. Move mouse at the bottom of the Tree, scrolling does not start anymore.

Patch against trunk is attached.
TagsNo tags attached.
Widgetset
Attached Fileszip file icon vtv_scroll.zip [^] (2,591 bytes) 2012-05-07 12:12
diff file icon vtvdragmanager_nocreate.diff [^] (565 bytes) 2012-05-07 12:13 [Show Content]

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-05-07 12:12 cobines New Issue
2012-05-07 12:12 cobines File Added: vtv_scroll.zip
2012-05-07 12:13 cobines File Added: vtvdragmanager_nocreate.diff
2012-05-07 18:50 Luiz Americo Status new => assigned
2012-05-07 18:50 Luiz Americo Assigned To => Luiz Americo
2012-05-12 18:32 Luiz Americo Status assigned => resolved
2012-05-12 18:32 Luiz Americo Resolution open => fixed
2012-05-14 18:43 cobines Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker