View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021994FPCDatabase Componentspublic2012-05-09 09:012012-05-14 06:59
ReporterLacaK 
Assigned ToJoost van der Sluis 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.7.1Product Build 
Target VersionFixed in Version2.7.1 
Summary0021994: TBufDataset when records are inserted into empty dataset and then canceled AV is raised
DescriptionPatch fixies:
* when records are inserted into empty dataset and then all canceled by CancelUpdates AV is raised
* another fix for bug 18004, applied in rev.20531 (improved in rev.21197)
  (original approach is not good because when record is inserted and deleted and again inserted,
   then same memory block can be returned, which leads to confusion, because we get same BookmarkData for distinct records)
* +test
TagsNo tags attached.
FPCOldBugId
Fixed in Revision21280
Attached Filesdiff file icon bufdataset.diff [^] (2,708 bytes) 2012-05-09 09:01 [Show Content]
diff file icon testbufdatasetstreams.pas.diff [^] (1,191 bytes) 2012-05-09 09:04 [Show Content]

- Relationships

-  Notes
(0059542)
Marco van de Voort (manager)
2012-05-12 22:16

fixed

- Issue History
Date Modified Username Field Change
2012-05-09 09:01 LacaK New Issue
2012-05-09 09:01 LacaK Status new => assigned
2012-05-09 09:01 LacaK Assigned To => Joost van der Sluis
2012-05-09 09:01 LacaK File Added: bufdataset.diff
2012-05-09 09:04 LacaK File Added: testbufdatasetstreams.pas.diff
2012-05-12 22:16 Marco van de Voort Fixed in Revision => 21280
2012-05-12 22:16 Marco van de Voort Status assigned => resolved
2012-05-12 22:16 Marco van de Voort Fixed in Version => 2.7.1
2012-05-12 22:16 Marco van de Voort Resolution open => fixed
2012-05-12 22:16 Marco van de Voort Note Added: 0059542
2012-05-14 06:59 LacaK Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker