View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022021LazarusLCLpublic2012-05-13 10:292012-05-29 17:41
ReporterIhor Lavrynyuk 
Assigned ToJuha Manninen 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
Platformi386OSUnix-likeOS VersionUbuntu 12.04 LTS
Product Version1.1 (SVN)Product Build27261 
Target VersionFixed in Version 
Summary0022021: Error reading EventLog.Paused: Unknown property: "Paused"
DescriptionI create my Application in windows and co from svn.
In GTK2 have dis error:
Error reading EventLog.Paused: Unknown property: "Paused"
In windows all ok.
Steps To ReproduceCreate project in windows
put on form TEventLog component
save
open your project on Linux
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2, Win32/Win64
Attached Filespng file icon 52.png [^] (307,013 bytes) 2012-05-13 10:30
png file icon 12.png [^] (386,188 bytes) 2012-05-13 10:30
zip file icon issue.zip [^] (178,326 bytes) 2012-05-13 21:14

- Relationships

-  Notes
(0059566)
Juha Manninen (developer)
2012-05-13 20:57

Works well here.
You must have mixed the source of different versions of Lazarus. It can cause many kinds of problems.
A clean installation may help.
(0059568)
Ihor Lavrynyuk (reporter)
2012-05-13 21:07
edited on: 2012-05-13 21:10

I download Lazarus from SVN in Linux and every time update and recompile to latest revision.
In Windows (if reinstall windows) I download Lazarus from Daily Snapshots and update to last revision.
In windows and Linux have same revision. and version 1.1 from trunk

(0059569)
Ihor Lavrynyuk (reporter)
2012-05-13 21:14
edited on: 2012-05-13 21:21

please test issue.zip on linux

(0059590)
Juha Manninen (developer)
2012-05-14 20:53

Ok, the problem is not Lazarus version but FPC version.
EventLog is a package of FPC and the Paused property is introduced in trunk 2.7.1.
The released FPC 2.6.x does not have it.

The solution is to use the same compiler version on both Windows and Linux.
(0059591)
Ihor Lavrynyuk (reporter)
2012-05-14 21:00

maybe, but in windows I use 2.6.1 fpc
in Linux fpc I update from svn, and install and select in Lazarus, but Lazarus see show 2.6.1 version

- Issue History
Date Modified Username Field Change
2012-05-13 10:29 Ihor Lavrynyuk New Issue
2012-05-13 10:29 Ihor Lavrynyuk Widgetset => GTK 2, Win32/Win64
2012-05-13 10:30 Ihor Lavrynyuk File Added: 52.png
2012-05-13 10:30 Ihor Lavrynyuk File Added: 12.png
2012-05-13 20:57 Juha Manninen Note Added: 0059566
2012-05-13 21:07 Ihor Lavrynyuk Note Added: 0059568
2012-05-13 21:10 Ihor Lavrynyuk Note Edited: 0059568
2012-05-13 21:14 Ihor Lavrynyuk File Added: issue.zip
2012-05-13 21:14 Ihor Lavrynyuk Note Added: 0059569
2012-05-13 21:21 Ihor Lavrynyuk Note Edited: 0059569
2012-05-14 20:53 Juha Manninen LazTarget => -
2012-05-14 20:53 Juha Manninen Status new => resolved
2012-05-14 20:53 Juha Manninen Resolution open => no change required
2012-05-14 20:53 Juha Manninen Assigned To => Juha Manninen
2012-05-14 20:53 Juha Manninen Note Added: 0059590
2012-05-14 21:00 Ihor Lavrynyuk Note Added: 0059591
2012-05-29 17:41 Ihor Lavrynyuk Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker