View Issue Details

IDProjectCategoryView StatusLast Update
0023821LazarusWidgetsetpublic2014-05-05 14:03
ReporterGroffy Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWin7/XP 
Product Version1.0.5 (SVN) 
Summary0023821: FormStyle and BorderIcons properties ingnored from MDI-chil form under QT widgetset
DescriptionChanging form properties FormStyle and BorderIcons shows no effect. FormStyle is always fsSizeable and border icons biMaximize, biMinimize, biSystemMenu are always visible.
Additional InformationWin7 - 64bit
Lazarus 1.05 - 32 bit
QT 4.8.4
Qt4Pas5.dll version 5.2.5
TagsNo tags attached.
Fixed in Revision44925
LazTarget-
WidgetsetQT
Attached Files

Activities

Groffy

2013-02-04 11:06

reporter   ~0065460

Issue is visible only for MDI child froms!

Zeljan Rikalo

2013-02-04 11:30

developer   ~0065463

Yes I know about that. Problem is that it have to be fixed in CreateHandle when QMDISubWindow is added to QMdiArea.... I'll try to fix that soon.

Groffy

2013-02-04 12:19

reporter   ~0065467

Its nothing what actually confuses me. As you might noticed, actually I just evaluate the QT widgets MDI implementation, because there is actually no MDI other implementation. I know, that MDI is not state of the art, but what Lazarus offers for docking actually does not convince me.

Zeljan Rikalo

2013-02-04 17:43

developer   ~0065476

As I can see Qt does not matter for title buttons settings.
It will be possible to have only 3 different mdichild titlebars:
1.Sizeable (as it is now) (bsSizeable)
2.Dialog (only close button) (bsDialog)
3.Frameless (no frame no title bar at all (bsNone).

Zeljan Rikalo

2014-05-05 14:03

developer   ~0074780

Please test and close if ok.
NOTE: FormStyle and BorderIcons are setted up ONLY WHEN mdichild handle (form.handle) is created. If you change those params during runtime you must call RecreateWnd (only for mdichild windows).

Issue History

Date Modified Username Field Change
2013-02-04 11:05 Groffy New Issue
2013-02-04 11:06 Groffy Note Added: 0065460
2013-02-04 11:30 Zeljan Rikalo LazTarget => -
2013-02-04 11:30 Zeljan Rikalo Note Added: 0065463
2013-02-04 11:30 Zeljan Rikalo Assigned To => Zeljan Rikalo
2013-02-04 11:30 Zeljan Rikalo Status new => assigned
2013-02-04 12:19 Groffy Note Added: 0065467
2013-02-04 17:43 Zeljan Rikalo Note Added: 0065476
2014-05-05 14:03 Zeljan Rikalo Fixed in Revision => 44925
2014-05-05 14:03 Zeljan Rikalo Note Added: 0074780
2014-05-05 14:03 Zeljan Rikalo Status assigned => resolved
2014-05-05 14:03 Zeljan Rikalo Resolution open => fixed