View Issue Details

IDProjectCategoryView StatusLast Update
0024329PatchesLCLpublic2014-01-15 13:00
ReporterBenito van der Zander Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.1 (SVN) 
Summary0024329: missing function in customdrawnwslazdeviceapis
DescriptionThere is a missing function in the non-android branch of customdrawnwslazdeviceapis, so it does not compile:

Index: /opt/lazarus/lcl/interfaces/customdrawn/customdrawnwslazdeviceapis.pas
===================================================================
--- /opt/lazarus/lcl/interfaces/customdrawn/customdrawnwslazdeviceapis.pas (revision 40899)
+++ /opt/lazarus/lcl/interfaces/customdrawn/customdrawnwslazdeviceapis.pas (working copy)
@@ -100,6 +100,10 @@
 
 end;
 
+class function TCDWSLazDeviceAPIs.GetScreenRotation(AScreenIndex: Integer): TScreenRotation;
+begin
+end;
+
 {$endif}
 
 {$ifdef CD_Android}
TagsNo tags attached.
Fixed in Revisionr43600
LazTarget-
Widgetset
Attached Files

Activities

Bart Broersma

2013-04-28 00:16

developer   ~0067197

Why not

class function TCDWSLazDeviceAPIs.GetScreenRotation(AScreenIndex: Integer
  ): TScreenRotation;
begin
  Result := inherited GetScreenRotation(AScreenIndex);
end;

Benito van der Zander

2013-04-28 12:03

reporter   ~0067206

Because all of the functions there are empty

Bart Broersma

2013-06-07 00:08

developer   ~0068103

AFAICS this was fixed in r40797.
Please reopen if I'm incorrect, otherwise please close.

Bart Broersma

2013-06-07 00:12

developer   ~0068104

Seems I was mistaken, sorry for that.

Bart Broersma

2013-12-27 16:26

developer   ~0072064

Applied Benito's patch.
Please close.

Issue History

Date Modified Username Field Change
2013-04-27 14:26 Benito van der Zander New Issue
2013-04-28 00:16 Bart Broersma Note Added: 0067197
2013-04-28 00:48 Bart Broersma LazTarget => -
2013-04-28 00:48 Bart Broersma Status new => confirmed
2013-04-28 12:03 Benito van der Zander Note Added: 0067206
2013-06-07 00:08 Bart Broersma Fixed in Revision => r40797
2013-06-07 00:08 Bart Broersma Note Added: 0068103
2013-06-07 00:08 Bart Broersma Status confirmed => resolved
2013-06-07 00:08 Bart Broersma Resolution open => fixed
2013-06-07 00:08 Bart Broersma Assigned To => Bart Broersma
2013-06-07 00:12 Bart Broersma Assigned To Bart Broersma =>
2013-06-07 00:12 Bart Broersma Note Added: 0068104
2013-06-07 00:12 Bart Broersma Status resolved => assigned
2013-06-07 00:12 Bart Broersma Resolution fixed => reopened
2013-12-27 16:26 Bart Broersma Fixed in Revision r40797 => r43600
2013-12-27 16:26 Bart Broersma Note Added: 0072064
2013-12-27 16:26 Bart Broersma Status assigned => resolved
2013-12-27 16:26 Bart Broersma Resolution reopened => fixed
2013-12-27 16:26 Bart Broersma Assigned To => Bart Broersma
2014-01-15 13:00 Benito van der Zander Status resolved => closed