View Issue Details

IDProjectCategoryView StatusLast Update
0025473LazarusIDEpublic2020-09-02 17:21
ReporterBond Keevil Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformGTK2OSLinux Mint 
Product Version1.2.0RC1 
Summary0025473: Form size and position is not saved by form designer
DescriptionThe forms Top, Left, Height and Width properties are not being saved by the form designer.

I have verified the problem exists in 1.0.14 and 1.2RC1
Steps To ReproduceCreate a new default project, move and resize the form, save the project. When you reopen the form in the form designer the form has it's default position and size.
Additional InformationThe issue first appeared when I upgraded to Linux Mint 16, which introduced Cinnamon 2.0 and MDM 1.4. I suspect it is related.
TagsNo tags attached.
Fixed in Revision44715
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0026349 resolvedZeljan Rikalo Unable to resize Forms at design time 

Activities

Bond Keevil

2013-12-31 04:28

reporter   ~0072122

I also noticed that this only happens when toggling between source and form view when using View | Toggle Form/Unit View. If I switch to the form by clicking on the form in my task bar the form does not lose it's size or position.

Also, it appears that the correct height/width, etc are being written to the form's lfm file but when I toggle from the source to the form by pressing F11 the height and width are then set back to the default values for a new form.

Juha Manninen

2013-12-31 08:33

developer   ~0072124

Cannot reproduce. I don't believe Cinnamon 2 would do such thing. Something else is going on in your system.

Bond Keevil

2014-01-05 22:07

reporter   ~0072238

The workaround, if anyone else experiences this problem, is to save the changes and restart lazarus after you position and resize your form.

Bart Broersma

2014-01-06 16:28

developer   ~0072258

Looking at some other issues by you, you seem to have a rather special computer ;-)

Bram van Vliet

2014-02-27 23:46

reporter   ~0073363

I can confirm i have the same issue with the formdesigner on Mint16

Zeljan Rikalo

2014-02-28 10:58

developer   ~0073365

@Bart, @Juha: everything is possible with Gtk2 ;)

@Bond: how did you change form size ? With mouse resize or via OI ?

Zeljan Rikalo

2014-04-13 13:21

developer   ~0074369

Please test and close if ok (will be merged to 1.2.2 release).

Bond Keevil

2014-06-17 16:59

reporter   ~0075764

Wonderful, it works thank you!

Bond Keevil

2017-09-20 21:19

reporter   ~0102954

This issue has reappeared. I'm using version 1.6.4 but I'm fairly sure the bug started again in an earlier version than this. Were these changes undone by someone?

Juha Manninen

2017-09-21 12:32

developer   ~0102963

Version 1.6 is not maintained any more.
Please test with 1.8 or trunk.

Zeljan Rikalo

2017-09-24 18:19

developer   ~0103025

Please write here exact window manager name.
You can get it via Gtk2WidgetSet.GetWindowManager function (include gtk2int in you project).

Juha Manninen

2020-09-02 17:21

developer   ~0125297

It has been almost 3 years. Resolving as "unable to reproduce".

Issue History

Date Modified Username Field Change
2013-12-31 02:20 Bond Keevil New Issue
2013-12-31 04:28 Bond Keevil Note Added: 0072122
2013-12-31 08:33 Juha Manninen Note Added: 0072124
2014-01-05 22:07 Bond Keevil Note Added: 0072238
2014-01-06 16:28 Bart Broersma Note Added: 0072258
2014-02-27 23:46 Bram van Vliet Note Added: 0073363
2014-02-28 10:58 Zeljan Rikalo Note Added: 0073365
2014-04-13 13:08 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-04-13 13:08 Zeljan Rikalo Status new => assigned
2014-04-13 13:21 Zeljan Rikalo Fixed in Revision => 44715
2014-04-13 13:21 Zeljan Rikalo LazTarget => -
2014-04-13 13:21 Zeljan Rikalo Note Added: 0074369
2014-04-13 13:21 Zeljan Rikalo Status assigned => resolved
2014-04-13 13:21 Zeljan Rikalo Resolution open => fixed
2014-06-17 15:14 Mattias Gaertner Relationship added related to 0026349
2014-06-17 16:59 Bond Keevil Note Added: 0075764
2017-09-20 21:19 Bond Keevil Note Added: 0102954
2017-09-20 21:21 Bond Keevil Status resolved => assigned
2017-09-20 21:21 Bond Keevil Resolution fixed => reopened
2017-09-21 12:32 Juha Manninen Note Added: 0102963
2017-09-24 18:19 Zeljan Rikalo Note Added: 0103025
2017-09-24 18:19 Zeljan Rikalo Status assigned => feedback
2020-09-02 17:21 Juha Manninen Status feedback => resolved
2020-09-02 17:21 Juha Manninen Resolution reopened => unable to reproduce
2020-09-02 17:21 Juha Manninen Widgetset GTK 2 => GTK 2
2020-09-02 17:21 Juha Manninen Note Added: 0125297