View Issue Details

IDProjectCategoryView StatusLast Update
0025588LazarusIDEpublic2019-04-22 19:33
ReporterMartin Friebe Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformw32OSwin 
Product Version1.2.0RC2 
Target Version1.2.0 
Summary0025588: RC regression / Crash in "Show project forms" (codetoolsstructs)
Descriptionhttp://forum.lazarus.freepascal.org/index.php/topic,23311.msg138989.html#msg138989

Needs the IDE compiled with -O2 and nothing else ( -gw is allowed)
fpc 2.6.2

Open the "View Forms" dialog, and choose a form

#0 FINDSUCCESSOR(0x36367b26, 0xe13920) at src\avl_tree.pp:847
0000001 MOVENEXT(0x11eba488) at codetoolsstructs.pas:749
0000002 OKBUTTONCLICK(0x36367b26, 0xe13920) at viewunit_dlg.pp:458

Same as the below, it crashes in MoveNext of the iterator
TagsNo tags attached.
Fixed in Revision43921
LazTarget1.2
Widgetset
Attached Files

Relationships

related to 0025681 closedMartin Friebe TAchart crash, when closing IDE 

Activities

Mattias Gaertner

2014-02-05 22:26

manager   ~0072868

No crash under Linux/gtk2 compiled with only -O2.

Martin Friebe

2014-02-06 20:20

manager   ~0072885

Most likely due to 0020827
Added workaround in rev 43921

Issue History

Date Modified Username Field Change
2014-01-24 17:32 Martin Friebe New Issue
2014-01-24 17:32 Martin Friebe LazTarget - => 1.2
2014-01-24 17:33 Martin Friebe Summary RC regression / Clash in "Show project forms" (codetoolsstructs) => RC regression / Crash in "Show project forms" (codetoolsstructs)
2014-02-05 21:24 Martin Friebe Relationship added related to 0025681
2014-02-05 22:26 Mattias Gaertner Note Added: 0072868
2014-02-06 20:20 Martin Friebe Fixed in Revision => 43921
2014-02-06 20:20 Martin Friebe Note Added: 0072885
2014-02-06 20:20 Martin Friebe Status new => resolved
2014-02-06 20:20 Martin Friebe Resolution open => fixed
2014-02-06 20:20 Martin Friebe Assigned To => Martin Friebe
2019-04-22 19:33 Martin Friebe Status resolved => closed