View Issue Details

IDProjectCategoryView StatusLast Update
0025681LazarusPackagespublic2019-04-22 19:33
ReporterMartin Friebe Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformw32OSwin 
Product Version1.3 (SVN) 
Summary0025681: TAchart crash, when closing IDE
DescriptionUsing fpc 2.6.2 / Lazarus svn trunk
Interestingly this crashes depending on compileropts. So it may have been there for an unknown amount of time

With my normal settings -gh -Criot it works.

But with ONLY
-gw -O2

it crashes

#0 MOVENEXT(0x1232d6c) at ..\objpas\classes\lists.inc:35
0000001 DESTROY(0xfc011a8, 0x1232d6c) at tachartutils.pas:777
0000002 $TATRANSFORMATIONS$_Ld12 at :0
0000003 FREE(0xe6ffd5c) at ..\inc\objpas.inc:278
0000004 FREEANDNIL(0) at ..\objpas\sysutils\sysutils.inc:153
0000005 DESTROY(0xfc011a8, 0x1232d6c) at tatransformations.pas:496
0000006 FREE(0xe6ffd5c) at ..\inc\objpas.inc:278
0000007 FREEANDNIL(0) at ..\objpas\sysutils\sysutils.inc:153
0000008 TACHARTAXIS_finalize at tachartaxis.pas:1165
0000009 FINALIZEUNITS at ..\inc\system.inc:833
0000010 INTERNALEXIT at ..\inc\system.inc:886
0000011 DO_EXIT at ..\inc\system.inc:937
0000012 main at lazarus.pp:142
Additional InformationThis may be a regression / not tested
TagsNo tags attached.
Fixed in Revision43922
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0025588 closedMartin Friebe RC regression / Crash in "Show project forms" (codetoolsstructs) 

Activities

Martin Friebe

2014-02-05 21:25

manager   ~0072865

possible related to 0025588

Both issues describe a crash in a for ... in loop when compiled with -O2

Martin Friebe

2014-02-06 20:21

manager   ~0072886

Most likely due to 0020827
Added workaround in rev 43922

Issue History

Date Modified Username Field Change
2014-02-05 21:24 Martin Friebe New Issue
2014-02-05 21:24 Martin Friebe Relationship added related to 0025588
2014-02-05 21:25 Martin Friebe Note Added: 0072865
2014-02-06 20:21 Martin Friebe Fixed in Revision => 43922
2014-02-06 20:21 Martin Friebe LazTarget - => 1.2
2014-02-06 20:21 Martin Friebe Note Added: 0072886
2014-02-06 20:21 Martin Friebe Status new => resolved
2014-02-06 20:21 Martin Friebe Resolution open => fixed
2014-02-06 20:21 Martin Friebe Assigned To => Martin Friebe
2019-04-22 19:33 Martin Friebe Status resolved => closed