View Issue Details

IDProjectCategoryView StatusLast Update
0025787LazarusInstallerpublic2014-04-12 04:04
Reportertintinux Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOS7 
Product Version1.2.0RC2 
Target Version1.4 
Summary0025787: Name of Cross Compiler Windows Installer is wrong
DescriptionThe installer of 1.2RC2 Cross compiler i386-win32-win64 is labelled "Lazarus", and this name is displayed several times during the installation process.

It should be labelled "Cross compiler" or "Lazarus Cross compiler" or anything more specific than "Lazarus".

Steps To ReproduceDowload

http://sourceforge.net/projects/lazarus/files/Lazarus%20Windows%2064%20bits/Lazarus%201.2RC2/lazarus-1.2RC2-fpc-2.6.2-cross-i386-win32-win64.exe/download

Run and look at the titles and messages.
TagsNo tags attached.
Fixed in Revision44692
LazTarget1.4
Widgetset
Attached Files

Activities

Martin Friebe

2014-02-26 21:47

manager   ~0073342

May not be as simple as it looks on first sight.

Afaik Inno-Setup adds the uninstall info to the existing uninstall of the actual lazarus install.
There are also entries that affect where in the win registry inno is adding the info.

Need to identify which fields in the inno template affect which feature.

tintinux

2014-02-27 08:43

reporter   ~0073345

Hi

From InnoSetup documentation : " 'Same application' refers to two separate installations that share the same AppId setting (or if AppId is not set, the same AppName setting), and the same install mode (32-bit or 64-bit)."

Provided the installer uses a Appid (GUI), I think that that 'AppName' can be changed without affecting the uninstall or anything else.

I suppose that this is true because otherwise uninstalling the cross compiler would uninstall the IDE which have the same AppName.

Reinier Olislagers

2014-02-27 09:47

developer   ~0073349

Tintinux 0073345 is correct: "application" is defined by AppId. Used it for updates myself.

Martin Friebe

2014-04-12 04:04

manager   ~0074333

AppName={#AppName} - Addon for target {#CrossTagetOs}-{#CrossTargetCPU}
UpdateUninstallLogAppName=no

The last sine was also needed, to avoid that uninstalling lazarus (the actual entire lazarus), would wrongly ask, if it should uninstall the addon.

Issue History

Date Modified Username Field Change
2014-02-26 13:37 tintinux New Issue
2014-02-26 17:50 Martin Friebe Assigned To => Martin Friebe
2014-02-26 17:50 Martin Friebe Status new => assigned
2014-02-26 21:47 Martin Friebe LazTarget => 1.4
2014-02-26 21:47 Martin Friebe Note Added: 0073342
2014-02-26 21:47 Martin Friebe Target Version => 1.4
2014-02-27 08:43 tintinux Note Added: 0073345
2014-02-27 09:47 Reinier Olislagers Note Added: 0073349
2014-04-12 04:04 Martin Friebe Fixed in Revision => 44692
2014-04-12 04:04 Martin Friebe Note Added: 0074333
2014-04-12 04:04 Martin Friebe Status assigned => resolved
2014-04-12 04:04 Martin Friebe Resolution open => fixed