View Issue Details

IDProjectCategoryView StatusLast Update
0026672PackagesLCLpublic2014-09-07 10:15
Reportersierdolg Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntelOSLinux 
Product Version1.2.4 
Target Version1.2.6Fixed in Version1.3 (SVN) 
Summary0026672: TPairSplitterSide does not publish Contraints property (in Linux, too)
DescriptionSetting constraints in code, e.g.


procedure TForm1.FormActivate(Sender: TObject);
begin
  PairSplitterSide1.Constraints.MinWidth:=50;
  PairSplitterSide2.Constraints.MinWidth:=50;
end;

works as expected, but constraints property does not appear in Object Inspector.
Steps To Reproduce1) Start a new application project.
2) Place a PairSplitter on its empy Form, set it to "Align:alClient".
3) Put one visual control (e.g. a Button) into each SplitterSide.
4) Select any PairSplitterSideX in Object Inspector: there is no "Constraints" entry between "ChildSizing" and "Cursor".

Additional InformationThis makes constraints unusable in a RAD tool's intended (visual) way.
However, they can be set in code as a workaround.

Easy Fix: Insert " property Constraints;" as line 63 into /usr/share/lazarus/1.2.4/lcl/pairsplitter.pas and recompile IDE.

See http://bugs.freepascal.org/view.php?id=25046 for the same on Windows! Hence, any other flavours of "pairsplitter.pas" (except Windows since Rev. 42854) are likely to contain the same problem.
TagsNo tags attached.
Fixed in Revision46130
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Zeljan Rikalo

2014-09-03 14:12

developer   ~0076864

Does Delphi publish Constraints property ?

sierdolg

2014-09-03 14:19

reporter   ~0076865

Last edited: 2014-09-03 14:22

View 2 revisions

Sorry, I never had Delphi at all. But

1) Delphi has TSplitter, but not TPairSplitter (as documented on http://wiki.freepascal.org/Lazarus_Components )

2) Windows version of Lazarus does publish this property since 2 years, and IMHO missing constraints in object inspector renders the whole IDE concept quite senseless at all ,-)


(Why use a RAD IDE if you want to write everything in code anyway?)

wp

2014-09-03 14:21

developer   ~0076866

Delphi does not have a PairSplitter, but all other components have Constraints published

Bart Broersma

2014-09-03 15:15

developer   ~0076869

> Windows version of Lazarus does publish this property since 2 years
At least in trunk this is not true.
Your fix suggests as much. The property simply isn't published at all.

Zeljan Rikalo

2014-09-03 16:09

developer   ~0076875

Then it will be published.

sierdolg

2014-09-03 16:40

reporter   ~0076876

Great. Thanks!

Zeljan Rikalo

2014-09-05 10:37

developer   ~0076902

Please test and close if ok.

Zeljan Rikalo

2014-09-07 10:15

developer   ~0076947

Updated target version.

Issue History

Date Modified Username Field Change
2014-09-03 14:10 sierdolg New Issue
2014-09-03 14:12 Zeljan Rikalo LazTarget => -
2014-09-03 14:12 Zeljan Rikalo Note Added: 0076864
2014-09-03 14:12 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-09-03 14:12 Zeljan Rikalo Status new => feedback
2014-09-03 14:19 sierdolg Note Added: 0076865
2014-09-03 14:19 sierdolg Status feedback => assigned
2014-09-03 14:21 wp Note Added: 0076866
2014-09-03 14:22 sierdolg Note Edited: 0076865 View Revisions
2014-09-03 15:15 Bart Broersma Note Added: 0076869
2014-09-03 16:09 Zeljan Rikalo Note Added: 0076875
2014-09-03 16:40 sierdolg Note Added: 0076876
2014-09-05 10:37 Zeljan Rikalo Fixed in Revision => 46130
2014-09-05 10:37 Zeljan Rikalo Note Added: 0076902
2014-09-05 10:37 Zeljan Rikalo Status assigned => resolved
2014-09-05 10:37 Zeljan Rikalo Resolution open => fixed
2014-09-07 10:15 Zeljan Rikalo Note Added: 0076947
2014-09-07 10:15 Zeljan Rikalo Fixed in Version => 1.3 (SVN)
2014-09-07 10:15 Zeljan Rikalo Target Version => 1.2.6