View Issue Details

IDProjectCategoryView StatusLast Update
0027298LazarusWidgetsetpublic2015-01-13 19:01
ReporterKrzysztof Dibowski Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSKubuntu 
Product Version1.2.6 
Summary0027298: TListView - Double click on list with OwnerData freeze application
DescriptionHi,

Double click on list view with OwnerData = True freeze aplication (ReadOnly is also TRUE)

Regards
Steps To Reproduce1. Run attached demo
2. Click Button1 to add items
3. Double click on random item
Additional InformationLazarus 1.2.6 but tested also with 1.3 from SVN (revision 47287M) and same problem
FPC 2.6.4
Kubuntu 14.04 64 bit, Qt widgetset
TagsNo tags attached.
Fixed in Revision47374
LazTarget-
WidgetsetQT
Attached Files

Activities

Krzysztof Dibowski

2015-01-12 21:32

reporter  

Bart Broersma

2015-01-13 00:42

developer   ~0080328

> (revision 47287M)
Means you have local modifications.
Please test without them.

I cannot reproduce with trunk on Windows (Lazarus 1.5 r47338 FPC 2.6.4 i386-win32-win32/win64), so might be widgetset issue).

Bart Broersma

2015-01-13 00:59

developer   ~0080329

Confirmed with QT Linux (Lazarus 1.5 r47338 FPC 2.6.2)

Zeljan Rikalo

2015-01-13 12:13

developer   ~0080335

It crashes when list is readonly too ?

Krzysztof Dibowski

2015-01-13 13:22

reporter   ~0080338

Yes

Zeljan Rikalo

2015-01-13 18:39

developer   ~0080359

Please test and close if ok. I'm just wondering why this bug does not trigger when OwnerData = False.

Krzysztof Dibowski

2015-01-13 19:01

reporter   ~0080361

Fixed. Thanks!

Issue History

Date Modified Username Field Change
2015-01-12 21:32 Krzysztof Dibowski New Issue
2015-01-12 21:32 Krzysztof Dibowski File Added: ListViewDoubleClickFreeze.zip
2015-01-13 00:42 Bart Broersma Note Added: 0080328
2015-01-13 00:59 Bart Broersma Note Added: 0080329
2015-01-13 00:59 Bart Broersma LazTarget => -
2015-01-13 00:59 Bart Broersma Status new => confirmed
2015-01-13 00:59 Bart Broersma Category LCL => Widgetset
2015-01-13 07:43 Zeljan Rikalo Assigned To => Zeljan Rikalo
2015-01-13 07:43 Zeljan Rikalo Status confirmed => assigned
2015-01-13 12:13 Zeljan Rikalo Note Added: 0080335
2015-01-13 13:22 Krzysztof Dibowski Note Added: 0080338
2015-01-13 18:39 Zeljan Rikalo Fixed in Revision => 47374
2015-01-13 18:39 Zeljan Rikalo Note Added: 0080359
2015-01-13 18:39 Zeljan Rikalo Status assigned => resolved
2015-01-13 18:39 Zeljan Rikalo Resolution open => fixed
2015-01-13 19:01 Krzysztof Dibowski Note Added: 0080361
2015-01-13 19:01 Krzysztof Dibowski Status resolved => closed