View Issue Details

IDProjectCategoryView StatusLast Update
0027559LazarusLCLpublic2015-02-28 13:45
ReporterVojtech Cihak Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSLinux 
Product Version1.5 (SVN) 
Summary0027559: TSplitter with ResizeStyle=rsNone crashes
DescriptionTSplitter with ResizeStyle=rsNone causes crash when you attempt to move it. Tested in Qt and GTk2.
Steps To ReproduceRun demo. Switch ResizeStyle to rsNone in Combo. Try to move the splitter. It causes crash. Other styles works well.
Additional InformationLazarus 1.5 r48026M FPC 3.1.1 x86_64-linux-qt
TagsNo tags attached.
Fixed in Revision48041,48042,48047,48048
LazTarget-
WidgetsetGTK 2, QT
Attached Files

Activities

Vojtech Cihak

2015-02-28 00:00

reporter  

ResizeStyle.zip (6,874 bytes)

Zeljan Rikalo

2015-02-28 12:43

developer   ~0081503

Please test and close if ok.

Vojtech Cihak

2015-02-28 13:15

reporter   ~0081506

I tested with r. 48046 and both GTk2 and Qt4 crashes.

Zeljan Rikalo

2015-02-28 13:31

developer   ~0081507

Yes, both crashes because of bug in LCL.

Zeljan Rikalo

2015-02-28 13:34

developer   ~0081508

Pls. test and close if ok. Note that r48047 fixes crash, r48048 fixes memleak (reproducable with qt and gtk2).

Vojtech Cihak

2015-02-28 13:45

reporter   ~0081509

Tested with r.48048. Both Qt and GTk2 demos run well and I didn't notice any memleak. Thanks.

Issue History

Date Modified Username Field Change
2015-02-28 00:00 Vojtech Cihak New Issue
2015-02-28 00:00 Vojtech Cihak File Added: ResizeStyle.zip
2015-02-28 12:43 Zeljan Rikalo Fixed in Revision => 48041,48042
2015-02-28 12:43 Zeljan Rikalo LazTarget => -
2015-02-28 12:43 Zeljan Rikalo Note Added: 0081503
2015-02-28 12:43 Zeljan Rikalo Status new => resolved
2015-02-28 12:43 Zeljan Rikalo Resolution open => fixed
2015-02-28 12:43 Zeljan Rikalo Assigned To => Zeljan Rikalo
2015-02-28 13:15 Vojtech Cihak Note Added: 0081506
2015-02-28 13:15 Vojtech Cihak Status resolved => assigned
2015-02-28 13:15 Vojtech Cihak Resolution fixed => reopened
2015-02-28 13:31 Zeljan Rikalo Note Added: 0081507
2015-02-28 13:34 Zeljan Rikalo Fixed in Revision 48041,48042 => 48041,48042,48047,48048
2015-02-28 13:34 Zeljan Rikalo Note Added: 0081508
2015-02-28 13:34 Zeljan Rikalo Status assigned => resolved
2015-02-28 13:34 Zeljan Rikalo Resolution reopened => fixed
2015-02-28 13:45 Vojtech Cihak Note Added: 0081509
2015-02-28 13:45 Vojtech Cihak Status resolved => closed