View Issue Details

IDProjectCategoryView StatusLast Update
0029739LazarusPackagespublic2017-04-28 23:31
ReporterDmitry Assigned ToMichl  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWin32-64OSWindows 
Product Version1.6 
Target Version1.9 (SVN) 
Summary0029739: Closing app with TrayIcon.Visible=True in debug mode => External: SIGSEGV after heaptrc message
DescriptionCreate application, create a debug mode,
TrayIcon throw on the form, set TrayIcon.Visible=True,
run the application, close the application,
press OK, see External: SIGSEGV.
Steps To ReproduceCreate application,
create a debug mode,
TrayIcon throw on the form,
set TrayIcon.Visible=True,
run the application,
close the application,
press OK,
see External: SIGSEGV.
TagsNo tags attached.
Fixed in Revisionr54766
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Dmitry

2016-02-29 07:57

reporter   ~0090461

On Windows XP all normal work.

Dmitry

2016-02-29 07:58

reporter   ~0090462

On Windows 10 this bug too.

Dmitry

2016-02-29 19:40

reporter  

Video_2016-02-29_213601.zip (1,973,207 bytes)

Robert Rosendahl

2016-03-02 00:26

reporter   ~0090536

Last edited: 2016-03-02 00:28

View 2 revisions

I've got a similar problem: also a SIGSEGV in the tray icon when i close my application. However, it only seems to cause a SIGSEGV if the tray icon hint (the normal hint, not the balloon hint) has appeared at least once. I'm not sure if the problem is related to that.

Anyway, here's the stack trace at the moment of the SIGSEGV:

#0 LCLINTF_$$_GETWINDOWLONG$LONGWORD$LONGINT$$LONGINT at :0
#1 WIN32WSEXTCTRLS_$$_TRAYWNDPROC$LONGWORD$LONGWORD$LONGINT$LONGINT$$LONGINT at :0
#2 USER32!SetManipulationInputTarget at :0
#3 USER32!CallWindowProcW at :0
#4 USER32!DispatchMessageW at :0
#5 USER32!PeekMessageW at :0
#6 ntdll!KiUserCallbackDispatcher at :0
#7 ?? at :0
#8 USER32!PeekMessageW at :0
#9 USER32!IsDialogMessageA at :0
#10 USER32!DialogBoxIndirectParamAorW at :0
#11 USER32!SoftModalMessageBox at :0
#12 USER32!MessageBoxW at :0
#13 USER32!MessageBoxTimeoutW at :0
#14 USER32!MessageBoxTimeoutA at :0
#15 USER32!MessageBoxExA at :0
#16 USER32!MessageBoxA at :0
#17 SYSTEM_$$_ERRORCLOSE$TEXTREC at :0
#18 SYSTEM_$$_CLOSE$TEXT at :0
#19 SYSTEM_$$_SYSTEM_EXIT at :0
#20 SYSTEM_$$_DO_EXIT at :0
#21 main at MyApplication.lpr:136

Robert Rosendahl

2016-03-15 22:05

reporter  

TrayIconProject.zip (206,362 bytes)

Robert Rosendahl

2016-03-15 22:09

reporter   ~0091093

Last edited: 2016-03-15 22:10

View 2 revisions

I took the liberty to create a small lazarus project to reproduce the problem (see attachment TrayIconProject.zip). If you open the project, set the compile mode to "Debug", build the project and run it, then the tray icon should appear and directly show a balloon hint. If you click the "Exit" button, while the balloon is still visible (it times out at 10 seconds), then you should be able to reproduce the segmentation fault.
If i can further assist then let me know. I'm running the 32-bit version of Lazarus on a Windows 10 64-bit system, by the way (i need to compile 32-bit binaries because of some 32-bit dll libraries i need to use...).

Michl

2017-04-28 23:31

developer   ~0099989

Fixed in Trunk. Plese test and close if ok.

Issue History

Date Modified Username Field Change
2016-02-26 23:55 Dmitry New Issue
2016-02-29 07:57 Dmitry Note Added: 0090461
2016-02-29 07:58 Dmitry Note Added: 0090462
2016-02-29 19:40 Dmitry File Added: Video_2016-02-29_213601.zip
2016-03-02 00:26 Robert Rosendahl Note Added: 0090536
2016-03-02 00:28 Robert Rosendahl Note Edited: 0090536 View Revisions
2016-03-02 12:19 Maxim Ganetsky LazTarget => -
2016-03-02 12:19 Maxim Ganetsky Summary When close app with TrayIcon.Visible=True in debug mode after message heaptrc see External: SIGSEGV. => Closing app with TrayIcon.Visible=True in debug mode => External: SIGSEGV after heaptrc message
2016-03-15 22:05 Robert Rosendahl File Added: TrayIconProject.zip
2016-03-15 22:09 Robert Rosendahl Note Added: 0091093
2016-03-15 22:10 Robert Rosendahl Note Edited: 0091093 View Revisions
2017-04-28 23:19 Michl Assigned To => Michl
2017-04-28 23:19 Michl Status new => assigned
2017-04-28 23:31 Michl Fixed in Revision => r54766
2017-04-28 23:31 Michl Widgetset => Win32/Win64
2017-04-28 23:31 Michl Note Added: 0099989
2017-04-28 23:31 Michl Status assigned => resolved
2017-04-28 23:31 Michl Resolution open => fixed
2017-04-28 23:31 Michl Target Version => 1.9 (SVN)