View Issue Details

IDProjectCategoryView StatusLast Update
0034752LazarusLCLpublic2018-12-24 10:29
ReporterZoran VučenovićAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86-64OSLinux MintOS Version18.3
Product Version2.1 (SVN)Product Build59892 
Target VersionFixed in Version 
Summary0034752: Qt - TCalendar does not receive LM_KEYDOWN and LM_KEYUP when pressing arrow keys (up, down, left, right).
DescriptionIn Qt, TCalendar does not receive key messages when a cursor (arrow - left, right, etc.) key gets pressed.
Unlike Qt, Gtk2 and Win32/64 do receive these.

I'm attaching a test application.
Steps To ReproduceTake a look at attached application. Compile with Qt widgetset and start.

The application shows that:
- WindowProc in TCalendar never receives LM_KEYDOWN and LM_KEYUP when an arrow key is pressed.
- as a consequence, events OnKeyDown and OnKeyUp do not work with arrow keys.

When compiled with Gtk2, everything works, as well as in Windows (win widgetset).

Tested in Linux Mint 18.3 64-bit Xfce (Qt4 and Gtk2 ws) and Windows 8 (win ws).
TagsNo tags attached.
Fixed in Revision59894
LazTarget-
WidgetsetQT, QT5
Attached Files

Activities

Zoran Vučenović

2018-12-22 13:43

developer  

KeysTestCalendar.zip (130,150 bytes)

Zeljan Rikalo

2018-12-22 14:12

developer   ~0112810

Added Qt5 too since it have same problem.

Zeljan Rikalo

2018-12-22 14:54

developer   ~0112812

Please test and close if ok.

Zoran Vučenović

2018-12-24 10:29

developer   ~0112857

Works now, thank you.
Closing.

Issue History

Date Modified Username Field Change
2018-12-22 13:43 Zoran Vučenović New Issue
2018-12-22 13:43 Zoran Vučenović File Added: KeysTestCalendar.zip
2018-12-22 14:08 Zeljan Rikalo Assigned To => Zeljan Rikalo
2018-12-22 14:08 Zeljan Rikalo Status new => assigned
2018-12-22 14:12 Zeljan Rikalo Widgetset QT => QT, QT5
2018-12-22 14:12 Zeljan Rikalo Note Added: 0112810
2018-12-22 14:54 Zeljan Rikalo Fixed in Revision => 59894
2018-12-22 14:54 Zeljan Rikalo Note Added: 0112812
2018-12-22 14:54 Zeljan Rikalo Status assigned => resolved
2018-12-22 14:54 Zeljan Rikalo Resolution open => fixed
2018-12-24 10:29 Zoran Vučenović Note Added: 0112857
2018-12-24 10:29 Zoran Vučenović Status resolved => closed