View Issue Details

IDProjectCategoryView StatusLast Update
0035764LazarusIDEpublic2019-07-01 11:27
ReporterMartin Friebe Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform64bit IntelOSwin 10 
Product Version2.1 (SVN) 
Summary0035764: IDE toolstatus goes wrong (IDE forgets that app is running)
DescriptionIf an app is running under the debugger, the IDE should (and normally does) refuse to build the project.

- Run an app in the debugger
- Run > Compile : Error
- Run > Run : No Error, but not compiling. However Status is reset. IDE no longer knows that the app is running.
- Run > Run: IDE tries to build (fail to create exe file, as it is in use by the still running app)
TagsNo tags attached.
Fixed in Revision61504.
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Martin Friebe

2019-06-30 23:59

manager   ~0117022

Last edited: 2019-07-01 00:04

View 2 revisions

This happens in (called by F9, while debugger is running)
  TMainIDE.DoRunProject
which calls

    Result := DebugBoss.StartDebugging;
  finally
    if Result<>mrOk then
      ToolStatus:=itNone;
  end;

StartDebugging returns mrCancel, and so the ToolStatus is reset. But the debugger still running.

--------------
Probably caused by
Revision: 60730
Author: mattias
Date: 20 March 2019 00:57:21
Message:
IDE: rundebug: restore toolstatus on error

Issue History

Date Modified Username Field Change
2019-06-25 15:19 Martin Friebe New Issue
2019-06-30 23:59 Martin Friebe Note Added: 0117022
2019-07-01 00:04 Martin Friebe Note Edited: 0117022 View Revisions
2019-07-01 10:18 Mattias Gaertner Assigned To => Mattias Gaertner
2019-07-01 10:18 Mattias Gaertner Status new => resolved
2019-07-01 10:18 Mattias Gaertner Resolution open => fixed
2019-07-01 10:18 Mattias Gaertner Fixed in Revision => 61504.
2019-07-01 10:18 Mattias Gaertner LazTarget => -
2019-07-01 10:18 Mattias Gaertner Widgetset Win32/Win64 => Win32/Win64
2019-07-01 11:27 Martin Friebe Status resolved => closed