View Issue Details

IDProjectCategoryView StatusLast Update
0010117FPCInstallerpublic2009-03-19 19:07
ReporterVincent SnijdersAssigned ToPeter Vreman 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSWindowsOS VersionXP Home SP2
Product VersionProduct Build 
Target Version2.2.2Fixed in Version2.2.2 
Summary0010117: fclel resource is not installed
DescriptionThe windows installer of fpc 2.2.0 does not install the fclel resource. This resources is used by a lazarus daemon example. The compiled resource should probably be installed in units\i386-win32\fcl-base.
TagsNo tags attached.
Fixed in Revision9762
FPCOldBugId0
FPCTarget2.2.2
Attached Files
  • svn.diff (525 bytes)
    Index: fpcsrc/packages/fcl-base/Makefile.fpc
    ===================================================================
    --- fpcsrc/packages/fcl-base/Makefile.fpc	(révision 11107)
    +++ fpcsrc/packages/fcl-base/Makefile.fpc	(copie de travail)
    @@ -47,6 +47,14 @@
     includedir_wince=src/win
     sourcedir=src/$(OS_TARGET) src
     
    +[prerules]
    +ifeq(${OS_TARGETr}),win32)
    +INSTALL_DATADIR=${INSTALL_UNITDIR}
    +endif
    +ifeq(${OS_TARGETr}),win64)
    +INSTALL_DATADIR=${INSTALL_UNITDIR}
    +endif
    +
     [install]
     fpcpackage=y
     files_win32=src/win/fclel.res
    
    svn.diff (525 bytes)
  • fclel.patch (2,167 bytes)
    Index: Makefile
    ===================================================================
    --- Makefile	(revision 11107)
    +++ Makefile	(working copy)
    @@ -1,5 +1,5 @@
     #
    -# Don't edit, this file is generated by FPCMake Version 2.0.0 [2008/05/28]
    +# Don't edit, this file is generated by FPCMake Version 2.0.0 [2008/05/27]
     #
     default: all
     MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded
    @@ -259,6 +259,12 @@
     PACKAGESDIR:=$(wildcard $(FPCDIR) $(FPCDIR)/packages $(FPCDIR)/packages/base $(FPCDIR)/packages/extra)
     override PACKAGE_NAME=fcl-base
     override PACKAGE_VERSION=2.0.0
    +ifeq ($(OS_TARGET),win32)
    +INSTALL_DATADIR=${INSTALL_UNITDIR}
    +endif
    +ifeq ($(OS_TARGET),win64)
    +INSTALL_DATADIR=${INSTALL_UNITDIR}
    +endif
     ifeq ($(FULL_TARGET),i386-linux)
     override TARGET_UNITS+=contnrs inifiles rtfpars idea base64 gettext iostream cachecls avl_tree uriparser eventlog custapp wformat whtml wtex rttiutils bufstream streamex blowfish streamio inicol pooledmm libtar streamcoll maskutils  syncobjs daemonapp fptimer
     endif
    Index: Makefile.fpc
    ===================================================================
    --- Makefile.fpc	(revision 11107)
    +++ Makefile.fpc	(working copy)
    @@ -49,6 +49,14 @@
     includedir_wince=src/win
     sourcedir=src/$(OS_TARGET) src
     
    +[prerules]
    +ifeq ($(OS_TARGET),win32)
    +INSTALL_DATADIR=${INSTALL_UNITDIR}
    +endif
    +ifeq ($(OS_TARGET),win64)
    +INSTALL_DATADIR=${INSTALL_UNITDIR}
    +endif
    +
     [install]
     fpcpackage=y
     files_win32=src/win/fclel.res
    
    fclel.patch (2,167 bytes)

Activities

Michael Van Canneyt

2007-12-29 23:11

administrator   ~0016948

Make install will now install fclel.res, so it should be picked up by the installer

Vincent Snijders

2007-12-30 21:56

manager   ~0016971

Using r9581 (9582 and later doesn't cycle) gives:
make.exe[2]: Entering directory `C:/lazarus/source/fpc/2.3/packages/fcl-base'
C:\lazarus\source\fpc\2.3\utils\fpcm\fpcmake.exe -p -Ti386-win32 Makefile.fpc
Processing Makefile.fpc
 Writing Package.fpc
C:/lazarus/source/fpcbuild/2.3/install/binw32/ginstall.exe -m 755 -d C:\fpc\2.3.1/units/i386-win32/fcl-base
C:/lazarus/source/fpcbuild/2.3/install/binw32/cp.exe -fp Package.fpc C:\fpc\2.3.1/units/i386-win32/fcl-base
C:/lazarus/source/fpcbuild/2.3/install/binw32/ginstall.exe -m 755 -d C:\fpc\2.3.1/units/i386-win32/fcl-base
C:/lazarus/source/fpcbuild/2.3/install/binw32/cp.exe -fp units/i386-win32/contnrs.ppu units/i386-win32/inifiles.ppu units/i386-win32/ezcgi.ppu units/i386-win32/rtfpars.ppu units/i386-win32/idea.ppu units/i386-win32/base64.ppu units/i386-win32/gettext.ppu units/i386-win32/iostream.ppu units/i386-win32/cachecls.ppu units/i386-win32/avl_tree.ppu units/i386-win32/eventlog.ppu units/i386-win32/custapp.ppu units/i386-win32/cgiapp.ppu units/i386-win32/wformat.ppu units/i386-win32/whtml.ppu units/i386-win32/wtex.ppu units/i386-win32/rttiutils.ppu units/i386-win32/bufstream.ppu units/i386-win32/streamex.ppu units/i386-win32/blowfish.ppu units/i386-win32/streamio.ppu units/i386-win32/inicol.ppu units/i386-win32/pooledmm.ppu units/i386-win32/libtar.ppu units/i386-win32/streamcoll.ppu units/i386-win32/maskutils.ppu units/i386-win32/fileinfo.ppu units/i386-win32/syncobjs.ppu units/i386-win32/daemonapp.ppu units/i386-win32/ServiceManager.ppu units/i386-win32/fptimer.ppu C:\fpc\2.3.1/units/i386-win32/fcl-base
C:/lazarus/source/fpcbuild/2.3/install/binw32/cp.exe -fp units/i386-win32/contnrs.o units/i386-win32/inifiles.o units/i386-win32/ezcgi.o units/i386-win32/rtfpars.o units/i386-win32/idea.o units/i386-win32/base64.o units/i386-win32/gettext.o units/i386-win32/iostream.o units/i386-win32/cachecls.o units/i386-win32/avl_tree.o units/i386-win32/eventlog.o units/i386-win32/custapp.o units/i386-win32/cgiapp.o units/i386-win32/wformat.o units/i386-win32/whtml.o units/i386-win32/wtex.o units/i386-win32/rttiutils.o units/i386-win32/bufstream.o units/i386-win32/streamex.o units/i386-win32/blowfish.o units/i386-win32/streamio.o units/i386-win32/inicol.o units/i386-win32/pooledmm.o units/i386-win32/libtar.o units/i386-win32/streamcoll.o units/i386-win32/maskutils.o units/i386-win32/fileinfo.o units/i386-win32/syncobjs.o units/i386-win32/daemonapp.o units/i386-win32/ServiceManager.o units/i386-win32/fptimer.o units/i386-win32/libimpdaemonapp.a C:\fpc\2.3.1/units/i386-win32/fcl-base
C:/lazarus/source/fpcbuild/2.3/install/binw32/ginstall.exe -m 755 -d C:\fpc\2.3.1
C:/lazarus/source/fpcbuild/2.3/install/binw32/cp.exe -fp fclel.res C:\fpc\2.3.1
cp.exe: fclel.res: No such file or directory
make.exe[2]: *** [fpc_install] Error 1
make.exe[2]: Leaving directory `C:/lazarus/source/fpc/2.3/packages/fcl-base'
make.exe[1]: *** [fcl-base_install] Error 2
make.exe[1]: Leaving directory `C:/lazarus/source/fpc/2.3/packages'
C:\lazarus\source\fpcbuild\2.3\install\binw32\make.exe: *** [packages_install] Error 2

Michael Van Canneyt

2007-12-30 22:00

administrator   ~0016973

Added the correct paths. I cannot test for windows, so it's untested.

Vincent Snijders

2007-12-30 23:00

manager   ~0016981

It is copied to the install root:
C:/lazarus/source/fpcbuild/2.3/install/binw32/cp.exe -fp src/win/fclel.res C:\fpc\2.3.1

I think it should be copied to C:\fpc\2.3.1/units/i386-win32/fcl-base

Michael Van Canneyt

2007-12-30 23:06

administrator   ~0016983

Assigning to peter, I don't know how to fix that using fpcmake.

Abou Al Montacir

2008-05-27 23:36

manager   ~0019765

The problem is that files_win32=src/win/fclel.res will add the files to INSTALL_FILES which are copied to INSTALL_DATADIR. This latter is eaqual to INSTALL_BASEDIR wich seems not be the correct path (cf note 0016981). This may be fixed by explicitely setting INSTALL_DATADIR to ${INSTALL_BASEDIR}/units/${CPU_TARGET}-${OS_TARGET}/${PACKAGE_NAME} or to ${INSTALL_UNITDIR}.

Vincent, could you change Makefile.fpc with either of the two suggestions and let me know if it fixes the issue, please?

Vincent Snijders

2008-05-28 00:03

manager   ~0019766

Mazen, can you create a patch for this?

2008-05-28 10:16

 

svn.diff (525 bytes)
Index: fpcsrc/packages/fcl-base/Makefile.fpc
===================================================================
--- fpcsrc/packages/fcl-base/Makefile.fpc	(révision 11107)
+++ fpcsrc/packages/fcl-base/Makefile.fpc	(copie de travail)
@@ -47,6 +47,14 @@
 includedir_wince=src/win
 sourcedir=src/$(OS_TARGET) src
 
+[prerules]
+ifeq(${OS_TARGETr}),win32)
+INSTALL_DATADIR=${INSTALL_UNITDIR}
+endif
+ifeq(${OS_TARGETr}),win64)
+INSTALL_DATADIR=${INSTALL_UNITDIR}
+endif
+
 [install]
 fpcpackage=y
 files_win32=src/win/fclel.res
svn.diff (525 bytes)

Abou Al Montacir

2008-05-28 10:18

manager   ~0019779

Patch should fix the issue temporary, the real issue is in fpcmake which should set INSTALL_DATADIR correctly.

Vincent Snijders

2008-05-28 10:33

manager   ~0019782

Why
+ifeq(${OS_TARGETr}),win32)
and not
+ifeq(${OS_TARGET}),win32)
?

2008-05-28 11:55

 

fclel.patch (2,167 bytes)
Index: Makefile
===================================================================
--- Makefile	(revision 11107)
+++ Makefile	(working copy)
@@ -1,5 +1,5 @@
 #
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2008/05/28]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2008/05/27]
 #
 default: all
 MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded
@@ -259,6 +259,12 @@
 PACKAGESDIR:=$(wildcard $(FPCDIR) $(FPCDIR)/packages $(FPCDIR)/packages/base $(FPCDIR)/packages/extra)
 override PACKAGE_NAME=fcl-base
 override PACKAGE_VERSION=2.0.0
+ifeq ($(OS_TARGET),win32)
+INSTALL_DATADIR=${INSTALL_UNITDIR}
+endif
+ifeq ($(OS_TARGET),win64)
+INSTALL_DATADIR=${INSTALL_UNITDIR}
+endif
 ifeq ($(FULL_TARGET),i386-linux)
 override TARGET_UNITS+=contnrs inifiles rtfpars idea base64 gettext iostream cachecls avl_tree uriparser eventlog custapp wformat whtml wtex rttiutils bufstream streamex blowfish streamio inicol pooledmm libtar streamcoll maskutils  syncobjs daemonapp fptimer
 endif
Index: Makefile.fpc
===================================================================
--- Makefile.fpc	(revision 11107)
+++ Makefile.fpc	(working copy)
@@ -49,6 +49,14 @@
 includedir_wince=src/win
 sourcedir=src/$(OS_TARGET) src
 
+[prerules]
+ifeq ($(OS_TARGET),win32)
+INSTALL_DATADIR=${INSTALL_UNITDIR}
+endif
+ifeq ($(OS_TARGET),win64)
+INSTALL_DATADIR=${INSTALL_UNITDIR}
+endif
+
 [install]
 fpcpackage=y
 files_win32=src/win/fclel.res
fclel.patch (2,167 bytes)

Vincent Snijders

2008-05-28 11:55

manager   ~0019784

I uploaded a working patch.

Michael Van Canneyt

2008-05-28 22:02

administrator   ~0019798

Resolved using patch from Mazen Neifer.

Vincent Snijders

2009-03-19 19:07

manager   ~0026248

The reason I did not close this issue, is that it did not work correctly, even if the file is installed.

Issue History

Date Modified Username Field Change
2007-11-05 13:44 Vincent Snijders New Issue
2007-11-05 13:44 Vincent Snijders Status new => assigned
2007-11-05 13:44 Vincent Snijders Assigned To => Michael Van Canneyt
2007-11-05 13:44 Vincent Snijders FPCOldBugId => 0
2007-11-05 13:44 Vincent Snijders FPCTarget => -
2007-11-05 13:44 Vincent Snijders FPCTarget - => 2.2.2
2007-12-29 23:11 Michael Van Canneyt Fixed in Revision => 9575.
2007-12-29 23:11 Michael Van Canneyt Status assigned => resolved
2007-12-29 23:11 Michael Van Canneyt Resolution open => fixed
2007-12-29 23:11 Michael Van Canneyt Note Added: 0016948
2007-12-30 21:56 Vincent Snijders Status resolved => feedback
2007-12-30 21:56 Vincent Snijders Resolution fixed => reopened
2007-12-30 21:56 Vincent Snijders Note Added: 0016971
2007-12-30 22:00 Michael Van Canneyt Fixed in Revision 9575. => 9591
2007-12-30 22:00 Michael Van Canneyt Status feedback => resolved
2007-12-30 22:00 Michael Van Canneyt Resolution reopened => fixed
2007-12-30 22:00 Michael Van Canneyt Note Added: 0016973
2007-12-30 23:00 Vincent Snijders Status resolved => feedback
2007-12-30 23:00 Vincent Snijders Resolution fixed => reopened
2007-12-30 23:00 Vincent Snijders Note Added: 0016981
2007-12-30 23:06 Michael Van Canneyt Note Added: 0016983
2007-12-30 23:06 Michael Van Canneyt Status feedback => assigned
2007-12-30 23:06 Michael Van Canneyt Assigned To Michael Van Canneyt => Peter Vreman
2008-04-13 11:34 Florian Target Version => 2.2.2
2008-05-27 23:36 Abou Al Montacir Note Added: 0019765
2008-05-28 00:03 Vincent Snijders Note Added: 0019766
2008-05-28 10:16 Abou Al Montacir File Added: svn.diff
2008-05-28 10:18 Abou Al Montacir Note Added: 0019779
2008-05-28 10:33 Vincent Snijders Note Added: 0019782
2008-05-28 11:55 Vincent Snijders File Added: fclel.patch
2008-05-28 11:55 Vincent Snijders Note Added: 0019784
2008-05-28 22:02 Michael Van Canneyt Fixed in Revision 9591 => 111111
2008-05-28 22:02 Michael Van Canneyt Status assigned => resolved
2008-05-28 22:02 Michael Van Canneyt Resolution reopened => fixed
2008-05-28 22:02 Michael Van Canneyt Note Added: 0019798
2008-10-16 01:03 Ivo Steinmann Status resolved => closed
2008-10-16 14:54 Vincent Snijders Status closed => resolved
2009-03-19 17:43 Jonas Maebe Fixed in Revision 111111 => 9762
2009-03-19 17:43 Jonas Maebe Status resolved => closed
2009-03-19 17:43 Jonas Maebe Fixed in Version => 2.2.2
2009-03-19 19:07 Vincent Snijders Note Added: 0026248