View Issue Details

IDProjectCategoryView StatusLast Update
0010188LazarusLCLpublic2009-06-13 12:10
ReporterDougNettletonAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.27 (SVN) 
Summary0010188: ScrollBox scrolls backwards
DescriptionWhile the arrow ends of the scroll bars didn't work in version 0.9.22 on linux, at least dragging the "bar center" resulted in the scrollbox contents moving the right way, i.e. into view. The Windows version 0.9.23 snapshot from July 31 with fpc 2.1.5 appeared to be working correctly. Sometime since then and before Oct 30 snapshot with fpc 2.2.1 the scroll bars on a scrollbox reversed the direction of the underlying contents. Last night's Windows 32-bit fpc 2.2.1 version still has the problem.

TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0010400 closedMattias Gaertner Scrollbars in forms working backwards 
related to 0010471 closedVincent Snijders LazReport designer window vertical scrollbar is invalid 
related to 0010091 closedBoguslaw Brandys TScrollBox.AutoScroll and scrolling is not possible 

Activities

Paul Ishenin

2009-02-01 08:49

manager   ~0024959

I cannot reproduce any problems. If it is still an issue for you then please attach a simple test application. In other case I will close this issue as unreproducable after 2 weeks.

Paul Ishenin

2009-02-23 11:09

manager   ~0025658

No feedback.

Issue History

Date Modified Username Field Change
2007-11-16 06:58 DougNettleton New Issue
2007-11-16 06:58 DougNettleton Widgetset => Win32
2007-11-30 22:55 Vincent Snijders LazTarget => 1.0
2007-11-30 22:55 Vincent Snijders Status new => acknowledged
2007-12-11 22:07 Vincent Snijders Relationship added related to 0010400
2008-01-31 13:05 Felipe Monteiro de Carvalho Relationship added related to 0010471
2008-03-09 23:15 Vincent Snijders Relationship added related to 0010091
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2009-02-01 08:49 Paul Ishenin Note Added: 0024959
2009-02-01 08:49 Paul Ishenin Status acknowledged => feedback
2009-02-23 11:09 Paul Ishenin Status feedback => resolved
2009-02-23 11:09 Paul Ishenin Fixed in Version => 0.9.27 (SVN)
2009-02-23 11:09 Paul Ishenin Resolution open => fixed
2009-02-23 11:09 Paul Ishenin Assigned To => Paul Ishenin
2009-02-23 11:09 Paul Ishenin Note Added: 0025658
2009-06-13 12:10 Marc Weustink Status resolved => closed