View Issue Details

IDProjectCategoryView StatusLast Update
0010199LazarusOtherpublic2011-12-01 11:24
ReporterGerman C. BasistyAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.23 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0010199: TMainMenu 's menu editor freezes when the scrollbar is used
DescriptionWhen a form has a main menu, and this menu is edited through the menu editor, it seems to stop working properly when th menu editor us too small and a scrollbar is needed. When you move the scrollbar to the right, it hangs.
Tagsmenu editor
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Activities

Martin Smat

2007-11-17 19:39

developer   ~0016205

It seems to be a more generic problem. Just create new form with some components (buttons), enable scrollbars and execute it. Then resize the window (make it smaller), the scrollbar appears. Move the scrollbar and it will show the same effect => you cannot move the scrollbar back to left.

Vincent Snijders

2009-06-24 15:51

manager   ~0028722

At this moment, no scrollbar is shown in the menu editor.

Paul Ishenin

2010-07-12 10:12

manager   ~0039279

It scrolls and works without hang now. Please test and close if it works for you now.

Issue History

Date Modified Username Field Change
2007-11-16 21:33 German C. Basisty New Issue
2007-11-16 21:33 German C. Basisty Widgetset => Win32
2007-11-17 19:39 Martin Smat Note Added: 0016205
2007-11-30 22:54 Vincent Snijders LazTarget => 1.0
2007-11-30 22:54 Vincent Snijders Status new => acknowledged
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2009-02-04 15:28 Paul Ishenin Tag Attached: menu editor
2009-06-24 15:51 Vincent Snijders Note Added: 0028722
2010-07-12 10:12 Paul Ishenin Status acknowledged => resolved
2010-07-12 10:12 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-07-12 10:12 Paul Ishenin Resolution open => fixed
2010-07-12 10:12 Paul Ishenin Assigned To => Paul Ishenin
2010-07-12 10:12 Paul Ishenin Note Added: 0039279
2011-12-01 11:24 Marc Weustink Status resolved => closed