View Issue Details

IDProjectCategoryView StatusLast Update
0010227LazarusIDEpublic2018-12-11 01:43
ReporterGeenimetsuriAssigned ToOndrej Pokorny 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version1.5 (SVN) 
Summary0010227: Top of Lazarus interface covered by taskbar
DescriptionIf taskbar - ie. the bar with Start button - is on top of the screen instead of the bottom when you first start the IDE the taskbar covers (the top) part of the interface.
Additional InformationAs a fix, I suggest Lazarus IDE takes into account the position and size of taskbar when creating the interface for the first time.
TagsNo tags attached.
Fixed in Revision50509
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0014433 resolvedOndrej Pokorny IDE designer windows hidden under left-aligned taskbar 
related to 0034650 new Part of UI covered by a taskbar when it maximized 

Activities

Geenimetsuri

2007-11-21 12:40

reporter   ~0016249

Yes, yes...forgot the OS again.

It's on Windows XP.

Juha Manninen

2011-11-20 12:26

developer   ~0054297

Last edited: 2011-11-20 12:27

What interface is covered? This doesn't make sense to me.

2011-11-20 21:50

 

winxp_top_bar_cover.png (24,192 bytes)
winxp_top_bar_cover.png (24,192 bytes)

Felipe Monteiro de Carvalho

2011-11-20 21:52

developer   ~0054322

I think it works like this. Steps to reproduce:

1> Move the taskbar to the top of the screen
2> Open Lazarus

Result:

The IDE window is covered by the bar (as shown in winxp_top_bar_cover.png)

Expected:

It should auto-detect the taskbar position and move down if required

Juha Manninen

2011-11-21 10:39

developer   ~0054332

Ok, I see.

Juha Manninen

2013-07-02 13:23

developer   ~0068689

Detaching myself from this issue. Don't know how to fix.

Vojtech Cihak

2013-07-02 14:11

reporter   ~0068691

I don't have any Windows but if the same problem is also with other applications I would close it. Furthermore this issue is only when the taskbar is not auto-hidden.

Łukasz

2013-07-09 19:39

reporter  

topbat.png (34,941 bytes)
topbat.png (34,941 bytes)

Łukasz

2013-07-09 19:40

reporter   ~0068772

I have the same problem on windows 8 64bit

Thaddy de Koning

2013-07-12 22:28

reporter   ~0068819

Last edited: 2013-07-12 22:50

View 6 revisions

This simple call obtains the proper positioning:
  var R:TRect;
  SystemParametersInfo(SPI_GETWORKAREA,0,@R,0);

In the current code 0,0 is assumed for topleft which is wrong.
The bar can be at all four sides of the desktop under Windows and furthermore at ANY screen or even extended over multiple monitors. Since this is dynamic there should probably be something like subclassing the taskbar for WM_MOVE messages as well.

Bart Broersma

2013-07-12 22:55

developer   ~0068823

> ... but if the same problem is also with other applications
FF has the same problem, but only when autohide of taskbar is true...

Thaddy de Koning

2013-07-22 23:04

reporter   ~0069003

A lot of wrongs doesn't make it right.
My suggestion will help fix the common case at least, but only for windows.
You can poll that call, btw, in the paint routine.

Recipe:
- If the windows taskbar is locked, skip it (cache first time).
- If it isn't query the position.
- Adjust Lazarus windows to taste...
- And plz relative to each other.

Juha Manninen

2013-07-23 00:00

developer   ~0069006

Thaddy de Koning, could you make a patch please.

Ondrej Pokorny

2015-11-26 20:45

reporter   ~0087625

Probably fixed in one of the older revisions. As far as my tests show r50508+r50509 are not affected any more.

Issue History

Date Modified Username Field Change
2007-11-21 12:39 Geenimetsuri New Issue
2007-11-21 12:39 Geenimetsuri Widgetset => Win32
2007-11-21 12:40 Geenimetsuri Note Added: 0016249
2007-11-30 22:52 Vincent Snijders LazTarget => post 1.2
2007-11-30 22:52 Vincent Snijders Status new => acknowledged
2011-11-20 12:25 Juha Manninen Status acknowledged => assigned
2011-11-20 12:25 Juha Manninen Assigned To => Juha Manninen
2011-11-20 12:26 Juha Manninen Note Added: 0054297
2011-11-20 12:26 Juha Manninen Status assigned => feedback
2011-11-20 12:27 Juha Manninen Note Edited: 0054297
2011-11-20 21:50 Felipe Monteiro de Carvalho File Added: winxp_top_bar_cover.png
2011-11-20 21:52 Felipe Monteiro de Carvalho Note Added: 0054322
2011-11-21 10:39 Juha Manninen Note Added: 0054332
2012-10-02 00:40 Juha Manninen Relationship added related to 0014433
2013-07-02 13:23 Juha Manninen Note Added: 0068689
2013-07-02 13:23 Juha Manninen Assigned To Juha Manninen =>
2013-07-02 13:23 Juha Manninen Status feedback => new
2013-07-02 14:11 Vojtech Cihak Note Added: 0068691
2013-07-09 19:39 Łukasz File Added: topbat.png
2013-07-09 19:40 Łukasz Note Added: 0068772
2013-07-12 22:28 Thaddy de Koning Note Added: 0068819
2013-07-12 22:30 Thaddy de Koning Note Edited: 0068819 View Revisions
2013-07-12 22:35 Thaddy de Koning Note Edited: 0068819 View Revisions
2013-07-12 22:37 Thaddy de Koning Note Edited: 0068819 View Revisions
2013-07-12 22:41 Thaddy de Koning Note Edited: 0068819 View Revisions
2013-07-12 22:50 Thaddy de Koning Note Edited: 0068819 View Revisions
2013-07-12 22:55 Bart Broersma Note Added: 0068823
2013-07-22 23:04 Thaddy de Koning Note Added: 0069003
2013-07-23 00:00 Juha Manninen Note Added: 0069006
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4
2014-09-10 12:42 Juha Manninen LazTarget 1.4 => -
2015-11-26 19:17 Ondrej Pokorny Assigned To => Ondrej Pokorny
2015-11-26 19:17 Ondrej Pokorny Status new => assigned
2015-11-26 20:45 Ondrej Pokorny Fixed in Revision => 50509
2015-11-26 20:45 Ondrej Pokorny Note Added: 0087625
2015-11-26 20:45 Ondrej Pokorny Status assigned => resolved
2015-11-26 20:45 Ondrej Pokorny Fixed in Version => 1.5 (SVN)
2015-11-26 20:45 Ondrej Pokorny Resolution open => fixed
2018-12-11 01:43 Juha Manninen Relationship added related to 0034650