View Issue Details

IDProjectCategoryView StatusLast Update
0010262LazarusWidgetsetpublic2013-09-03 12:07
ReporterChristianAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0010262: Treeview flickers
DescriptionIn WinCE the Treeview flickers on every change.
Maybe BitBlt is very slow.
Tagswince
Fixed in Revision
LazTarget1.4
WidgetsetWinCE
Attached Files

Activities

Felipe Monteiro de Carvalho

2008-04-19 03:02

developer   ~0018933

Yes, I can confirm. Even setting DoubleBuffered in the TreeView doesn't help (just changes from half component flickering to entire component flickering at once).

Maybe it's a bug related to erasing the background...

Felipe Monteiro de Carvalho

2010-05-21 06:48

developer   ~0037835

I tested now and couldn't reproduce. Please test with the latest snapshot and close if ok. Probably fixed in the mean time.

Christian

2010-05-21 07:57

reporter   ~0037839

Win32 treeview flickers without themes in same way i dont think that it is fixed but i will test it.

Issue History

Date Modified Username Field Change
2007-11-24 13:01 Christian New Issue
2007-11-24 13:01 Christian Widgetset => WinCE
2007-11-28 16:40 Vincent Snijders LazTarget => post 1.2
2007-11-28 16:40 Vincent Snijders Status new => acknowledged
2007-11-28 16:40 Vincent Snijders Category LCL => Widgetset
2008-02-11 08:47 Felipe Monteiro de Carvalho Status acknowledged => assigned
2008-02-11 08:47 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2008-04-18 03:00 Felipe Monteiro de Carvalho Tag Attached: wince
2008-04-19 03:02 Felipe Monteiro de Carvalho Note Added: 0018933
2008-04-19 03:02 Felipe Monteiro de Carvalho Status assigned => confirmed
2010-05-21 06:48 Felipe Monteiro de Carvalho Status confirmed => resolved
2010-05-21 06:48 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-05-21 06:48 Felipe Monteiro de Carvalho Resolution open => fixed
2010-05-21 06:48 Felipe Monteiro de Carvalho Note Added: 0037835
2010-05-21 07:57 Christian Note Added: 0037839
2011-12-01 11:23 Marc Weustink Status resolved => closed
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4