View Issue Details

IDProjectCategoryView StatusLast Update
0010400LazarusWidgetsetpublic2011-12-01 11:22
ReporterDaniel ShepardAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version0.9.22Product Build 
Target Version1.0.0Fixed in Version 
Summary0010400: Scrollbars in forms working backwards
DescriptionA lot like bug 0010188:

If the scrollbars are enabled in a form and the range of the toolbar exceeds the width of the form the contents will be scrolled backwards: that is, contents will move to the right as if their default position was in the right of the screen. Same happens with vertical movement.
Additional InformationCould this bug be related to the scrollbar itself?. It works under Linux but happens in the win32 version.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0010188 closedPaul Ishenin ScrollBox scrolls backwards 
related to 0007321 closedZeljan Rikalo ScrollBars in a scrollBox 
related to 0010471 closedVincent Snijders LazReport designer window vertical scrollbar is invalid 

Activities

Paul Ishenin

2009-09-12 11:50

manager   ~0030655

Does this bug still present? If so then please attach a test project.

Vincent Snijders

2009-10-19 20:22

manager   ~0031462

No feedback from reporter, maybe fixed in the mean time.

Issue History

Date Modified Username Field Change
2007-12-11 20:37 Daniel Shepard New Issue
2007-12-11 20:37 Daniel Shepard Widgetset => Win32
2007-12-11 22:07 Vincent Snijders Relationship added related to 0010188
2007-12-11 22:08 Vincent Snijders LazTarget => 1.0
2007-12-11 22:08 Vincent Snijders Status new => acknowledged
2008-01-09 00:41 Mattias Gaertner Status acknowledged => assigned
2008-01-09 00:41 Mattias Gaertner Assigned To => Mattias Gaertner
2008-01-31 13:05 Felipe Monteiro de Carvalho Relationship added related to 0010471
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2008-08-29 13:50 Mattias Gaertner Relationship added related to 0007321
2009-09-12 11:50 Paul Ishenin Note Added: 0030655
2009-09-12 11:50 Paul Ishenin Status assigned => feedback
2009-10-19 20:22 Vincent Snijders Status feedback => resolved
2009-10-19 20:22 Vincent Snijders Resolution open => unable to reproduce
2009-10-19 20:22 Vincent Snijders Note Added: 0031462
2011-12-01 11:22 Marc Weustink Status resolved => closed