View Issue Details

IDProjectCategoryView StatusLast Update
0010402LazarusLCLpublic2013-09-03 12:07
ReporterNyitrai Péter Assigned ToBart Broersma  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN) 
Target Version0.9.27 (SVN)Fixed in Version0.9.27 (SVN) 
Summary0010402: A little nuance with SpinEdit
DescriptionWhen the control loses focus, or
user press the enter key, it should refresh its edit field with the Value
property. An example: Set MaxValue to 10000. Then, if I type 99999 into
the edit field and I press enter or I leave this field, it should be
changed to 10000 like the Value property does.
TagsNo tags attached.
Fixed in Revision18446
LazTarget1.4
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0013046 closedPaul Ishenin TFloatSpinEdit: if you type an "invalid" value in the control, the text should be corrected when control looses focus 

Activities

Felipe Monteiro de Carvalho

2008-01-24 13:50

developer   ~0017420

Still present.

Bart Broersma

2009-02-28 15:47

developer   ~0025820

Please close if OK

Nyitrai Péter

2009-06-18 10:39

reporter   ~0028601

The solution is acceptable, but the mentioned/suggested enter key related behavior is not implemented. Altough it's not a Delphi incompatibility, I thought it can come handy.

Issue History

Date Modified Username Field Change
2007-12-12 01:35 Nyitrai Péter New Issue
2007-12-12 01:35 Nyitrai Péter Widgetset => Win32
2007-12-12 09:18 Vincent Snijders LazTarget => post 1.2
2007-12-12 09:18 Vincent Snijders Status new => acknowledged
2008-01-24 13:50 Felipe Monteiro de Carvalho Note Added: 0017420
2009-02-28 15:47 Bart Broersma Fixed in Revision => 18446
2009-02-28 15:47 Bart Broersma Relationship added duplicate of 0013046
2009-02-28 15:47 Bart Broersma Duplicate ID 0 => 13046
2009-02-28 15:47 Bart Broersma Status acknowledged => resolved
2009-02-28 15:47 Bart Broersma Fixed in Version => 0.9.27 (SVN)
2009-02-28 15:47 Bart Broersma Resolution open => fixed
2009-02-28 15:47 Bart Broersma Assigned To => Bart Broersma
2009-02-28 15:47 Bart Broersma Note Added: 0025820
2009-02-28 15:47 Bart Broersma Target Version => 0.9.27 (SVN)
2009-06-13 12:10 Marc Weustink Status resolved => closed
2009-06-18 10:39 Nyitrai Péter Note Added: 0028601
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4