View Issue Details

IDProjectCategoryView StatusLast Update
0010626LazarusLCLpublic2008-07-07 15:46
ReporterChristianAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version0.9.25 (SVN) 
Summary0010626: Progressbar with Height < 10 dont work correct
DescriptionWhen the Height is 9 or below the progressbar dont work correct in Win32 it shows up only at 1/3 of the Width the second /3 is white and the last gray.
TagsNo tags attached.
Fixed in Revision14926
LazTarget
WidgetsetWin32/Win64, WinCE
Attached Files

Relationships

related to 0010312 closedFelipe Monteiro de Carvalho GTK2 TComboBox sizing issues 

Activities

Gerard V

2008-02-05 18:27

reporter   ~0017614

I see what you descrive at design time, but at runtime it seems to work ok.
Is this correct?

Christian

2008-02-05 21:02

reporter   ~0017615

No, this problem exists in both Runtime and Designtime

Paul Ishenin

2008-02-06 02:30

manager   ~0017616

The problem is only with themed application

Paul Ishenin

2008-02-06 02:44

manager   ~0017617

Read here:
http://msdn2.microsoft.com/en-us/library/bb760816(VS.85).aspx

Especially this note: If you are using a progress bar control with the Theme API on Microsoft Windows XP the control must be at least 10 pixels high.

Christian

2008-02-07 08:16

reporter   ~0017626

then maybe you should close the issue. also a entry in wiki "known issues" would be nice.

Felipe Monteiro de Carvalho

2008-02-09 22:06

developer   ~0017678

But maybe the win32 interface should set a constrain on the progress bar size. The problem is that it will affect themed and non-themed apps.

Felipe Monteiro de Carvalho

2008-02-15 22:07

developer   ~0017803

I initially thougth one could use AutoSize to fix this one, but the widgetset interface to autosize let's us choose a fixed size for this, not a minimum size, so I have no idea how to improve this and I'm going for the suggestion of the reporter, an entry on the known issues.

Vincent Snijders

2008-02-15 22:18

manager   ~0017804

A minimum height can be passed to the LCL by setting Constraints.MinInterfaceHeight to 10 for themed progressbars in TWin32WidgetSet.GetControlConstraints.

Paul Ishenin

2008-02-16 06:04

manager   ~0017806

Yes, and I sent patch to laz-dev, but I dont think it works.

Issue History

Date Modified Username Field Change
2008-01-13 11:07 Christian New Issue
2008-01-13 11:07 Christian Widgetset => Win32, WinCE
2008-02-05 18:27 Gerard V Note Added: 0017614
2008-02-05 21:02 Christian Note Added: 0017615
2008-02-06 02:30 Paul Ishenin Note Added: 0017616
2008-02-06 02:44 Paul Ishenin Note Added: 0017617
2008-02-07 08:16 Christian Note Added: 0017626
2008-02-09 21:52 Felipe Monteiro de Carvalho Relationship added related to 0010312
2008-02-09 22:06 Felipe Monteiro de Carvalho Note Added: 0017678
2008-02-09 23:11 Felipe Monteiro de Carvalho Status new => assigned
2008-02-09 23:11 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2008-02-15 22:07 Felipe Monteiro de Carvalho Note Added: 0017803
2008-02-15 22:18 Vincent Snijders Note Added: 0017804
2008-02-16 06:04 Paul Ishenin Note Added: 0017806
2008-04-22 02:16 Felipe Monteiro de Carvalho Fixed in Revision => 14926
2008-04-22 02:16 Felipe Monteiro de Carvalho Status assigned => resolved
2008-04-22 02:16 Felipe Monteiro de Carvalho Fixed in Version => 0.9.25 (SVN)
2008-04-22 02:16 Felipe Monteiro de Carvalho Resolution open => fixed
2008-07-07 15:46 Christian Status resolved => closed