View Issue Details

IDProjectCategoryView StatusLast Update
0010685LazarusWidgetsetpublic2008-12-12 04:04
ReporterSatya PothamsettiAssigned ToPaul Ishenin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.24Product Build 
Target Version1.0.0Fixed in Version0.9.25 (SVN) 
Summary0010685: Controls lose tab selection if the "Use manifest..." option is checked and mouse is used to open the app.
DescriptionControls (like buttons etc.,) lose tab selection if the "Use manifest file to enable themes (windows only)" option is checked from Project Options screen.

This has a small twist.. The problem does not show up if you do not use mouse while opening your executable. i.e., If you move around the file name with up&down arrow keys and hit Enter key to run the app, everything will be fine.
But that is only an exception to the rule as most Windows users use their mouse to open an app.
In case of using mouse to open the app, we cannot see which button is currently selected.
i.e., You will not see the selection dots around the default button.
If you click tab, the next button also does not show the selection.
No selection at all.

We can say it internally moves as clicking tab key a few times and hitting enter key opens a different button, but you cannot visually see which button is selected. This happens with other controls like check boxes too.

Steps to reproduce:
1. Create an empty win32 application and drop 2 buttons (and some other controls like check boxes if you want).
2. Go to Project Options screen and enable the "Use manifest file to enable themes (windows only)" option.
3. Build the executable and test it opening it in two different ways A).Double click on the EXE name. B). Open it without using mouse. (Up/Down and Enter keys from your keyboard).
4. Control Selection is not visible in scenario A. (But visible in B).

I have tested this on Windows XP and Vista. The behavior is same in both.

I am using Lazarus only for the past 2 days. I am sorry if my bug report has not followed any conventions you are used to.

Thanks,
Satya
Additional InformationA similar test app created in Delphi does not have this problem.
TagsNo tags attached.
Fixed in Revision15997
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Activities

Satya Pothamsetti

2008-01-25 06:32

reporter   ~0017444

In addition to the missing keyboard focus, the mnemonics selected on labels (the _ with & symbol) are not showing up when the manifest was used in a windows app (and that app was invoked using mouse).

Bernd

2008-07-10 16:27

reporter   ~0020626

I can confirm the described behavior. Lazarus 0.9.25, rev 10176 behaves the same.
A test case, compiled with Lazarus 0.9.20 (manifest.res file linked into the exe) behaves correct.

Paul Ishenin

2008-07-13 15:35

manager   ~0020673

Bernd, you must understand that it is very big space in revisions between 0.9.20 and 0.9.25. But if you find exact rev. number we will fix it quick.

Bernd

2008-07-15 14:56

reporter   ~0020703

Paul, rev 10732 is the last revision, which worked correct. May be the problem is related to the changes in win32wsbuttons.pp which are present in rev 10733.

2008-08-07 10:17

 

test.zip (5,961 bytes)

Bernd

2008-08-07 10:17

reporter   ~0021109

Last edited: 2008-08-07 10:27

The attached test case reproduces the wrong behavior. If you use the keyboard (not the mouse) to open Form2, the program behaves correct.

Paul Ishenin

2008-08-08 15:49

manager   ~0021156

Partialy fixed. Focus rectangle is invisible though.

Issue History

Date Modified Username Field Change
2008-01-23 17:10 Satya Pothamsetti New Issue
2008-01-23 17:10 Satya Pothamsetti Widgetset => Win32
2008-01-25 06:32 Satya Pothamsetti Note Added: 0017444
2008-02-22 18:23 Felipe Monteiro de Carvalho LazTarget => 1.0
2008-02-22 18:23 Felipe Monteiro de Carvalho Status new => acknowledged
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2008-07-10 16:27 Bernd Note Added: 0020626
2008-07-13 15:35 Paul Ishenin Note Added: 0020673
2008-07-15 14:56 Bernd Note Added: 0020703
2008-08-07 10:17 Bernd File Added: test.zip
2008-08-07 10:17 Bernd Note Added: 0021109
2008-08-07 10:27 Bernd Note Edited: 0021109
2008-08-08 15:49 Paul Ishenin Fixed in Revision => 15997
2008-08-08 15:49 Paul Ishenin Status acknowledged => resolved
2008-08-08 15:49 Paul Ishenin Fixed in Version => 0.9.25 (SVN)
2008-08-08 15:49 Paul Ishenin Resolution open => fixed
2008-08-08 15:49 Paul Ishenin Assigned To => Paul Ishenin
2008-08-08 15:49 Paul Ishenin Note Added: 0021156
2008-12-12 04:04 Paul Ishenin Status resolved => closed