View Issue Details

IDProjectCategoryView StatusLast Update
0010738LazarusIDEpublic2013-09-03 12:07
ReporterMarius Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN) 
Target Version0.9.28Fixed in Version0.9.27 (SVN) 
Summary0010738: Ctrl-T shortcut "delete to end of word" in comments
DescriptionWhen using Ctrl-T (classic keyboard) everything from <cursor> to the ";" is deleted. It only happends in strings and comments (non parsed code?)

'The quick <cursor>brown fox jumps over the lazy dog';

Ctrl-T at <cursor> gives:

'The quick ;

TagsNo tags attached.
Fixed in Revision17224
LazTarget1.4
Widgetset
Attached Files

Relationships

duplicate of 0012486 closedMartin Friebe Ctrl-T within strings or comments deletes too much 
related to 0012583 closedMartin Friebe Ctrl+T with whitespaces behaviour regression 

Activities

Vincent Snijders

2008-03-04 13:41

manager   ~0018102

What is actual and desired behavior?

What is the bug?

Marius

2008-03-30 16:25

reporter   ~0018493

Ctrl+T: Deletes a word, It should only delete the characters in the current word (up to the next word including spaces). This works perfect with normal code, but when Ctrl-T is used in literal string constants it is wrong.

To use the previous example:
Ctrl-T at <cursor> gives:
'The quick ;
But it should be:
'The quick <cursor>fox jumps over the lazy dog';

Again, please note the quottes around the text!

Flávio Etrusco

2008-04-28 18:48

developer   ~0019132

I prefer the Delphi behavior, too. However the code was clearly modified in Lazarus to delete tokens instead of "words" (the original code which is IFDEF-ed out doesn't quite work like Delphi either; current SynEdit has a closer implementation but with not-quite-beautiful code...)

Martin Friebe

2008-11-04 22:30

manager   ~0023172

@Marius: Please close if ok

Marius

2008-11-06 21:49

reporter   ~0023197

This works much better, pressing Ctrl-T at <cursor> will now give the following:

(situation 1) a := 'The quick <cursor>brown fox jumps over the lazy dog';
(situation 2) a := 'The quick <cursor> fox jumps over the lazy dog';

The space after "brown" should be removed also AFAIK (then it would be a turbo and delphi editor compatible behaviour)

Martin Friebe

2008-11-07 00:17

manager   ~0023198

I forgot to resolve it, you can now actually lose it.

As for the space. The previous solution also deleted to the "end of word" (which is according to the name of the function).

The previous solution would tread the white-spaces (as well as any other token: :=, <, >, even a single dot) between the real words like there also were words.
Pressing ctrl-t in the middle of a word would first delete this word, the next ctrl-t would delete the white-spaces, and so on.

I will resolve this issue anyway, as it was about the comments and strings.

Please feel free to open a new issue / feature request about the white space behaviour.

Issue History

Date Modified Username Field Change
2008-01-31 12:36 Marius New Issue
2008-01-31 12:36 Marius Widgetset => Win32
2008-03-04 13:41 Vincent Snijders LazTarget => post 1.2
2008-03-04 13:41 Vincent Snijders Note Added: 0018102
2008-03-04 13:41 Vincent Snijders Status new => feedback
2008-03-30 16:25 Marius Note Added: 0018493
2008-04-28 13:23 Vincent Snijders Status feedback => acknowledged
2008-04-28 18:48 Flávio Etrusco Note Added: 0019132
2008-11-04 18:14 Martin Friebe Relationship added duplicate of 0012486
2008-11-04 18:14 Martin Friebe Status acknowledged => assigned
2008-11-04 18:14 Martin Friebe Assigned To => Martin Friebe
2008-11-04 22:30 Martin Friebe Fixed in Revision => 17224
2008-11-04 22:30 Martin Friebe Widgetset Win32 =>
2008-11-04 22:30 Martin Friebe Status assigned => resolved
2008-11-04 22:30 Martin Friebe Resolution open => fixed
2008-11-04 22:30 Martin Friebe Note Added: 0023172
2008-11-04 22:30 Martin Friebe Target Version => 0.9.28
2008-11-06 21:49 Marius Status resolved => assigned
2008-11-06 21:49 Marius Resolution fixed => reopened
2008-11-06 21:49 Marius Note Added: 0023197
2008-11-07 00:17 Martin Friebe Status assigned => resolved
2008-11-07 00:17 Martin Friebe Fixed in Version => 0.9.27 (SVN)
2008-11-07 00:17 Martin Friebe Resolution reopened => fixed
2008-11-07 00:17 Martin Friebe Note Added: 0023198
2008-11-07 15:20 Martin Friebe Relationship added related to 0012583
2009-06-13 12:08 Marc Weustink Status resolved => closed
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4