View Issue Details

IDProjectCategoryView StatusLast Update
0010808LazarusIDEpublic2011-12-01 11:23
ReporterPhilAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformAllOSOS Version
Product Version0.9.25 (SVN)Product Build20080207 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0010808: File | New descriptions are not clear
DescriptionI would like to improve the descriptions of File | New items. The lazaruside.po file does not appear to be loaded by Lazarus since it's the default English file, so making changes there don't show up in the IDE. Should changes be made to lazarusidestrconsts.pas? But then this would require rebuilding the IDE to see any changes, right?

Here are some of the things I find confusing:

- "The program file is automatically maintained by lazarus." What does this mean, exactly? Doesn't Lazarus maintain all of the project's files, not just the "program" file, which presumably is the .lpr file.

- "graphical" --> "GUI" is the more common term for modern, interactive programs. "Graphical" suggests something like SigmaPlot.

- "Custom program" - what is this? The description tells me nothing.

- "Simple CGIAppication" - refers to LazWeb package. What's this? There's a weblaz package in the fpweb folder. Is this what it should be referring to? And how would the newcomer ever find this, if so. And should this package then be installed or what?

- Is it too much to ask to use the normal English rules of capitalization for nouns? Sometimes it looks like German rules are being used with common nouns capitalized, other times not even proper nouns are capitalized, like some Romance language run amok.

- Etc.

Since the File | New dialog is probably one of the first points of collision between new users and Lazarus, it would seem like this would be a place where some extra polish (not Polish) could be usefully applied. I would be happy to do that if I knew where to start.

Thanks.

-Phil
TagsNo tags attached.
Fixed in Revision25387
LazTarget1.0
Widgetset
Attached Files

Activities

Mattias Gaertner

2008-02-10 01:24

manager   ~0017685

Please ask questions on the mailing lists or on the lazarus-ide channel.

Vincent Snijders

2008-03-04 14:13

manager   ~0018107

You assumptions seem correct.

Vincent Snijders

2009-04-23 11:04

manager   ~0026976

IMHO, this bug report is a bit vague. What should be done to resolve it?

Vladimir Zhirov

2009-04-23 18:35

reporter   ~0026997

I believe there is at least one thing to do, that is making TreeView items in "File -> New..." dialog localizable. I reported this problem in bug 0013572.
Once these items are localizable the reporter could submit alternative translation to make his suggestion more clear.

Vincent Snijders

2009-04-23 22:10

manager   ~0027003

The reporter is a native english speaker AFAIK.

Maxim Ganetsky

2010-05-12 01:16

developer   ~0037462

@Phil. Please make your string replacements suggestions, I'll change them.

samuel herzog

2010-05-12 22:40

developer   ~0037488

Just tested on win32 with current SVN 25338 and language set to german.
The treeview items are translated to german and make "sense".
So it looks as if this Items are possible to translate by .po files.

I vote for state "resolved".

Maxim Ganetsky

2010-05-12 22:47

developer   ~0037491

The dialog was localized, yes. But original reporter has issues with original English descriptions.

samuel herzog

2010-05-13 04:49

developer   ~0037497

yes, but this issue was report 2 years ago.

Maxim Ganetsky

2010-05-14 00:05

developer   ~0037556

Descriptions were improved in r25387.

Issue History

Date Modified Username Field Change
2008-02-10 01:09 Phil New Issue
2008-02-10 01:09 Phil Widgetset => GTK
2008-02-10 01:24 Mattias Gaertner Note Added: 0017685
2008-03-04 14:13 Vincent Snijders LazTarget => 1.0
2008-03-04 14:13 Vincent Snijders Note Added: 0018107
2008-03-04 14:13 Vincent Snijders Status new => acknowledged
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2009-04-23 11:04 Vincent Snijders Note Added: 0026976
2009-04-23 11:04 Vincent Snijders Status acknowledged => feedback
2009-04-23 18:35 Vladimir Zhirov Note Added: 0026997
2009-04-23 22:10 Vincent Snijders Note Added: 0027003
2010-05-12 01:16 Maxim Ganetsky Note Added: 0037462
2010-05-12 01:16 Maxim Ganetsky Status feedback => assigned
2010-05-12 01:16 Maxim Ganetsky Assigned To => Maxim Ganetsky
2010-05-12 01:16 Maxim Ganetsky Status assigned => feedback
2010-05-12 22:40 samuel herzog Note Added: 0037488
2010-05-12 22:47 Maxim Ganetsky Note Added: 0037491
2010-05-13 04:49 samuel herzog Note Added: 0037497
2010-05-14 00:05 Maxim Ganetsky Fixed in Revision => 25387
2010-05-14 00:05 Maxim Ganetsky Widgetset GTK =>
2010-05-14 00:05 Maxim Ganetsky Status feedback => resolved
2010-05-14 00:05 Maxim Ganetsky Fixed in Version => 0.9.29 (SVN)
2010-05-14 00:05 Maxim Ganetsky Resolution open => fixed
2010-05-14 00:05 Maxim Ganetsky Note Added: 0037556
2011-12-01 11:23 Marc Weustink Status resolved => closed