View Issue Details

IDProjectCategoryView StatusLast Update
0010939LazarusOtherpublic2020-11-28 20:16
ReporterAndrea Mauri Assigned ToMaxim Ganetsky  
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN) 
Summary0010939: TOpenGLControl is drawn not correctly (WinXP)
DescriptionFPC 2.2

When I put a TOpenGLControl on a form it has a small "shadow" on the left and bottom border.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

2008-03-04 12:06

 

opengldesigntime.jpg (43,585 bytes)   
opengldesigntime.jpg (43,585 bytes)   

Juha Manninen

2020-11-25 17:10

developer   ~0127177

Does it still happen? What about more recent Windows versions? Does it make a difference?

Sven Barth

2020-11-25 23:48

manager   ~0127194

On Windows 10 there is no "shadow". I'll try to check it on XP on probably Friday.

Anton Kavalenka

2020-11-26 16:07

reporter   ~0127198

Win2003 server i386

Maxim Ganetsky

2020-11-27 14:38

developer   ~0127207

OK, seems to be fixed in the meantime.

Sven Barth

2020-11-27 14:54

manager   ~0127209

As I said I'd test it today: Also working for me on XP i386. :)
lazarus-xp.png (19,129 bytes)   
lazarus-xp.png (19,129 bytes)   

Issue History

Date Modified Username Field Change
2008-03-04 12:06 Andrea Mauri New Issue
2008-03-04 12:06 Andrea Mauri File Added: opengldesigntime.jpg
2008-03-04 12:06 Andrea Mauri Widgetset => Win32
2008-03-04 12:23 Vincent Snijders LazTarget => post 1.2
2008-03-04 12:23 Vincent Snijders Status new => acknowledged
2013-09-03 12:08 Martin Friebe LazTarget post 1.2 => 1.4
2014-09-10 14:56 Juha Manninen LazTarget 1.4 => -
2020-11-25 17:10 Juha Manninen Note Added: 0127177
2020-11-25 23:48 Sven Barth Note Added: 0127194
2020-11-26 16:07 Anton Kavalenka Note Added: 0127198
2020-11-26 16:07 Anton Kavalenka File Added: Здымак экрана, 2020-11-26 18-06-51.png
2020-11-27 14:38 Maxim Ganetsky Assigned To => Maxim Ganetsky
2020-11-27 14:38 Maxim Ganetsky Status acknowledged => resolved
2020-11-27 14:38 Maxim Ganetsky Resolution open => fixed
2020-11-27 14:38 Maxim Ganetsky Widgetset Win32/Win64 => Win32/Win64
2020-11-27 14:38 Maxim Ganetsky Note Added: 0127207
2020-11-27 14:54 Sven Barth Note Added: 0127209
2020-11-27 14:54 Sven Barth File Added: lazarus-xp.png
2020-11-28 20:16 Andrea Mauri Status resolved => closed