View Issue Details

IDProjectCategoryView StatusLast Update
0011120LazarusWidgetsetpublic2009-04-28 11:39
ReporterGraeme Geldenhuys Assigned ToPaul Ishenin  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSUbuntu Linux 
Product Version0.9.25 (SVN) 
Target Version1.0.0Fixed in Version0.9.27 (SVN) 
Summary0011120: Painting bug in GTK2: TButton
DescriptionSee the image referred to in the following bug report.
http://bugs.freepascal.org/view.php?id=10994

message-compose-ubuntu-gtk2.png
http://bugs.freepascal.org/file_download.php?file_id=7415&type=bug

Bottom/Right in the screenshot. GTK2 allows the button image to paint outside the bounds of the TButton!
Tagsgtk2
Fixed in Revision19646
LazTarget1.0
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0008765 closedMattias Gaertner Text to low in components under GTK2 
child of 0008165 closedMattias Gaertner GTK2 - suggested to be default 

Activities

Paul Ishenin

2009-04-27 11:28

manager   ~0027121

Please test and close if ok.

Graeme Geldenhuys

2009-04-28 11:39

reporter   ~0027147

Works perfectly now. Thanks!

Issue History

Date Modified Username Field Change
2008-04-08 13:32 Graeme Geldenhuys New Issue
2008-04-08 13:32 Graeme Geldenhuys Widgetset => GTK 2
2008-04-08 15:10 Vincent Snijders Status new => acknowledged
2008-04-08 15:11 Vincent Snijders LazTarget => 1.2
2008-04-12 12:50 Felipe Monteiro de Carvalho Tag Attached: gtk2
2008-04-16 02:54 Felipe Monteiro de Carvalho Relationship added duplicate of 0008765
2008-07-16 20:33 Vincent Snijders Relationship added child of 0008165
2009-04-27 11:28 Paul Ishenin Fixed in Revision => 19646
2009-04-27 11:28 Paul Ishenin LazTarget 1.2 => 1.0
2009-04-27 11:28 Paul Ishenin Status acknowledged => resolved
2009-04-27 11:28 Paul Ishenin Fixed in Version => 0.9.27 (SVN)
2009-04-27 11:28 Paul Ishenin Resolution open => fixed
2009-04-27 11:28 Paul Ishenin Assigned To => Paul Ishenin
2009-04-27 11:28 Paul Ishenin Note Added: 0027121
2009-04-27 11:28 Paul Ishenin Target Version => 1.0.0
2009-04-28 11:39 Graeme Geldenhuys Status resolved => closed
2009-04-28 11:39 Graeme Geldenhuys Note Added: 0027147