View Issue Details

IDProjectCategoryView StatusLast Update
0011122LazarusWidgetsetpublic2011-10-08 21:36
ReporterGraeme Geldenhuys Assigned ToVincent Snijders  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Platformx86OSUbuntu Linux 
Product Version0.9.25 (SVN) 
Target Version1.0.0 
Summary0011122: Painting bug in GTK2: TLabel
DescriptionSee the image referred to in the following bug report.
http://bugs.freepascal.org/view.php?id=10994

message-compose-ubuntu-gtk2.png
http://bugs.freepascal.org/file_download.php?file_id=7415&type=bug

Top/Left of screenshot. GTK2 allows the TLabel text to paint into the bounds of the TGroupBox! Text is over the GroupBox, but under the RadioButton.
Tagsgtk2
Fixed in Revision
LazTarget1.0
WidgetsetGTK 2
Attached Files

Relationships

child of 0008165 closedMattias Gaertner GTK2 - suggested to be default 

Activities

Mattias Gaertner

2009-08-20 00:08

manager   ~0030005

Last edited: 2009-08-20 00:19

A gtk2 groupbox is transparent.
Overlapping controls should be avoided or special care must be taken.
I think the real bug was the layout of the message composer with overlapping controls. The current version does not have such a bug.

Zeljan Rikalo

2011-04-03 16:41

developer   ~0047127

Same thing with qt. I think that this should be resolved. Overlapping is visible because TGroupBox is transparent.

Issue History

Date Modified Username Field Change
2008-04-08 13:37 Graeme Geldenhuys New Issue
2008-04-08 13:37 Graeme Geldenhuys Widgetset => GTK 2
2008-04-08 15:10 Vincent Snijders Status new => acknowledged
2008-04-08 15:11 Vincent Snijders LazTarget => 1.2
2008-04-12 12:51 Felipe Monteiro de Carvalho Tag Attached: gtk2
2008-07-16 20:32 Vincent Snijders Relationship added child of 0008165
2009-08-20 00:08 Mattias Gaertner Note Added: 0030005
2009-08-20 00:19 Mattias Gaertner Note Edited: 0030005
2009-09-27 11:17 Vincent Snijders LazTarget 1.2 => 1.0
2009-09-27 11:17 Vincent Snijders Target Version => 1.0.0
2011-04-03 16:41 Zeljan Rikalo Note Added: 0047127
2011-10-08 21:36 Vincent Snijders Status acknowledged => resolved
2011-10-08 21:36 Vincent Snijders Resolution open => no change required
2011-10-08 21:36 Vincent Snijders Assigned To => Vincent Snijders