View Issue Details

IDProjectCategoryView StatusLast Update
0011136LazarusLCLpublic2012-01-09 17:24
ReporterGraeme GeldenhuysAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSUbuntu LinuxOS Version7.04
Product Version0.9.25 (SVN)Product Buildv0.9.25 r14596M i386-linux-gtk 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0011136: TDateEdit.Options.dsStartMon property doesn't work
DescriptionSetting the TDateEdit.Options.dsStartMon = True and then opening the dateedit popup, the calendar always starts on Sunday as the first day.
See attached screenshot. This was tested under GTK1.
TagsNo tags attached.
Fixed in Revision34684
LazTarget1.0
WidgetsetGTK, GTK 2
Attached Files
  • Screenshot.png (17,725 bytes)
    Screenshot.png (17,725 bytes)
  • gtk2.issues.xml.diff (634 bytes)
    Index: issues.xml
    ===================================================================
    --- issues.xml	(revision 29157)
    +++ issues.xml	(working copy)
    @@ -24,5 +24,9 @@
     		<issue name="TTabControl.MultiLine">
     			<short>MultiLine property is not supported</short>
     		</issue>
    +		<issue name="TDateEdit.CalendarDisplaySettings.dsStartMon">	
    +			<short>TDateEdit.CalendarDisplaySettings.dsStartMon is ignored in GTK+ since 2.4</short>
    +			<descr>Since GTK+ 2.4, this option is deprecated and ignored by GTK+. The information on which day the calendar week starts is derived from the locale.</descr>
    +		</issue>.
     	</widgetset>
     </package>
    
    gtk2.issues.xml.diff (634 bytes)

Relationships

related to 0010190 closedPaul Ishenin TCalendar crash when activating dsShowWeekNumbers through OI 

Activities

2008-04-11 12:47

 

Screenshot.png (17,725 bytes)
Screenshot.png (17,725 bytes)

Graeme Geldenhuys

2008-04-11 12:49

reporter   ~0018723

Sorry, the property is TDateEdit.CalendarDisplaySettings.dsStartMon

Juha Manninen

2010-12-20 13:26

developer   ~0044426

Happens also with GTK2.

Gerard V

2010-12-29 18:49

reporter   ~0044691

Last edited: 2010-12-29 18:49

It seems that after GTK 2.4 the beginning of the week is set by the locale, and that the option to set Monday as the first day is deprecated.
See:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=272054
http://library.gnome.org/devel/gtk/stable/GtkCalendar.html#GtkCalendarDisplayOptions
If it's correct i don't see how to fix it.

Vincent Snijders

2010-12-29 20:43

manager   ~0044693

Adding a note to issues.xml will be enough to resolve this issue as 'not fixable'.

2011-03-24 10:56

 

gtk2.issues.xml.diff (634 bytes)
Index: issues.xml
===================================================================
--- issues.xml	(revision 29157)
+++ issues.xml	(working copy)
@@ -24,5 +24,9 @@
 		<issue name="TTabControl.MultiLine">
 			<short>MultiLine property is not supported</short>
 		</issue>
+		<issue name="TDateEdit.CalendarDisplaySettings.dsStartMon">	
+			<short>TDateEdit.CalendarDisplaySettings.dsStartMon is ignored in GTK+ since 2.4</short>
+			<descr>Since GTK+ 2.4, this option is deprecated and ignored by GTK+. The information on which day the calendar week starts is derived from the locale.</descr>
+		</issue>.
 	</widgetset>
 </package>
gtk2.issues.xml.diff (634 bytes)

Bart Broersma

2011-03-24 10:57

developer   ~0046783

I attached an diff for lcl/interfaces/gtk2/issues.xml describing the issue.
This should be enough to resolve the issue?

Bart Broersma

2011-05-08 11:01

developer   ~0048126

Reminder sent to: Vincent Snijders

Vincent, can this be resolved now?

Zeljan Rikalo

2012-01-09 17:24

developer   ~0055632

Added to issues.xml. Please close.

Issue History

Date Modified Username Field Change
2008-04-11 12:47 Graeme Geldenhuys New Issue
2008-04-11 12:47 Graeme Geldenhuys File Added: Screenshot.png
2008-04-11 12:47 Graeme Geldenhuys Widgetset => GTK
2008-04-11 12:49 Graeme Geldenhuys Note Added: 0018723
2008-04-12 09:56 Vincent Snijders LazTarget => 1.0
2008-04-12 09:56 Vincent Snijders Status new => acknowledged
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2010-12-20 13:26 Juha Manninen Note Added: 0044426
2010-12-20 13:26 Juha Manninen Relationship added related to 0010190
2010-12-20 13:28 Vincent Snijders Widgetset GTK => GTK, GTK 2
2010-12-29 18:49 Gerard V Note Added: 0044691
2010-12-29 18:49 Gerard V Note Edited: 0044691
2010-12-29 20:43 Vincent Snijders Note Added: 0044693
2011-03-24 10:56 Bart Broersma File Added: gtk2.issues.xml.diff
2011-03-24 10:57 Bart Broersma Note Added: 0046783
2011-05-08 11:01 Bart Broersma Note Added: 0048126
2011-09-24 15:19 Bart Broersma Target Version 1.0.0 => 0.99.0
2012-01-09 17:24 Zeljan Rikalo Fixed in Revision => 34684
2012-01-09 17:24 Zeljan Rikalo Status acknowledged => resolved
2012-01-09 17:24 Zeljan Rikalo Fixed in Version => 0.9.31 (SVN)
2012-01-09 17:24 Zeljan Rikalo Resolution open => fixed
2012-01-09 17:24 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-01-09 17:24 Zeljan Rikalo Note Added: 0055632