View Issue Details

IDProjectCategoryView StatusLast Update
0001128LazarusOtherpublic2005-09-29 18:34
Reporterdan marinescu Assigned ToVincent Snijders  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionduplicate 
PlatformIntel AMD (both 32 and 64 bit)OSAny Linux Unix 
Product Version0.9.8 
Summary0001128: fpc rtl cannot deal with files over 2GB!
Descriptionprogram bigfile;

var
  f: TextFile;

begin
  Assign(f, 'rez.rez');
  Rewrite(f);
  while True do
    WriteLn(f, 'Hello World');
  Close(f);
end.

The program will crash when the file rez.rez reaches 2GB. It is __NOT__ a filesystem limitation (tried JFS, ReiserFS, XFS on 64 bit machines). Proof: the following program will cross that barier:

program bigfile2;

begin
  while True do
    WriteLn('Hello World');
end.

When you go like ./bigfile2 > rez.rez
Steps To Reproducecompile bigfile & bigfile2

run ./bigfile

expected: should run over the 2GB filesize limit
actual: crashes when rez.rez reaches 2GB filesize limit

run ./bigfile2 > rez.rez

now everything is file, rez.rez grows to terabytes!

ps
this is a show stopper... issue is not in lazarus ide, it's the fpc rtl
Additional Informationif you don't have time, i can fix that, how do i get check-in rights?
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK
Attached Files

Relationships

child of 0001126 closedVincent Snijders fpc rtl cannot deal with files over 2GB! 

Activities

2005-08-27 14:40

 

bigfile.pas (228 bytes)   
program bigfile;

var
  f: TextFile;

begin
  Assign(f, 'rez.rez');
  Rewrite(f);
  while True do
    WriteLn(f, '*************************************** Hello World  ***************************************');
  Close(f);
end.

bigfile.pas (228 bytes)   

Issue History

Date Modified Username Field Change
2005-08-27 14:40 dan marinescu New Issue
2005-08-27 14:40 dan marinescu File Added: bigfile.pas
2005-08-27 14:40 dan marinescu Widgetset => GTK
2005-08-27 15:14 Vincent Snijders Target => -
2005-08-27 15:14 Vincent Snijders Relationship added duplicate of 0001026
2005-08-27 15:14 Vincent Snijders Duplicate ID 0 => 1026
2005-08-27 15:14 Vincent Snijders Status new => resolved
2005-08-27 15:14 Vincent Snijders Resolution open => duplicate
2005-08-27 15:14 Vincent Snijders Assigned To => Vincent Snijders
2005-08-27 15:33 Jesus Reyes Relationship deleted 0001026
2005-08-27 15:44 Vincent Snijders Relationship added child of 0001126
2005-09-29 18:34 Marc Weustink Status resolved => closed