View Issue Details

IDProjectCategoryView StatusLast Update
0011294LazarusLCLpublic2012-02-06 19:57
ReporterLee JenkinsAssigned ToLuiz Americo 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.25 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.31 (SVN) 
Summary0011294: TComboBox does not honor DropDownCount
DescriptionDespite setting (or keeping the default value of 8) of property DropDownCount, TComboBox will display a list of 29, 30 or more items and the dropdown is invoked.
Additional InformationDoes not seem to matter of Style property is set to csDropDown or csDropDownList.
TagsNo tags attached.
Fixed in Revision15129,15171,35188
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0020359 closedLuiz Americo Anchor Editor flickers / all controls jump around on every change 

Activities

Lee Jenkins

2008-05-13 17:47

reporter   ~0019392

Here is the definition for the combo box as well.

object cboDay: TComboBox[9]
    Left = 338
    Height = 29
    Top = 72
    Width = 136
    AutoCompleteText = [cbactEndOfLineComplete, cbactSearchAscending]
    DropDownCount = 4
    Font.Height = -16
    ItemHeight = 21
    MaxLength = 4
    Style = csDropDownList
    TabOrder = 2
  end

Vincent Snijders

2008-05-14 08:46

manager   ~0019398

I cannot reproduce this issue on windows 2000. Please upload a complete (i.e. all sources) sample application.

Vincent Snijders

2008-05-14 09:09

manager   ~0019399

Changing the dropdowncount after creation doesn't work.

Lee Jenkins

2008-05-15 15:05

reporter   ~0019420

Hi Vincent, I did not originally try to set this property after creation. I was setting it at design time. I was just commenting that it didn't have any effect by setting it in code "either". I'll put together a test application.

Vincent Snijders

2008-05-15 15:10

manager   ~0019421

Please test with r15129 or later.

2008-05-15 15:21

 

combobox_0011294.zip (9,285 bytes)

Lee Jenkins

2008-05-15 15:24

reporter   ~0019422

I have uploaded a test app. The problem only manifests itself when you select "Use manifest file to enable themes (windows only)" from:

Project > Project Options.

Tried it several times. Turn it off, the property is enforced. Turning it on, the property is not enforced.

Vincent Snijders

2008-05-15 16:20

manager   ~0019423

I only have windows 2000 now, but I tried to fix it in r15156. Can you test?

Lee Jenkins

2008-05-15 17:58

reporter   ~0019424

Tried with rev. 15156 and it still does it.

Vincent Snijders

2008-05-15 23:26

manager   ~0019429

I see that changing it after handle creating works now, just not yet the initial value.

Graeme Geldenhuys

2008-05-16 09:33

reporter   ~0019431

I'm not sure if you are only refering to the Win32 widgetset or not. I know this issue exists in GTK1 and GTK2 and was told it will not be fixed.

See the wiki page below:

http://wiki.lazarus.freepascal.org/Lazarus_known_issues_(things_that_will_never_be_fixed)

Lee Jenkins

2008-05-16 10:44

reporter   ~0019433

Graeme,

I was referring only to Win32 as I have not tried on GTK1/2 yet. Looks like on gtk its something I'll just have to live with.

Luiz Americo

2012-02-06 19:42

developer   ~0056591

Revision 29880 broke the setting of DropDownCount at runtime when themes are not enabled and leads to issue 20359.

Luiz Americo

2012-02-06 19:57

developer   ~0056595

Partially reverted 29880

Issue History

Date Modified Username Field Change
2008-05-13 17:44 Lee Jenkins New Issue
2008-05-13 17:44 Lee Jenkins Widgetset => Win32
2008-05-13 17:47 Lee Jenkins Note Added: 0019392
2008-05-14 08:46 Vincent Snijders Note Added: 0019398
2008-05-14 09:09 Vincent Snijders LazTarget => 1.0
2008-05-14 09:09 Vincent Snijders Note Added: 0019399
2008-05-14 09:09 Vincent Snijders Assigned To => Vincent Snijders
2008-05-14 09:09 Vincent Snijders Status new => confirmed
2008-05-14 09:09 Vincent Snijders Target Version => 1.0.0
2008-05-14 09:11 Vincent Snijders Fixed in Revision => 15129
2008-05-14 09:11 Vincent Snijders Status confirmed => resolved
2008-05-14 09:11 Vincent Snijders Fixed in Version => 0.9.25 (SVN)
2008-05-14 09:11 Vincent Snijders Resolution open => fixed
2008-05-15 15:05 Lee Jenkins Status resolved => feedback
2008-05-15 15:05 Lee Jenkins Resolution fixed => reopened
2008-05-15 15:05 Lee Jenkins Note Added: 0019420
2008-05-15 15:10 Vincent Snijders Note Added: 0019421
2008-05-15 15:21 Lee Jenkins File Added: combobox_0011294.zip
2008-05-15 15:24 Lee Jenkins Note Added: 0019422
2008-05-15 16:20 Vincent Snijders Note Added: 0019423
2008-05-15 17:58 Lee Jenkins Note Added: 0019424
2008-05-15 23:26 Vincent Snijders Note Added: 0019429
2008-05-16 09:33 Graeme Geldenhuys Note Added: 0019431
2008-05-16 10:44 Lee Jenkins Note Added: 0019433
2008-05-17 01:54 Vincent Snijders Fixed in Revision 15129 => 15129,15171
2008-05-17 01:54 Vincent Snijders Status feedback => resolved
2008-05-17 01:54 Vincent Snijders Resolution reopened => fixed
2008-10-16 01:06 Ivo Steinmann Status resolved => closed
2012-02-06 19:42 Luiz Americo Assigned To Vincent Snijders => Luiz Americo
2012-02-06 19:42 Luiz Americo Status closed => assigned
2012-02-06 19:42 Luiz Americo Resolution fixed => reopened
2012-02-06 19:42 Luiz Americo Note Added: 0056591
2012-02-06 19:44 Luiz Americo Relationship added related to 0020359
2012-02-06 19:57 Luiz Americo Fixed in Revision 15129,15171 => 15129,15171,35188
2012-02-06 19:57 Luiz Americo Status assigned => resolved
2012-02-06 19:57 Luiz Americo Fixed in Version 0.9.25 (SVN) => 0.9.31 (SVN)
2012-02-06 19:57 Luiz Americo Resolution reopened => fixed
2012-02-06 19:57 Luiz Americo Note Added: 0056595