View Issue Details

IDProjectCategoryView StatusLast Update
0011347FPCFCLpublic2008-10-16 01:03
ReporterLeslieAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.2.1Product Build 
Target VersionFixed in Version 
Summary0011347: ARM-WinCE - FCL does not compile
DescriptionIt has been like this for some days. (Maybe just one or two). The last time I checked with

FPC-SVN : R11051
Lazarus-SVN : R15218

Free Pascal Compiler version 2.2.1 [2008/05/22] for arm
Copyright (c) 1993-2008 by Florian Klaempfl
Target OS: WinCE for ARM
Compiling src\buildwinceunits.pp
Fatal: Internal error 200208151
Fatal: Compilation aborted


   - Leslie -

TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Leslie

2008-05-23 14:52

reporter   ~0019630

Oops, It is of course always reproducable, I have forgotten to set it.

Leslie

2008-05-23 14:53

reporter   ~0019631

Onoe more peace of information: it was compiled from the command line.

Florian

2008-05-23 22:32

administrator   ~0019651

make clean all OS_TARGET=wince CPU_TARGET=arm FPC=fpc
in fixes works for me?

The IE suggests that you might have some old units lying around?

Leslie

2008-05-24 00:50

reporter   ~0019659

Last edited: 2008-05-24 01:07

I have downloaded the SVN source again and rebuilt the crosscompiler. Could the "reversion" of the crosscomplier be the difference?

Or maybe you can see something int the command what I cannot:

make clean all CPU_TARGET=arm OS_TARGET=wince PP=ppcrossarm.exe FPC=fpc OPT="-FUQ:\Lazarus_221\fpc\2.2.1\units\arm-wince"


make -C winceunits all
make[1]: Entering directory `Q:/Lazarus_221/fpc/2.2.1/source/packages/winceunits'
fpc.exe -Twince -Parm -XParm-wince- -Xr -Ur -Fu../../rtl/units/arm-wince -FE. -FUunits/arm-wince -FUQ:\Lazarus_221\fpc\2.2.1\units\arm-wince -darm src/buildwinceunits.pp
Free Pascal Compiler version 2.2.1 [2008/05/24] for arm
Copyright (c) 1993-2008 by Florian Klaempfl
Target OS: WinCE for ARM
Compiling src\buildwinceunits.pp
Fatal: Internal error 200208151
Fatal: Compilation aborted
Error: Q:\Lazarus_221\fpc\2.2.1\bin\i386-win32\ppcrossarm.exe returned an error exitcode (normal if you did not specify a source file to be compiled)
make[1]: Leaving directory `Q:/Lazarus_221/fpc/2.2.1/source/packages/winceunits'

Florian

2008-05-24 09:12

administrator   ~0019661

Did you also clean -FUQ:\Lazarus_221\fpc\2.2.1\units\arm-wince ?

Leslie

2008-05-24 10:11

reporter   ~0019664

So easy! :)

I appretiate a lot that you guys, who are doing all the hard and complex part of FPC/Lazarus are taking your time to solve the problems the rookies come up with.

On the other hand I absulately hate it because your time is much needed for working on the project.

Thank you very much!

Florian

2008-05-24 10:20

administrator   ~0019666

You do

make clean all CPU_TARGET=arm OS_TARGET=wince PP=ppcrossarm.exe FPC=fpc OPT="-FUQ:\Lazarus_221\fpc\2.2.1\units\arm-wince"

Where does this come from? I.e. why did you add OPT="-FUQ:\Lazarus_221\fpc\2.2.1\units\arm-wince"? Does some tutorial tell so or does lazarus this?

Leslie

2008-05-24 10:41

reporter   ~0019667

Last edited: 2008-05-24 10:44

As far as I understand, the current addon installer is not capabable of building from the SVN version of the source with FPC 2.21 for ARM-WinCe, so it needs to be set up manually, and rebuilded after every update from the SVN trunk from the command line.

http://wiki.lazarus.freepascal.org/Windows_CE_Interface

Search the page for "OPT=".

Leslie

2008-05-24 10:51

reporter   ~0019668

Reading the comments of this thread I am not quite sure that I was clear enough: cleaning the target directory before building solved the problem. :)

Florian

2008-05-26 23:02

administrator   ~0019748

Yes, but using make clean all CPU_TARGET=arm OS_TARGET=wince PP=ppcrossarm.exe FPC=fpc OPT="-FUQ:\Lazarus_221\fpc\2.2.1\units\arm-wince" is not the recommended way.

Felipe Monteiro de Carvalho

2008-06-09 04:12

developer   ~0020043

The OPT="..." part is necessary because otherwise the .o and .ppu files are spread across lot's of directories and you have to move them all manually to the Lazarus installation.

Florian

2008-06-09 08:36

administrator   ~0020049

Yes, but this is exactly the problem: OPT=-FU... doesn't clean the target dir, setting COMPILER_UNITTARGETDIR does.

Florian

2008-06-12 23:40

administrator   ~0020112

Please don't advice people to use OPT=-FU... but COMPILER_UNITTARGETDIR=... instead.

Issue History

Date Modified Username Field Change
2008-05-23 14:49 Leslie New Issue
2008-05-23 14:52 Leslie Note Added: 0019630
2008-05-23 14:53 Leslie Note Added: 0019631
2008-05-23 22:32 Florian FPCTarget => -
2008-05-23 22:32 Florian Note Added: 0019651
2008-05-23 22:32 Florian Status new => feedback
2008-05-24 00:50 Leslie Note Added: 0019659
2008-05-24 01:07 Leslie Note Edited: 0019659
2008-05-24 09:12 Florian Note Added: 0019661
2008-05-24 10:11 Leslie Note Added: 0019664
2008-05-24 10:20 Florian Note Added: 0019666
2008-05-24 10:41 Leslie Note Added: 0019667
2008-05-24 10:44 Leslie Note Edited: 0019667
2008-05-24 10:51 Leslie Note Added: 0019668
2008-05-26 23:02 Florian Note Added: 0019748
2008-06-09 04:12 Felipe Monteiro de Carvalho Note Added: 0020043
2008-06-09 08:36 Florian Note Added: 0020049
2008-06-12 23:40 Florian Status feedback => resolved
2008-06-12 23:40 Florian Resolution open => no change required
2008-06-12 23:40 Florian Assigned To => Florian
2008-06-12 23:40 Florian Note Added: 0020112
2008-10-16 01:03 Ivo Steinmann Status resolved => closed