View Issue Details

IDProjectCategoryView StatusLast Update
0011386LazarusLCLpublic2011-12-01 11:24
Reporteralexander1 Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN) 
Summary0011386: TRadioGroup doesn't adjust the items correct, when size changes in OnShow
DescriptionIf you change the height in OnShow (of the form), then the items of a RadioGroup aren't adjusted correctly.

My System is a ubuntu 8.04 (64bit)
TagsNo tags attached.
Fixed in Revision26005
LazTarget1.2
WidgetsetGTK 2
Attached Files

Relationships

related to 0014877 closedPaul Ishenin radiogroup item sizing 

Activities

2008-05-31 18:26

 

Vincent Snijders

2008-05-31 22:39

manager   ~0019845

Maybe not just a gtk2 issue, but for all widgetsets.

Ales Katona

2008-06-26 17:16

developer   ~0020384

I can confirm for gtk2 at least, but I think I saw this happen on win32 too, will check that later.

Zeljan Rikalo

2010-06-09 10:49

developer   ~0038421

Lazarus 0.9.29 r26005 FPC 2.4.1 i386-linux-gtk 2 (beta). Cannot reproduce anymore, seem it's fixed during newautosize.

Issue History

Date Modified Username Field Change
2008-05-31 18:26 alexander1 New Issue
2008-05-31 18:26 alexander1 File Added: Demo Program and Screenshot.tar.gz
2008-05-31 18:26 alexander1 Widgetset => GTK 2
2008-05-31 22:39 Vincent Snijders LazTarget => 1.2
2008-05-31 22:39 Vincent Snijders Note Added: 0019845
2008-05-31 22:39 Vincent Snijders Status new => acknowledged
2008-06-26 17:16 Ales Katona Note Added: 0020384
2008-06-26 17:16 Ales Katona Status acknowledged => confirmed
2009-10-22 21:54 Vincent Snijders Relationship added related to 0014877
2010-06-09 10:49 Zeljan Rikalo Fixed in Revision => 26005
2010-06-09 10:49 Zeljan Rikalo Status confirmed => resolved
2010-06-09 10:49 Zeljan Rikalo Resolution open => fixed
2010-06-09 10:49 Zeljan Rikalo Assigned To => Zeljan Rikalo
2010-06-09 10:49 Zeljan Rikalo Note Added: 0038421
2011-12-01 11:24 Marc Weustink Status resolved => closed